[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

awstats with iis6.0

Posted on 2006-10-20
7
Medium Priority
?
1,044 Views
Last Modified: 2008-01-09
I am trying to setup awstats with iis 6.0 and I keep recieving all of my records corrupted? It keeps telling me that its an incorrect log format. In the config file I set it to 2. I do not know why this keeps happening?
0
Comment
Question by:thenone
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
7 Comments
 
LVL 9

Expert Comment

by:FixingStuff
ID: 17778987
Have you selected extended logging format and selected ONLY the columns that AWstats wants in the install doc?
Also, if you have previous logs that are not exactly setup like the install wants, delete or archive them somewhere and restart IIS.
Just did this today... worked perfect.
FS-
0
 
LVL 8

Author Comment

by:thenone
ID: 17779030
Yes but I need to know I have a custom config file format so I need to know exactly what parameters go into it such as

LogFormat = "%time2 %host %logname %method %url %code %bytesd %ua %referer"
0
 
LVL 9

Expert Comment

by:FixingStuff
ID: 17779075
Ok... is this your log column list?   if not exactly, please provide your exact IIS log format. thanks.
FS-
0
Simplify Your Workload with One Tool

How do you combat today’s intelligent hacker while managing multiple domains and platforms? By simplifying your workload with one tool. With Lunarpages hosting through Plesk Onyx, you can:

Automate SSL generation and installation with two clicks
Experience total server control

 
LVL 8

Author Comment

by:thenone
ID: 17779094
ok here it is its the same list as awstat

Date
Time
C-ip
CS-username
CS-method
cs-uri-stem
cs-uri-query
sc-status
sc-bytes
cs-version
cs-user-agent
referrer
0
 
LVL 9

Accepted Solution

by:
FixingStuff earned 1000 total points
ID: 17790374
Ok... you originally mentioned that your logformat was set to 2.... you should set your LogFormat to the following:
LogFormat="date time c-ip cs-username cs-method cs-uri-stem cs-uri-query sc-status sc-bytes cs-version cs(User-Agent) cs(Referer)"

Also, double check the following:
  your LogFile config to make sure it is pointing to the log you want.
  LogType=W
  LogSeparator=" "

Let me know how this works for you.
FS-

0
 
LVL 18

Assisted Solution

by:Sam Panwar
Sam Panwar earned 1000 total points
ID: 17793025
Hi,

This is happenning due to the Awsts configure so please install awstats through the following steps.

Installation of Awstats


1.      Download the Latest version of Awstats from following url:
(http://awstats.sourceforge.net/)

2.      Install the Awstats using Downloaded Installer. (Recommended path is c:\Awstats).

3.      Create a Directory with the name of Data at c:\Awstats.

4.      Make the configuration of log format in IIS (Windows 2003) IIS>web site>properties>website tab>Active Log format>properties>Advanced Tab.

5.      Create a virtual directory in IIS through which you can view the Awstats through Helm CP or directly by url like (http://IPAddress/awstats/cgi-bin/awstats.pl?config=domainname.com)

6.      Add update. bat file in the schedule task, update. bat will be available in ‘C:\Awstats\wwwroot\cgi-bin’, it will be daily process the log files and update the stats.

7.      Make sure check the Awstats after one or two days to make sure that your stats are updating or not because if any problem in installation then you can’t recover the old logs. If the Awstats is working fine also the c:\Awstats\data directory, it should contain a data file for each domain on which Awstats has been enabled.

8.      If you want to update the logs manually then please use following command:

c:\awstats\wwwroot\cgi-bin> Awstats.pl config=domain name -update

Some useful Links:

http://forums.webhostautomation.com/viewtopic.php?t=13388&postdays=0&postorder=asc&highlight=awstats+icon&start=0

http://forums.webhostautomation.com/viewtopic.php?t=1792&highlight=awstats

http://www.allscoop.com/tools/awstats-log-format/index.php
0
 
LVL 8

Author Comment

by:thenone
ID: 17793296
Thanks guys for your help but I figured out my problem...
0

Featured Post

Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A web service (http://en.wikipedia.org/wiki/Web_service) is a software related technology that facilitates machine-to-machine interaction over a network. This article helps beginners in creating and consuming a web service using the ColdFusion Ma…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
Suggested Courses

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question