Spamassassin is not marking messages as SPAM

ITMiami
ITMiami used Ask the Experts™
on
I just installed the spamassassin module on a Slakware 10.2 server that's usuing "Sendmail version 8.13.4, config V10/Berkeley"

I followed the steps in this article:
http://www.slackbasics.org/html/sendmail.html

the only thing I did not do is the last step to move the emails to an spam folder

But the messages still not being tagged as spam at all

Does someone knows what is missing here?

Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Sr Software Engineer
Commented:
did you restart sendmail and start spamd so that sendmail is reading the correct config and that spamd is listening so spamc can communicate to it.

check the syslog as well to see if there are any error messages there.  

btw, i've never used sendmail and have minimal experience with procmail, but i found this at sendmail.org:
http://www.sendmail.org/doc/sendmail-current/cf/README



local_procmail      Use procmail or another delivery agent as the local mailer.
            The argument to this feature is the pathname of the
            delivery agent, which defaults to PROCMAIL_MAILER_PATH.
            Note that this does NOT use PROCMAIL_MAILER_FLAGS or
            PROCMAIL_MAILER_ARGS for the local mailer; tweak
            LOCAL_MAILER_FLAGS and LOCAL_MAILER_ARGS instead, or
            specify the appropriate parameters.  When procmail is used,
            the local mailer can make use of the
            "user+indicator@local.host" syntax; normally the +indicator
            is just tossed, but by default it is passed as the -a
            argument to procmail.

            This feature can take up to three arguments:

            1. Path to the mailer program
               [default: /usr/local/bin/procmail]
            2. Argument vector including name of the program
               [default: procmail -Y -a $h -d $u]
            3. Flags for the mailer [default: SPfhn9]

            Empty arguments cause the defaults to be taken.
            Note that if you are on a system with a broken
            setreuid() call, you may need to add -f $f to the procmail
            argument vector to pass the proper sender to procmail.

            For example, this allows it to use the maildrop
            (http://www.flounder.net/~mrsam/maildrop/) mailer instead
            by specifying:

            FEATURE(`local_procmail', `/usr/local/bin/maildrop',
             `maildrop -d $u')

            or scanmails using:

            FEATURE(`local_procmail', `/usr/local/bin/scanmails')

            WARNING: This feature sets LOCAL_MAILER_FLAGS unconditionally,
            i.e.,  without respecting any definitions in an OSTYPE setting.

Author

Commented:
You got it, I restarted the box and the spamassassin is working now...

Thanks a lot
Cyclops3590Sr Software Engineer

Commented:
Glad I could help point you in the right direction.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial