opacity and filter

Refael
Refael used Ask the Experts™
on

Hi,

In an html page with a light image background I am trying to set an area with some text.
Since the text kind of fade in the light background I used opacity and filter on the text area background:

background-color:#751B8C;
opacity: .65;
filter: alpha(opacity=65);

The problem is that its also fades the text… how is it possible to have this opacity and filter not to affect the text inside?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
you should use classes. use one class to apply to the tag that uses the background, and then, use another nested tag within, which would have another class attribute, with the opacity as 100...it would look something like this

<div id="parent" class="transparentbg">
    <div id=text" class="normalbg">
        this is where you would insert the text
    </div>
</div>

the css would look like this.

.transparentbg{
    background-image: url(someImage.gif);
    opacity: .65;
    filter: alpha(opacity=65);
}

.normalbg{
    background-color:#751B8C;
    opacity: 1;
    filter: alpha(opacity=100);
}


Lemee know if this works for you

~Gary

Author

Commented:

thanks!

its applies to a td....

<td valign="top" id="parent" class="transparentbg">

the style is not with an image.....

}
.transparentbg{
background-color:#222222;
opacity: .65;
filter: alpha(opacity=65);
}

then right after the TD i added the DIV to insert the text...

<div id="text" class="normalbg">

with the style.....

.normalbg{
    background-color:#751B8C;
      color:#FFFFFF;
    opacity: 0;
    filter: alpha(opacity=100);
}

for some reason the background is changed but the the font color still fading?!?!?




Top Expert 2006
Commented:
Opacity is not inherited.  So specifying 100% opacity on an inner element will have no effect.
For a semi-transparent background, use an alpha-transparent PNG image.

For IE6, uset the background image and use a filter:
  background-image: none;
  filter:progid:DXImageTransform.Microsoft.AlphaImageLoader(enabled=true, src=background.png, sizingMethod=scale);
Top Expert 2006

Commented:
"uset" should read "unset"  :)

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial