Solved

The list of servers for this workgroup is not currently available

Posted on 2006-10-21
31
3,328 Views
Last Modified: 2011-08-18
My network consists of a cable modem, a D-Link Vonage Wireless Router, a Belkin Wireless Pre-N Router, two desktops and one notebook all running Windows XP Pro SP2. They are connected in that order. One desktop is hard wired to the Belkin router while the other desktop and the notebook function wirelessly.

All three computers can access the internet. The two desktops can access each other without any problem although the wireless desktop cannot ping itself or the notebook (timeout). They can see the notebook but cannot acces it, and trying produces the message "The network path was not found".

The notebook cannot ping itself or the wireless desktop but can ping the wired desktop and the gateway.

On the Notebook "My Network Places - View Workgroup Computers" brings up the message "The list of servers for this workgroup is not currently available." There would seem to be one setting on the notebook that needs to be changed. What is it?

I have seen and studied many of the cases with the same subject on E-E but none seem to be applicable and the solutions provided do not cure my problem.

How can I get the notebook on the network?

Karl





0
Comment
Question by:KStork
  • 13
  • 10
  • 3
  • +2
31 Comments
 
LVL 1

Expert Comment

by:Ifixthings
ID: 17781276
HI
It sounds like you have a gateway issue, as your using a Belkin router this should be set to provide IP addresses via DHCP, to enter the config on the belkin router start a webpage and enter 192.168.2.1 as the address, look for the section Lan Settings or similar, and make sure DHCP is turned on

On each PC click Start > Run  > CMD >enter and in the black box type ipconfig.

This should show  the IP address, Subnet mask and Default Gateway.

The IP address should be in the range set in the DHCP table on the router, and the default gateway should be that of the router, assuming that the PC's are set to get their IP address via DHCP, if they differ from the range then chances are you have Ip addresses set statically and you will need to change this so your PC's get an address via DHCP.

To do this in XP Start > settings> control panel> network and dialup>double click the icon for your network link >properties> TCP/IP> properties> change radio button to obtain via DHCP.

Now make sure all the PC's are in the same workgroup, right click my computer on the desk top > properties> network identification> it should show the PC name and workgroup, if any are not identical to the others (Workgroup is the norm on XP Pro) then click properties and change it.

Now dont forget that if you want to share files you will have to enable file and printer sharing and share at least one folder, this is covered in the help section of XP by searching file sharing.

Now reboot the router first then all the PC's in turn ( some say you dont need to reboot either the router or PC but I prefer to do it that way).

Regards

0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 17782315
Hmm..  well, if you any computer cannot ping it's own address, then you have something else seriously going on..  here are the 4 rules where you start your troubleshooting:

Step-1: Ping Loopback IP address (127.0.0.1). Success shows that TCP/IP is properly installed.

Step-2: Ping local NIC's IP address. Success shows that NIC is working properly.

Step-3: Ping Default Gateway. Success shows that local physical layer connections are ok.

Step-4: Ping Remote IP address. Success shows that remote physical layer connections are ok.

Depending on how the tests go will tell you what you need to look at..  might be a Winsock Catalog reset that is needed..  

netsh winsock reset catalog

Run through these and bring back the results...  Also, might be useful to see some ipconfigs from all three systems..

FE
0
 

Author Comment

by:KStork
ID: 17782628
1. The Belkin Router's Lan Setting has DHCP turned on.

2. On every computer IPConfig shows the correct IP address, Subnetmask and Default Gateway.

3. The Advanced TCP/IP Settings shows that the IP address is "DHCP enabled".

4. All computers show the same network

5. File and printer sharing is enabled on all computers.

6. I have not recently, but have previously, shut down and restarted the modem, the routers and the computers but that didn't solve the problem. The notebook could not access the network and its files could not be seen by the other two computers.

Karl
0
 
LVL 1

Expert Comment

by:Ifixthings
ID: 17783521
Hi
Just noticed, why do you have 2 routers, the vonage and the belkin ?

Surely if both are wireless capable you only need one, if its a case of not enough ports then use a Hub, this may be the problem.

0
 

Author Comment

by:KStork
ID: 17783686
Thanks for your messages.

1.  Ping of 127.0.0.1 worked fine

2.  Ping of the NIC (Network Interface Card?) with the address (192.168.2.4) assigned by the Gateway timed out.

3.  Ping of the Gateway (192.168.2.1) worked fine.

4.  Pings of several remote IP Addresses timed out but Ping of my own IP Address 72.181.43.191 worked fine.

I need the D-Link Vonage Router for VoiP but it is too slow as a wireless router. The Belkin Router works beautifully with 108 Mbps. The setup has worked before until the motherboard of the Acer Notebook was replaced.

Karl
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 17783818
http://support.microsoft.com/kb/314067

If the loopback test (127.0.0.1) succeeds but you cannot ping the local IP address, there may be an issue with the routing table or with the network adapter driver.

You might try first making sure you have the correct driver for the NIC on the motherboard, although usually this would prevent the card from working at all, it is the first step..   After that, it might be interesting to see your routing table..

http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/route.mspx?mfr=true
0
 

Author Comment

by:KStork
ID: 17784055
The Device Manager says the Intel PRO/Wireless  2200 BG Network Connection is working properly. There are no conflicts.

The Intel Driver Version is 9.0.4.13 dated 4/5/2006.

Running the route program brought the following results:

Interface List

0x1........................................................................MS TCP Loopback interface
0x2 ... 00 0e 35 84 c4 4f..........................................Intel PRO/Wireless 2200 BG Network Connection
Packet Scheduler Miniport
0x1004  ...00 0e 96 68 14 61 ...................................Bluetooth Device (Perosnal Network Area) #2

Active Routes

Network Destination               Netmask                   Gateway                   Interface                   Metric
0.0.0.0                                  0.0.0.0                     192.168.2.1              192.168.2.1               25
127.0.0.0                              255.0.0.0                  127.0.0.1                  127.0.0.1                  1
192.168.2.0                           255.255.255.0           192.168.2.4              192.168.2.4               25
192.168.2.4                           255.255.255.255       127.0.0.1                  127.0.0.1                   25
192.168.2.255                        255.255.255.255       192.168.2.4              192.168.2.4               25
224.0.0.0                               240.0.0.0                  192.168.2.4              192.168.2.4               25
255.255.255.255                    255.255.255.255        192.168.2.4              192.168.2.4               1
255.255.255.255                    255.255.255.255        192.168.2.4              10004                       1

Default Gateway                     192.168.2.1

Persistent Routes:  None

I hope you what to do with this information because I don't.

What do you think of rebuilding the TCP/IP stack?    Please see:   http://support.microsoft.com/kb/299357  

Karl
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 17788107
Try resetting the catalog first, as I mentioned above.  
0
 

Author Comment

by:KStork
ID: 17791997
Resetting that catalog did not solve my problem. I can see the network in Windows Explorer but continue to get the message that "The list of servers for this workgroup is not currently available".

IPConfig appears to be entirely normal on all three computers.

Karl
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 17792525
Try running a Route Print on the computer that is in the same subnet, and CAN access the other computers..  to see if there are any differences in the routing table..  For some reason, the problem computer cannot find the route to the other computers...
0
 

Author Comment

by:KStork
ID: 17792833
The only differences between the two computers are:

1. Where the Metric reads 25 on the troublesome computer it reads 20 on the trouble-free wireless computer.

2. The entire last line which reads 10004 for the Interface on the troublesome computer does not exist on the trouble-free wireless computer.

3. Of course, the IP Addresses of the two computers are different.

Karl
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 17795087
Well, the routing table appears good, as everything is there that should be..  including your default route..  (the metric signifies the priority of the route, and the lower the metric, the higher the priority..)  even the route for pinging the local IPAddress is there, which tells me that the local PING should work..  

I am not too sure where to go from here with this..  It could be something being injected into the packet header, or even a problem with the router..  at this point in time, if it were me, I would not hesitate to reinstall the OS and start fresh, but I certainly understand that it may be inconvenient for you..  Or, first I might install a replacement NIC in the system to eliminate that as a problem, since replacing a NIC is probably the easiest piece of hardware in a computer to replace..

FE
0
 
LVL 14

Expert Comment

by:FriarTuk
ID: 17832948
are they members of the same workgroup & do they both have enabled netbios over tcp/ip?  do a start - run - cmd - ipconfig /all & post results here for comparison.  in the meantime check out the below.

click Entire Network, Microsoft Network, click the workgroup name, you receive:
"Unable to access Computers Near Me. Workgroup is not accessible.
 The list of servers for this workgroup is not currently available."
(pc is set as a master browser, or netbios over tcp not enabled)
http://support.microsoft.com/kb/285035/en-us
0
 

Author Comment

by:KStork
ID: 17838928
FE: You are right, I don't want to re-install Windows XP SP2. However, I have ordered a new NIC. It should be here in 5 days.

FriarTuk: All three of my computers are in the same workgroup. I am using the Default NertBIOS setting in the WINS window of the "Advanced TCP/IP Setting". The MS KB 285035 applies only to Windows 2000. I am using Windows XP.

IPConfig on the problem computer gave this result:

indows IP Configuration



        Host Name . . . . . . . . . . . . : ACER

        Primary Dns Suffix  . . . . . . . :

        Node Type . . . . . . . . . . . . : Broadcast

        IP Routing Enabled. . . . . . . . : No

        WINS Proxy Enabled. . . . . . . . : No

        DNS Suffix Search List. . . . . . : Ciconia



Ethernet adapter Wireless Network Connection:



        Connection-specific DNS Suffix  . : Ciconia

        Description . . . . . . . . . . . : Intel(R) PRO/Wireless 2200BG Network Connection

        Physical Address. . . . . . . . . : 00-0E-35-84-C4-4F

        Dhcp Enabled. . . . . . . . . . . : Yes

        Autoconfiguration Enabled . . . . : Yes

        IP Address. . . . . . . . . . . . : 192.168.2.4

        Subnet Mask . . . . . . . . . . . : 255.255.255.0

        Default Gateway . . . . . . . . . : 192.168.2.1

        DHCP Server . . . . . . . . . . . : 192.168.2.1

        DNS Servers . . . . . . . . . . . : 192.168.2.1

        Lease Obtained. . . . . . . . . . : Saturday, October 30, 2004 2:08:04 AM

        Lease Expires . . . . . . . . . . : Monday, January 18, 2038 10:14:07 PM



Ethernet adapter Bluetooth Network Connection:



        Media State . . . . . . . . . . . : Media disconnected

        Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network) #2

        Physical Address. . . . . . . . . : 00-0E-9B-68-14-61

MS has a network diagnostic tool, which did not solve the problem but gave the following diagnostic:

Last diagnostic run time: 10/29/04 10:20:56 HTTP, HTTPS, FTP Diagnostic
HTTP, HTTPS, FTP connectivity

info HTTP: Successfully connected to www.microsoft.com.
warn HTTPS: Error 12037 connecting to www.microsoft.com: The date in the certificate is invalid or has expired  
warn HTTPS: Error 12037 connecting to www.passport.net: The date in the certificate is invalid or has expired  
info FTP (Passive): Successfully connected to ftp.microsoft.com.
error Could not make an HTTPS connection.
info Redirecting user to support call
 


DNS Client Diagnostic
DNS - Not a home user scenario

info Using Web Proxy: no
info Resolving name ok for (www.microsoft.com): yes
No DNS servers

DNS failure

 


Gateway Diagnostic
Gateway

info The following proxy configuration is being used by IE: Automatically Detect Settings:Disabled Automatic Configuration

Script: Proxy Server: Proxy Bypass list:  
info This computer has the following default gateway entry(ies): 192.168.2.1
info This computer has the following IP address(es): 192.168.2.4
info The default gateway is in the same subnet as this computer
info The default gateway entry is a valid unicast address
info The default gateway address was resolved via ARP in 1 try(ies)
info The default gateway was reached via ICMP Ping in 1 try(ies)
info TCP port 80 on host 207.46.19.60 was successfully reached
info The Internet host www.microsoft.com was successfully reached
info The default gateway is OK
 


IP Layer Diagnostic
Corrupted IP routing table

info The default route is valid
info The loopback route is valid
info The local host route is valid
info The local subnet route is valid
Invalid ARP cache entries

action The ARP cache has been flushed
 


IP Configuration Diagnostic
Invalid IP address

info Valid IP address detected: 192.168.2.4
 


Wireless Diagnostic
Wireless - Service disabled

Wireless - User SSID

action User input required: Specify network name or SSID
Wireless - First time setup

info The Wireless Network name (SSID) to which the user would like to connect = Ciconia.
Wireless - Radio off

info Valid IP address detected: 192.168.2.4
Wireless - Out of range

Wireless - Hardware issue

Wireless - Novice user

Wireless - Ad-hoc network

Wireless - Less preferred

Wireless - 802.1x enabled

Wireless - Configuration mismatch

Wireless - Low SNR

 


WinSock Diagnostic
WinSock status

info IrDA protocol is not found in Winsock catalog.
info All base service provider entries are present in the Winsock catalog.
info The Winsock Service provider chains are valid.
info Provider entry MSAFD Tcpip [TCP/IP] passed the loopback communication test.
info Provider entry MSAFD Tcpip [UDP/IP] passed the loopback communication test.
info Provider entry RSVP UDP Service Provider passed the loopback communication test.
info Provider entry RSVP TCP Service Provider passed the loopback communication test.
info Connectivity is valid for all Winsock service providers.
 


Network Adapter Diagnostic
Network location detection

info Using home Internet connection
Network adapter identification

info Network connection: Name=Bluetooth Network Connection, Device=Bluetooth Device (Personal Area Network) #2, MediaType=LAN,

SubMediaType=BLUETOOTH
info Network connection: Name=Local Area Connection, Device=Broadcom NetXtreme Gigabit Ethernet, MediaType=LAN,

SubMediaType=LAN
info Network connection: Name=Wireless Network Connection, Device=Intel(R) PRO/Wireless 2200BG Network Connection,

MediaType=LAN, SubMediaType=WIRELESS
info Network connection: Name=1394 Connection, Device=1394 Net Adapter #2, MediaType=LAN, SubMediaType=1394
info Both Ethernet and Wireless connections available, prompting user for selection
action User input required: Select network connection
info Wireless connection selected
Network adapter status

info Network connection status: Connected
 


HTTP, HTTPS, FTP Diagnostic
HTTP, HTTPS, FTP connectivity

info HTTP: Successfully connected to www.microsoft.com.
warn HTTPS: Error 12037 connecting to www.microsoft.com: The date in the certificate is invalid or has expired  
warn HTTPS: Error 12037 connecting to www.passport.net: The date in the certificate is invalid or has expired  
info FTP (Passive): Successfully connected to ftp.microsoft.com.
error Could not make an HTTPS connection.
 

I don't know yet what error 12037 is.  Do you see anything worth pursuing in this report?

Karl
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 17839053
Nope, I don't see anything wrong here...  

that error (warn HTTPS: Error 12037) references an invalid certificate with a bad date, or, your Calendar is not correct..  might want to ck that, just to be sure it is correct before going on..

FE
0
 

Author Comment

by:KStork
ID: 17839227
You are right. I had already found that for one reason or another the year on my computer was set to 2004. Once that was corrected the Network Diagnostic Tool reported that there were no problems but "the list of servers ..... is (still) not available".

Karl
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 17846969
Well, we fixed at least one problem here, eh?  :)

Might want to make sure you are running a synced up time with your servers...  usually you will get an error message regarding this, but make sure you are syncing with the Local Time server..
0
 

Author Comment

by:KStork
ID: 17847446
The time was automatically synchronized with NIST at 7:15 AM. When I tried to synchronize the time this evening I got the message that an error occured, that the operation had timed out.

Karl

0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 17849210
At this point, I might try moving the computers to the first router, and trying to access the shares from that point...  just for testing purposes to see if that second router is causing issues..
0
 

Author Comment

by:KStork
ID: 17850801
I moved the troublesome computer to the first router and received the same message "the list of servers ..... is (still) not available". The ping request times out, too. Let's see if the new NIC will make any difference.
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 17851736
Yea, I hope it solves the issue, as I am just out of ideas on this one..  :(
0
 
LVL 14

Expert Comment

by:FriarTuk
ID: 17865203
kb/285035/en-us is valid for xp along with 2k as it relates to enabling netbios over tcp/ip

i need to see the results of the ipconfig /all on the working computer in order to compare, it could be the node type, see below.


 browse domain from the Entire Network =
"The list of servers for this workgroup is not currently available"
http://support.microsoft.com/kb/903267/en-us      node type set to peer to peer
http://support.microsoft.com/kb/160177/en-us      node types 8 = hybrid
(1) b mode = default if no wins svr or val not specified - uses broadcasts
(2) p mode = peer2peer - uses only point-to-point name queries to a name server (WINS)
(4) m mode = mixed - broadcasts first, then queries the name server
(8) h mode = default if with wins svr - queries the name server first, then broadcasts
0
 

Author Comment

by:KStork
ID: 17865920
The IPConfig results for the other wireless computer are identical except for the host name, the Physical Address of the NIC and the IP Adress, which is 192.168.2.3 . In particular, the node type is "Broadcast" for both.

As FE recommended I have installed a Belkin Wireless Pre-N Notebook Network Card, which did not solve my problem as "the list of servers ... remains not avalable". The system is now entirely Belkin.

The two wireless computers cannot ping themselves or each other. The ping requests timed out.

Karl
0
 
LVL 14

Expert Comment

by:FriarTuk
ID: 17866201
try resetting tcp/ip
netsh int ip reset c:\resetlog.txt  (http://support.microsoft.com/?kbid=299357)
or using the tool
http://www.spychecker.com/program/winsockxpfix.html


NETSH FIREWALL RESET
NETSH WINSOCK RESET
(http://support.microsoft.com/kb/811259 how to recover from winsock2 corruption)
0
 

Author Comment

by:KStork
ID: 17867604
I have reset the TCP/IP stack and the WINSOCK several days ago and that didn't solve the problem. ZoneAlarm doesn't seem to be a problem. I have deactivated it and that made no difference.
0
 
LVL 40

Expert Comment

by:Fatal_Exception
ID: 17868492
I have seen Zonealarm linger, even if it was disabled...  it can cause issues regardless of the state it is in...
0
 

Author Comment

by:KStork
ID: 17868661
ZoneAlarm has not previously been a problem. It recognizes the network and puts it into the Trusted Zone.
0
 

Author Comment

by:KStork
ID: 19216231
Installation of the program "Network Magic" has solved the problem.
Thanks for the effort.
Karl
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 19321975
PAQed with points refunded (250)

Computer101
EE Admin
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Sometimes you might need to configure routing based not only on destination IP address, but also on a combination of destination IP address (or hostname) and destination port number. I will describe a method how to accomplish this with free tools. …
A common practice in small networks is making file sharing easy which works extremely well when intra-network security is not an issue. In essence, everyone, that is "Everyone", is given access to all of the shared files - often the entire C: drive …
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now