We help IT Professionals succeed at work.

Home Networking Workgroup Blues

Medium Priority
Last Modified: 2013-11-16
OK.  I've spent about 2 hours trying to figure this one out and I'm stuck enough to offer it up to the "gods" (Gurus on Duty!) for help!

I have a small workgroup of four computers.  The purpose is strictly for printer and file sharing.  Two are running computers running XP home and two XP pro.  All the computers can see each other in the "Show the computers in my workgroup", but the two XP home computers cannot access (nor see) the shared files, drives, or printers on one of the computers running pro (named Jane).  And when you click on Jane from the workgroup "diagram" (from "Show the computers in my workgroup"), it prompts with a domain username/password box.

I must have toggled a switch wrong somewhere, but I'm unable to decipher where!  I have disabled the Norton Firewall as well as the Windows Firewall, so what do I do next?

Thanking you in advance, mhs
Watch Question

Windows XP uses (by default) a simplified way of sharing files called 'Simple File Sharing', which allows access with as least trouble as possible. In Windows XP Pro the simple file sharing feature can be turned off, which causes Windows to use the more complex approach of username/password authentication. This allows multiple users to access shared files on your computer, each with his/her own permissions.
Suppose you're trying to access a file shared on computer A (which is XP Pro and has SFS turned off) from computer B (running XP either Home or Pro), you will get prompted for a username/password. To gain access you need to input a username/password combination with is valid on computer A (the one sharing the files) - Such as the username/password you've used to log-in to computer A (this will work only for users that have a password set - Blank passwords cannot be used for remote access on Windows XP/2003).
Alternatively you can simple re-enable the SFS feature to save yourself the trouble. Open My Computer or any folder on the XP Pro computer, select Tools -> Folder Options, go to the View tab, scroll down the Advanced Settings list and check the box that says "Use Simple File Sharing (Recommended)".


Of course!  I turned SFS off because I was dealing with permissions stuff when transferring info from an old disk and had forgotten to turn it back on!  Do I have to restart the computer for the change to take effect?



OK,  I turned SFS back on, but the only change that happened is now the xp home computers are prompted for a password for the xp pro guest account login.

Have you set a password for the guest account?


No.  The only account on Jane with a password is the Administrator account.


BTW I checked and the Guest account is OFF.

It should still work for remote access. Unlike other accounts, disabling guest only affects local logins, but you're welcome to try and enable it and see if it makes any difference. Please also try resetting the guest password to blank.
I'll try checking a bit more about this. Meanwhile, although this is remotely related, I should give you a word of warning about security. When SFS is enabled, remote users automatically authenticate using the Guest account. If it has a password, they will be prompted for it (as you are). If it does not then users are automatically granted access. The issue is that you should note that if you are connected to the internet without a firewall and have any folders shared with SFS enabled and no password set, you're actually sharing your folders with the whole world. Make sure you properly protect yourself.

Okay, I found that you should try enabling the guest account from the local users and groups snap-in rather than the user account control panel applet.
Do this:
1. click Start, right click My Computer, select Manage
2. navigate to System Tools, Local Users and Groups
3. click Users
4. in the right pane, right click Guest, select Properties
5. remove the check mark from Account is disabled
6. click OK

Principal Systems Administrator
First of all file and print sharing works much better WITH OUT SFS in Windows XP so turn it back off.
Second DO NOT ENABLE THE GUEST ACCOUNT this is a security risk.

No to get your file and print sharing to work;
Setup the same user accounts with the same passwords on each computer.  EVERY COMPUTER must have EVERY account, and the passwords for the acconts MUST BE THE SAME on each computer;

This is how you get file and print sharing to work in a work group.

You need this because with out the centralized access control in a domain each computer needs to be able to authorize each user.

I use this method in many different places and it works wonders.


Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Erik BjersPrincipal Systems Administrator

ANOTHER THING NEVER SET THE GUEST PASSWORD TO A BLANK PASSWORD, you're opening all kinds of doors for this.

Also I know remote desktop requires a password, it will not work if the account does not have a password (this is Microsoft knowing what's best for you and protecting you, but I think this time they are right)

And make sure you have your firewall configured correctly.
for Windows firewall: http://support.microsoft.com/kb/304040

if you need help with a different firewall let me know what you have and I'll see if I can help.



So, I need to add profiles for each user of the network to every computer in the home network--regardless if they are running xp home or pro?
Erik BjersPrincipal Systems Administrator

technicaly you need to add accounts (which will add the profiles), but yes, that is the only way a workgroup will work.



So, as a post script, both approaches "worked" with a couple of caveats!  

Because this is a home network connected to the internet, I felt safer with the latter approach offered by ebjers.

BUT the first approach of turning back on SFS and enabling the Guest account worked--IF you also set the local security policy to DELETE Guest from "Deny Access to this computer from the Network" on the XP pro computer.  (Read that carefully because it actually is a double negative!)

That said, I was glad to get back to some real work; and thank both ebjers as well as Chatable for all the help!  mhs
Erik BjersPrincipal Systems Administrator

I'm glad you got it working

Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.


Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.