Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1015
  • Last Modified:

FTP Server Problem

Okay I am running windows XP with service pack 1
and i am running Serv-U ftp

I have a dyndns set up at dyndns.org

I set up port forwarding on my Linksys WER54G router.

when logon, the server sees me as being there but i can't see any of the folders.

after a while it give me an error

An error occured opening that folder on the ftp server make sure you have permission to access that folder

Details the connection with the server was reset

this is my ftp log

[1] Mon 21Aug06 21:02:14 - Starting FTP Server...
[1] Mon 21Aug06 21:02:16 - FTP Server listening on port number 21, IP 192.168.1.101, 127.0.0.1
[1] Mon 21Aug06 21:02:18 - UPnP: Found device: Linksys: WRT54G (on 192.168.1.101 subnet)
[1] Mon 21Aug06 21:02:18 - UPnP: Inspecting device:  Linksys: WRT54G [70.65.132.237] (on 192.168.1.101 subnet)
[1] Mon 21Aug06 21:02:18 - UPnP: Device discovery complete: Linksys: WRT54G [70.65.132.237] (on 192.168.1.101 subnet)
[1] Mon 21Aug06 21:02:18 - UPnP: Error mapping port 21 to IP 192.168.1.101 (HTTP: 500 - UPnP: 718 - Desc: ConflictInMappingEntry)
[1] Mon 21Aug06 21:02:18 - UPnP: Successful port mapping on ports 44500-44501 to IP 192.168.1.101
[5] Mon 21Aug06 21:02:38 - (000001) Connected to 70.65.132.237 (Local address 192.168.1.101)
[5] Mon 21Aug06 21:02:38 - (000001) Closing connection
[5] Mon 21Aug06 21:02:38 - (000002) Connected to 70.65.132.237 (Local address 192.168.1.101)
[5] Mon 21Aug06 21:02:39 - (000002) Closing connection
[5] Mon 21Aug06 21:02:42 - (000003) Connected to 70.65.132.237 (Local address 192.168.1.101)
[5] Mon 21Aug06 21:02:43 - (000003) User TRACY logged in
[5] Mon 21Aug06 21:02:44 - (000004) Connected to 70.65.132.237 (Local address 192.168.1.101)
[5] Mon 21Aug06 21:02:44 - (000004) User TRACY logged in
[5] Mon 21Aug06 21:02:46 - (000004) Closing connection for user TRACY (00:00:02 connected)


any ideas??
0
hulitk
Asked:
hulitk
1 Solution
 
jasonr0025Commented:
a couple of things to try.
Under admin management of serv-u double click your user name and then click the dir tab.  Make sure you have at least read/write access to the folder.
under domain/settings click advanced tab and make sure passive mode data transfers are enabled.
If you are using third party firewall try disbling it to see if this cures the problem.  If so you need to add exceptions for ports 20 and 21.  (in and out)
Also make sure you have set up port fowarding for port 20 and 21 in your router.
If you are trying to access your server from your server via http---try accessing it from a pc in another location--seperate from your network altogether.
0
 
jasonr0025Commented:
Also under local server settings-advanced tab, uncheck auto configure upnp firewalls.  Recheck the firewall port translation settings--port 20 and 21 have to be fowarded.
hope this help.  I just finished setting up my u-ftp sever behind a pix 506e with pc-cillin.  It took some tweaking but it works great now.  If none of this helps-I will keep trying to help get yours working.
0
 
gopal_krishnaCommented:
This issue is will be resolved if you install the Microsoft Firewall client on your computer. Since if you are accessing the Outside FTP it requires Secuirty. Hence Please install the Microsoft Firewall client and check if you are able to access the site.

In order to download the Microsoft Firewall client Please access the below mentioned URL:

http://www.microsoft.com/downloads/details.aspx?FamilyID=45855498-66ba-43d3-a8f1-37837d380389&DisplayLang=en

Once you install please restart the computer and then try accessing the FTP Site.

Good luck, Get back to me if you have any issue.

regards
Gopal Krishna K
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
inbarasanCommented:
Check whether both ports 20 and 21 are open. It looks like port 20 is blocked.
0
 
jasonr0025Commented:
With all respect inbarasan, I stated that in the first post/
Thanks
0
 
hulitkAuthor Commented:
It works with an ftp program, but not with internet explorer.
0
 
giltjrCommented:
Check Internet Explorer's settings in the advanced tab.  Is see if you have "Use Passive FTP", checked.  If it is checked uncheck it.  If it unchecked, check it.

This controls which type of data connection IE will use, active or passive.  Both types use port 21 for the command/control session.  

When using active the sever uses port 20 as the source and it (the sever) inititates the connection to the client. The client listens on a random port above 1023.

When using passive the client , using a random port above 1023, connects to the sever which is listening on a random port that is abovr 1023.
0
 
PaultheBrokerCommented:
Well I'll be darned - thanks giltjr - this just solved my problem too!!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now