[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Cisco Pix 501 Natting an inside host to Outside address while using Site to Site tunnel

Posted on 2006-10-23
1
Medium Priority
?
264 Views
Last Modified: 2010-04-17
I have created a Point to Point Tunnel to a vendor.  My server's IP is 192.168.1.1.  I need to nat the server IP to the outside address of the Pix when going across the tunnel because of conflicts with vendors network IP's and mine.(192.168.1.x)

fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
access-list 120 permit tcp any host xx.xx.xx.xx eq 3389
access-list 120 permit tcp any host xx.xx.xx.xx eq pcanywhere-data
access-list 120 permit udp any host xx.xx.xx.xx eq 5631
access-list 120 permit udp any host xx.xx.xx.xx eq pcanywhere-status

access-list 80 permit ip host 192.168.1.1 host yy.yy.yy.yy

pager lines 24
icmp permit any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside xx.xx.xxx.xx 255.255.255.0
ip address inside 192.168.1.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 80
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp xx.xx.xx.xx 3389 192.168.1.1 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp xx.xx.xx.xx pcanywhere-data 192.168.1.1 pcanywhere-data netmask 255.255.255.255 0 0
static (inside,outside) udpxx.xx.xxx.xxx pcanywhere-status 192.168.1.1 pcanywhere-status netmask 255.255.255.255 0 0

static (inside,outside) tcp yy.yy.yy.yy  192.168.1.1  netmask 255.255.255.255 0 0

access-group 120 in interface outside
route outside 0.0.0.0 0.0.0.0 zz.zz.zz.zz 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set strong esp-3des esp-md5-hmac
crypto map bla 10 ipsec-isakmp
crypto map bla 10 match address 80
crypto map bla 10 set peer yy.yy.yy.zz
crypto map bla 10 set transform-set strong
crypto map bla interface outside
isakmp enable outside
isakmp key ******** address yy.yy.yy.zz netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 5
console timeout 0
dhcpd address XXXXXXXXXX inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside


THanks
0
Comment
Question by:wiseman4250
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 17791876
Remove this:
nat (inside) 0 access-list 80

Change this:
 access-list 80 permit ip host 192.168.1.1 host yy.yy.yy.yy

To this:
  no access-list 80
  access-list 80 permit ip host <outside ip> host yy.yy.yy.yy

Re-apply to the crypto map
  crypto map bla 10 match address 80

Re-apply map to interface
  crypto map bla interface outside


0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question