Solved

SQL Server Management Studio Behind a Firewall

Posted on 2006-10-23
9
454 Views
Last Modified: 2013-12-03
Hi, trying to use the SQL Server Management Studio to administer 2005 from behind a firewall.  The following documentation more or less tells me I need TCP 1433 and UDP 1434 open.  Also File and Printer Sharing.

http://msdn2.microsoft.com/en-us/library/ms175043.aspx

So I opened nearly everything I could think of.  But with just the following, I get errors logging in.

TCP 1433
UDP 1434
TCP 139
TCP 445
UDP 137
UDP 138

I can log in JUST FINE if I set the firewall to forward all ports for this IP address.  So it’s a conflict of what ports specifically I need to open.

So what is my issue?  Is it with a named instance?  I’m pretty sure the server is not running a named instance.  Just the default settings.

Other articles I found close, but not definitive to fixing the problem..

http://msdn2.microsoft.com/en-us/library/ms175483.aspx
http://msdn2.microsoft.com/en-us/library/ms177440.aspx

Thanks.
0
Comment
Question by:rebies
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 30

Expert Comment

by:nmcdermaid
ID: 17792684
>> I’m pretty sure the server is not running a named instance

You'll need to verify this. Go to the surface area configuration tool and verify that it is running TCP/IP, and also what port it is running on.
0
 
LVL 30

Expert Comment

by:nmcdermaid
ID: 17792694
Also if you type

NETSTAT -b

at the command prompt on the server it should give some clues as to what sqlserver is listening on (once you have enabled all ports and established a connection)
0
 
LVL 1

Author Comment

by:rebies
ID: 17792702
SQL Server Configuration Manager > SQL Server 2005 Network Configuration > Protocols for MSSQLSERVER > TCP/IP
Enabled

When I double click on TCP/IP and then onto the "IP Addresses" tab I see my IPs there.  IP1 is 192.168.1.123, andIP2 is 127.0.0.1 and IPALL.  TCP Dynamic Ports on all three sections is "" (null).  It's not a '0' which to me would indicate named instance, right?

Also, IP1 and IP2 are set to "Enabled: no"  But IPAll is not.  All three are using TCP Port 1433.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 30

Expert Comment

by:nmcdermaid
ID: 17792806
This is where it gets haze as I unforutnately don't use SQL2005 as much as I would like.

It sounds like everything is above board.


Can you enable all the ports, connect, and run that NETSTAT thing? You should theoretically only need to enable 1433 and 1434.
0
 
LVL 1

Author Comment

by:rebies
ID: 17793058
nmcdermaid,

Thanks.  Will check first thing in the morning.  The developer with SQL 2005 installed locally is gone now.   Though I'm positive just opening up 1433 and 1434 did not work earlier.

Just looking at netstat -b right now I see...

TCP   compname:ms-sql-s    foreigncompname:2651    established      2068    [sqlservr.exe]

I also see two "ms-wbt-server" entries" on ports 1955 and 1200.  I suspect those are remote desktop though.  [svchost.exe]

Maybe that line above explains something.  To me - why it's connected on port 2651 (which it seems to be) is a bit odd.
0
 
LVL 30

Accepted Solution

by:
nmcdermaid earned 500 total points
ID: 17793719
Yes that is odd.. the next thing to try of course is close all the ports again and open the ones you already posted, as well as 2068

Its possible that he installed SQL2005 express as a named instance in which case it wouldbe on a different port.
0
 
LVL 1

Author Comment

by:rebies
ID: 17805936
Thanks for the help nmcdermaid!  I have not fixed the issue, but for the time being have opened all ports.
0
 
LVL 30

Expert Comment

by:nmcdermaid
ID: 17810709
Did opening just 2068 fix it or have you run out of time to try it?
0
 
LVL 1

Author Comment

by:rebies
ID: 17814881
I tried that and it did not work.  I actually wound up having more important things to do and have not gotten back to working on / fixing this issue.

Thanks for the help on this though!
0

Featured Post

[Webinar] Code, Load, and Grow

Managing multiple websites, servers, applications, and security on a daily basis? Join us for a webinar on May 25th to learn how to simplify administration and management of virtual hosts for IT admins, create a secure environment, and deploy code more effectively and frequently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to reset the password of the sa account on a Microsoft SQL Server.  The steps in this article work in SQL 2005, 2008, 2008 R2, 2012, 2014 and 2016.
JSON is being used more and more, besides XML, and you surely wanted to parse the data out into SQL instead of doing it in some Javascript. The below function in SQL Server can do the job for you, returning a quick table with the parsed data.
This video shows, step by step, how to configure Oracle Heterogeneous Services via the Generic Gateway Agent in order to make a connection from an Oracle session and access a remote SQL Server database table.
Viewers will learn how to use the INSERT statement to insert data into their tables. It will also introduce the NULL statement, to show them what happens when no value is giving for any given column.

732 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question