Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions

CD Rom no work!!

Posted on 2006-10-24
Last Modified: 2010-04-26
My computer's CD rom is not being recognized. I unstalled and reinstalled with no luck. I'm getting error: Windows successfully loaded the device driver for this hardware but cannot find the hardware device. (Code 41). HELP!!

Accepted Solution

bcohea earned 340 total points
ID: 17793947
PSYCHOBETTY, if this is Windows XP open the registry (Start > Run > regedit) and navigate to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

and delete the UpperFilters and LowerFilters values. Then go to the Device Manager (Start > Run > devmgmt.msc) and uninstall the CDROM again and reboot and see if it reinstalls.


Author Comment

ID: 17794234
The CD rom loaded and I used it. When I rebooted and clicked on the Cd rom in "MY COMPUTER" I get the error: The request could not be performed because of an I/O  device error.

Expert Comment

ID: 17794292
So it worked at first after editing the registry and now it doesn't? Well at any rate, take a look at this page, it may help with your new error:

If that doesn't help try to move the CDROM to another entire IDE channel and/or replace with another IDE cable. Let us know...

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.


Author Comment

ID: 17794376
My reg only had the Upperfilter not the lower, and I deleted the whole thing. Was that right or should I have opened it and space out the bottom value? I will check the link. I have tried 3 diff CD roms and 2 diff cables. No go. Thanks

Expert Comment

ID: 17794409
If you right-clicked on the word "Upperfilter" and clicked delete, that was correct.

About the IDE channels, have you tried a completely different channel? And by this I mean have you tried to disconnect the IDE cable from the mainboard and connect it to the OTHER IDE port? If you are using an IDE Hard Disk Drive, that will not be available, so just set up the HDD jumpered as "Master" and the CDROM jumpered as "Slave". Put the HDD on the VERY END of the cable and the CDROM in the middle. If you have SATA HDDs then just connect the CDROM's IDE cable to the other IDE port on your mainboard.

If this helps it may be that one of your mainboard's IDE channels is failing.

Oh, and I can't believe I am just thinking of this (it must be late) but is the CDROM jumpered correctly in the first place?


Expert Comment

ID: 17795201
I would definately check the jumpers and make sure it is jumpered correctly (I think I would have checked this out before changing the reg file, but no harm).  If this is ok,  I would guess that you have a faulty cd drive and would go out and buy a new one,  for $30 it's probably a fairly cheap solution versus hours of troubleshooting.  In the past,  I have had a few cd drives fail after a few uses, and after hours of troubleshooting, ended up just replacing the drive.  

Expert Comment

ID: 17797754
First, try to boot of the CD-ROM drive. Use the Windows XP cd or any other bootable cd. That is an easy way to see if your drive is working and properly connected.

If you are able to boot properly, then you have a software issue. Most likely it is since you removed the UpperFilters and it was detected but now says I/O error. It is just a tought.

Hope this is helpful.

Assisted Solution

chihs earned 160 total points
ID: 17801332
It seems the IDE port of motherboard issue, please to change to plug the cable to another port on motherboard to test,  

If you are often to plug and unplug the IDE cable of CD-ROM, you can to check the golden pin of IDE port, make sure every pins are well and both side of cable are connect firmly.


Author Comment

ID: 17827874
I have the CD rom on secondary IDE master,the jumpers are correct. I can take the CD rom and cable and put it on another computer and it installs and works, no problem. The problem computer would load the driver and it would show up in properties as Sony  CD-RW CR1851E and then I would get the errors. Here's what happened,  I reinstalled again and picked the driver that said "CD ROM" not the Sony driver (although is shows up as a Sony CD rom  CR1851E ) and it has been working to this day. I guess it needed a kick start..

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Does your iMac really need a hardware upgrade? Will upgrading RAM speed-up your computer? If yes, then how can you proceed? Upgrading RAM in your iMac is not as simple as it may seem. This article will help you in getting and installing right RA…
Stuck in voice control mode on your Amazon Firestick?  Here is how to turn it off!!!
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question