Solved

Make Exchange 2003 SP2 send ALL outgoing mail via www.authsmtp.com

Posted on 2006-10-24
20
1,161 Views
Last Modified: 2008-01-09
Hello. I run SBS2003 R2 and since we implemented it 2 months ago a lot of outgoing emails are being rejected by customer's mail servers viz ...

Your message did not reach some or all of the intended recipients.

      Subject:      RE:
      Sent:      24/10/2006 12:14

The following recipient(s) could not be reached:

      Linda Mogort-Valls on 24/10/2006 12:14
            There was a SMTP communication problem with the recipient's email server.  Please contact your system administrator.
            <sbs2003.Sandhills.local #5.5.0 smtp;550 Spam score too high (score 10.7)>

Prior to this we were just using Outlook and www.authsmtp.com to send mail (i.e. there was no Exchange) and we never had a problem.

Reference to ... http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_22035242.html
this previous question answered my point about why we were now being treated as spam, and what the solution is ...
BUT ...

Can anyone take me through EXACTLY how to configure the SMTP connector to send ALL mail via authsmtp.com (it will need authentication when it reaches authsmtp.com) as I can't afford to muck up our live environment.

Especially, is it necessary to create a new connector as a) we only run one Exchange 2003 server and will never run more and b) ALL outgoing emails will go via authsmtp.com ...?? can we not just configure the existing SMTP connector?

I'm a little nervous about experimenting as you can see! But I'm getting too many customer emails not being delivered so have to do something.
0
Comment
Question by:MPSmith4258
  • 7
  • 5
  • 4
  • +1
20 Comments
 

Author Comment

by:MPSmith4258
Comment Utility
Oh, as a follow up, as I said we never had a problem before sending through www.authsmtp.com when we just had a local Outlook (no Exchange) environment, but would you agree with me that all recipients will very likely see emails coming through www.authsmtp.com as a trusted source?
0
 
LVL 39

Expert Comment

by:redseatechnologies
Comment Utility
Hi MPSmith4258,

They have an online help guide for that here;

http://www.authsmtp.com/exchange-2003/index.html

6 steps, looks pretty straight forward (and they say they have tested it)

Hope that helps,

-red
0
 
LVL 39

Expert Comment

by:redseatechnologies
Comment Utility
MPSmith4258,

If you never had a problem sending through authsmtp.com before, then sending through them now using exchange would be just as effective.

Having never used or heard of them, I am making this assumption from _your_ previous experience with them

-red
0
 
LVL 9

Expert Comment

by:olifarago
Comment Utility
Hi MPSmith4258,

OK, to do this:

1. In System Manager Expand your server, then protocols, then SMTP
2. Right click on Default SMTP Virtual Server and select properties.
3. Select the delivery tab.
4. Click advanced in the bottom right.
5. Under Smart Host enter in the SMTP server details that you are sending though and click OK.
6. Click Outbound security.
7. Select Basic Authentication.
8. Enter you username and password for AuthSMTP
9. Click OK, and OK.
10. Restart the SMTP service

Hope this Helps,
Oli
0
 
LVL 9

Expert Comment

by:olifarago
Comment Utility
I have worked for clients who use the AuthSMTP service so they could send email no matter where they connected from in the world and have never had any problems.
0
 
LVL 104

Accepted Solution

by:
Sembee earned 500 total points
Comment Utility
This is SBS. Therefore the responses above about where to configure Exchange to use a smart host are wrong.

Remember the GOLDEN RULE with SBS.

ALWAYS USE THE WIZARDS.

DO NOT ATTEMPT TO CONFIGURE ANYTHING IN SBS BY HAND.

Therefore if you need to relay your email out through the another server there is only way way to configure it.
Use the Internet and Email wizard and change the settings midway through to send email out through another host. SBS will then do the rest.

It is generally considered bad practise to configure the smart host directly on the SMTP virtual server as it can cause problems with internal email delivery. Always use an SMTP Connector so that the native SMTP virtual server is left in its default state. This is particularly true when using SBS as the wizard will not clear those settings.

Simon.
0
 

Author Comment

by:MPSmith4258
Comment Utility
Dear Simon,

Point taken, but the Wizard does not seem to allow specification of user name and password as an option on the section "Configure How to Send Mail to the Internet" ... I can type in the address of the external receiving email server (mail.authsmtp.com) only.
Would you suggest I plug ahead with the wizard, and then afterwards edit the connector to add the authentication details?
Will there be another connector in addition to the current default one after running the wizard?
I'm not too fussed if internal mail gets routed through an external server and then back in again, but it would be better if it did'nt. Is that one of the reasons for doing it the Wizard way?

Cheers!!,
0
 
LVL 39

Expert Comment

by:redseatechnologies
Comment Utility
I think I would do it manually, but I am a bit of a cowboy when it comes to SBS and her wizards.

Although, for a simple smarthost, it isn't going to cause a heap of problems (like say not using the wizard to create users or join computers to the domain).

Still, you have to realise that SBS can get awfully stroppy if things are not just so.
0
 
LVL 9

Expert Comment

by:olifarago
Comment Utility
Simon,

I agree with you RE using the SBS wizards where possible but the SBS does not ask for authentication details does it?

However your comment that it is bnad practice to edit the main SMTP connector I would defiantely disagee, MS themselves recommend that if all mail to external domain is routed through a smart host then to use this method (SEE: http://support.microsoft.com/kb/821911 )

Only when splitting certain mail through smart hosts would you need to use additional connectors.

Oli
0
 
LVL 104

Expert Comment

by:Sembee
Comment Utility
I was waiting for someone to throw that KB article back at me. The MVPs have asked Microsoft to remove that recommendation a number of times. The smart host setting on the SMTP virtual server causes nothing but problems, plus people forget it is there. The best practise you will get from anyone who works in the field with Exchange is to use an SMTP Connector.

Once you have done as many migrations as I have, plus worked through them with people on this site, you will soon realise why the recommendation to use an SMTP Connector is so heavily pushed. The number one reason for a migration to a new server failing is a smart host on the SMTP virtual server, because it overrides everything else.

Microsoft also provide instructions on how to put Exchange in to a DMZ, and that is widely regarding as a very stupid thing to do.

I haven't got my SBS system on at the moment, but I believe wizard does ask if you need to authenticate to the smart host. Even if it doesn't, you should modify the smtp connector, rather than set it on the SMTP virtual server.

Simon.
0
The curse of the end user strikes again      

You’ve updated all your end user’s email signatures. Hooray! But guess what? They’re playing around with the HTML, adding stupid taglines and ruining the imagery. Find out how you can save your signatures from end users today.

 

Author Comment

by:MPSmith4258
Comment Utility
Dear Simon, I will run the Wizard tonight when my users have left for the day. Just to recap, I run the wizard, accepting all the defaults already there, excepting the one regarding Configuring Outgoing Email, where I put in mail.authsmtp.com. Assuming that works fine, but it does not ask for the additional authentication details at that point, I click Finish, wait for the wizard to crunch through, then go to Connectors in Exchange and edit the authentication settings of the new connector created by the wizard. Presumably I should restart this service? I assume that at that point all mail NOT to internal recipients will go through that new connector.
Does this sound right? Please let me know if not!!!
Many thanks, and thanks (so far) to Red and Oli.
0
 
LVL 104

Expert Comment

by:Sembee
Comment Utility
That is all there is. No need to restart the services as Exchange will start using the new configuration almost immediately. You can actually make the change during the day. The worst thing that will happen is that email will start to queue.

If you give me a few hours I can probably boot up my SBS environment and see what it says. I have Exchange 2007 running at the moment and the server they are on cannot cope with both running at the same time.

Simon.
0
 

Author Comment

by:MPSmith4258
Comment Utility
Simon, that would be great. Look fwd to hearing from you! I won't do anything ehre for at least 5 hours or so ...
0
 
LVL 9

Expert Comment

by:olifarago
Comment Utility
OK, I can certainly see your point about people not realising the setting was there, and only checking the connectors have seen that happen more than once!  Silly me for trusting the MS KB for reommendations :)

oli
0
 
LVL 9

Expert Comment

by:olifarago
Comment Utility
I just ran through the wizard on an SBS I have over here and it doesnt ask for the authentication details, you just change the radio box to use smart host, and enter the server and then it just moves through the rest of the wizard.  It then adds the SMTP connector with the smart host so you will have to manually add the authentication details.
0
 

Author Comment

by:MPSmith4258
Comment Utility
Thanks Oli
0
 

Author Comment

by:MPSmith4258
Comment Utility
Hi Simon, Oli

I ran the wizard, all ran smoothly (I think!) although it did not ask for authentication details for the external mail server - but when looking at my connectors after the wizard finished, there was no new connector just the original "Small Business SMTP Connector" but the wizard had filled in the details for my new relay server rather than direct sending (DNS)!!!
I filled in the authentication details and so far so good, as in authsmtp.com's control panel shows all my outgoing messages relaying succesfully.
One just hopes my sensitive recipients now accept us properly!

So Simon it seems that the wizard itself is happy with amending the default connector. Would you advise me to leave things as they are now, or explore further creating another connector? I know what I'd rather do!

Cheers to all
0
 
LVL 104

Expert Comment

by:Sembee
Comment Utility
As its SBS, leave it alone. What you have seen is what I would expect.

Simon.
0
 

Author Comment

by:MPSmith4258
Comment Utility
Thanks to all for your help, have given points to Simon as I did follow his solution and I needed the guaranteed low risk kosher way of doing it!
0
 
LVL 39

Expert Comment

by:redseatechnologies
Comment Utility
That is fine with me, Sembee provided the best instructions, and I'm glad to hear you got it sorted.

-red
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

Resolve Outlook connectivity issues after moving mailbox to new Exchange 2016 server
Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now