Solved

Cannot connect to ProFtpd in Passive Mode

Posted on 2006-10-24
3
3,156 Views
Last Modified: 2013-12-23
I am using CoreFTP lite to connect to my FTP server in passive mode and I get something like (I am not behind a firewall):

Connect socket #660 to 66.117.23.50, port 21...
220 ProFTPD 1.2.10 Server (ProFTPD) [66.117.23.50]  
USER ftpuser
331 Password required for ftpuser.  
PASS **********  
230 User ftpuser logged in.  
SYST  
215 UNIX Type: L8  
Keep alive off...
PWD  
257 "/" is current directory.  
PASV  
227 Entering Passive Mode (66,117,23,50,238,146).  
LIST  
Connect socket #652 to 66.117.23.50, port 61074...
timeout
QUIT  

(P.S. Real IP is not being used)

However unchecking passive mode in FTP client allows FTP connections *AND* passive mode connections over SFTP (port 22) do work !

Issue is: I need to enable passive connections over plain FTP (port 21), because I am using a backup script that only works in passive mode.
0
Comment
Question by:agubaira
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 

Author Comment

by:agubaira
ID: 17795895
Passive ports in proftpd are defined like this:

# Port 21 is the standard FTP port.
Port                            21
PassivePorts                    60000 65000
0
 
LVL 43

Accepted Solution

by:
ravenpl earned 250 total points
ID: 17801454
> *AND* passive mode connections over SFTP (port 22) do work !
there's no such thing - really! Even if passv command works - does nothing!
http://slacksite.com/other/ftp.html Here You have explanation how passive works, and what needs to be done on server's side firewall.
You propably have closed (on firewall from server side) all ports above 1024 (or only some are open). You need to open ports beeing used by proftpd as passive listening ports. As agubaira said - You don't have to allow every port >1024 as You can define some range for use by ftpd.
0
 

Author Comment

by:agubaira
ID: 17815546
Thanks for your help ! It was Plesk's firewall blocking those ports.

Antonio
0

Featured Post

Revamp Your Training Process

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
I had an issue with InstallShield not being able to use Computer Browser service on Windows Server 2012. Here is the solution I found.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
Suggested Courses
Course of the Month8 days, 21 hours left to enroll

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question