SBS not giving users a mailbox

Posted on 2006-10-24
Last Modified: 2012-05-05
I have recently set up our new server, running SBS 2003 with Exchange. I have successfully created all the required users to date and given them mailboxes, etc. Now I go to create a new user, they are not given any Exchange rights, no email address/logon, etc. Any clues on what I can do to give them these?

Many thanks
Question by:mew6ov
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
LVL 39

Expert Comment

ID: 17795893
Hi mew6ov,

How long are you waiting after creating the user?

It will take up to 15 minutes for the RUS to stamp the new accounts

And, the obligatory SBS Q, did you use the wizard to create this new user?

Hope that helps,


Author Comment

ID: 17795929
Thanks for the quick reply!

I have waited longer than 15 minutes on one of them, definately.

Would it still not come up in the storage groups under members if this was the case?

And yes, I did use the wizard to create it. But if I click on properties on the specific user, it still doesn't show any email addresses?
LVL 39

Expert Comment

ID: 17799478
If email address details are not being given to the new accounts, then the RUS is not stamping it.

Here are two guides to troubleshoot it;

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!


Author Comment

ID: 17811488
I've had a look at these, but can't make head nor tail of them!

I downloaded SP2 for exchange, but I don't know if it's installed properly.

Any ideas?!
LVL 39

Accepted Solution

redseatechnologies earned 500 total points
ID: 17815090

If the RUS is not working, then SP2 will do little to fix it (but should be installed anyway, did you install SP2 for Exchange?)

Here are the release notes, the only real "gotcha" is that you have to uninstall any existing versions of IMF lower than 2.0 ->

This guide to troubleshooting the RUS has much of the same info above, but also starts with a description and is written a little better


Author Comment

ID: 17818558
After digging a bit more, I did find something that helped me from your previous links.

Many thanks for your help!
LVL 39

Expert Comment

ID: 17818770
You are most welcome,

What was it that helped you?


Featured Post

Enroll in May's Course of the Month

May’s Course of the Month is now available! Experts Exchange’s Premium Members and Team Accounts have access to a complimentary course each month as part of their membership—an extra way to increase training and boost professional development.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
In-place Upgrading Dirsync to Azure AD Connect
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
This video discusses moving either the default database or any database to a new volume.

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question