We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Installing Redhat 4 without basic X Windows

newgentechnologies
on
Medium Priority
586 Views
Last Modified: 2013-12-15
We have gone through and tried installing Redhat 4 with a bare install, no packages or GUI options selected. After the install on boot, loading up the OS, it goes to a very basic X Windows type system. Any idea why this might be happening?


Thanks.
Comment
Watch Question

Top Expert 2005

Commented:
Many applications, even if they don't use X directly need some X libraries (ie they changing xterm titlebar).
Therefore some part of X system is always installed. You may try uninstall it by hand after the system is installed.
Also, if Your system run in X mode at startup, then You have checked something from X envinronment during install. You can revery it back by editing /etc/inittab file. Find line like
id:5:initdefault:
change to
id:3:initdefault:
and reboot (or issue: telinit q)
Commented:
if you want the system to boot with a non-GUI option, then change the file

/etc/inittab

change the default boot option to 3 in line

id:5:initdefault

to read something like

id:3:initdefault

this will make the system boot in a command line mode or a non-gui mode.

make sure that the xdm is running on level 5 in the line
x:5:respawn:/etc/X11/prefdm

which means that the GUI is running level 5 but you want the system to boot in default level 3 which is non GUI for you.

probably you tried to install a base level, and chose some package that had a X dependency which got automatically resolved at installation time and redhat installation by default makes the system boot in GUI mode (if you had clicked next on most of the options in install time)

goutham

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Or:

-- you could just go into /etc/rc.d folders for your default runlevel (runlevel 3, i think, so that'd be rc3.d, but you could do ~2 and ~4 just to be safe) and change all entries starting with "S--X11" or "S91xserver" or whatever you've got and change the "S" to a "K"

-- just try and un-install your xserver hardware, and see if you get any dependency conflicts.  If you don't, then fine -- take it off.  If you do, then investigate whether or not you really need to have that functionality present.

-- Similar to the above, you could simply disable all kdm, xdm, and gdm entries by changing them, instead, to a "K".  Your xserver won't initialize, then.

Queries about your hardware will take the form:

$ yum list all [your-favorite-regexpression-here]

So you could do something like this:

$ yum list all *xorg*

and

$ yum list all *x11*  // <=== this one you might want to try changin the x to uppercase, as well

to see what sort of Xserver software you've got installed.  Then, after examining what you've got, you can just go through it all and take off what you don't need.

Still, it sounds like what's happened is y'all unwittingly chose some sort of package that requires and X *environment* to work, and so Fedora's gone and isntalled the entire xserver package because there's no other way to resolve the dependencies that package triggered.  So my guess is that you are going to need to review your installation and track down the packages that called up the xserver installation to see if you really need them (and it).
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.