Solved

Laserjet network printer setup in AIX...

Posted on 2006-10-24
7
7,684 Views
Last Modified: 2013-11-17
I need some help setting up a network printer in AIX. Everytime I set it up it prints one job and then the print queue goes down and can not be brought back up. This is happening on all three of my brand new HP Laserjet 4240n printers, My older HP Laserjet 1012n, and my old IBM NP17. I am not sure what I am doing wrong if anything and would like to see a step by step for setting up a network printer in AIX. I have searched google and found nothing that catches my eye. Hopefully there is an expert here. I am sure there is... Speak up please Mr. Expert.
0
Comment
Question by:_SKIN_
  • 3
7 Comments
 
LVL 4

Expert Comment

by:robertfwoods
ID: 17798519
Well first of all we will require some more background:

1)  What version of AIX?
2)  What printing environment? At AIX 5.3 your choices are PowerPC print subsystem or System V print subsystem.
3)  You asked about "network printer". Can we assume that these printers are available on your TCP/IP network and are connected using HP JetDirect protocol? (Just asking. I have seen laser jet printers connected serially with terminal servers cause these kind of problems :-) ).
4)  If they are available on the network, do you have them in your /etc/hosts file or are you resolving names using DNS?
5)  Can you ping or telnet to the printer?

Regards
0
 
LVL 4

Accepted Solution

by:
robertfwoods earned 250 total points
ID: 17798686
The following is my personal resource document for AIX printing: (Please excuse the links. I could not figure out how to imbed them as hyperlinks.)

The following IBM Red Books will be of great assistance:

Printing for Fun and Profit in AIX 5L SG24-6018-00
http://www.redbooks.ibm.com/abstracts/sg246018.html?Open

Problem Solving and Troubleshooting in AIX 5L  SG24-5496-01 (See Chapter 12)
http://www.redbooks.ibm.com/abstracts/sg245496.html?Open

AIX and Linux Interoperabilty SG24-6622-00 (See Chapter 11)
http://www.redbooks.ibm.com/abstracts/sg246622.html?Open

The Redbook home page. Be sure to search here if you have need for practical guidance to complex AIX configuration questions. Suggested bookmark.
http://www.redbooks.ibm.com/

AIX Printing System V Labs for AIX 5.1. While this lab is a bit dated, you will find a great deal of interest and help.

1.      Lab 0  AIX System V Printing - Changing to the System V Print System: Lab 0
2.      Lab 1  AIX System V Printing - Adding a System V Printer From the Command Line: Lab 1
3.      Lab 2  AIX System V Printing - System V Filters: Lab 2
4.      Lab 3  AIX System V Printing - Interface Scripts: Lab 3
5.      Lab 4  System V Printing in AIX 5 - lpr/lpd remote printing: Lab 4
6.      Lab 5  System V Printing - Adding a JetDirect Printer: Lab 5


In case the hyperlinks for the labs above do not work for you the full url’s follow:

Lab 0
http://www-1.ibm.com/support/docview.wss?rs=0&q1=AIX+System+V+Printing+lab&uid=isg3T1000454&loc=en_US&cs=utf-8&cc=us&lang=en

lab 1
http://www-1.ibm.com/support/docview.wss?uid=isg3T1000455

lab 2
http://www-1.ibm.com/support/docview.wss?rs=0&q1=system+V+printing&uid=isg3T1000456&loc=en_US&cs=utf-8&cc=us&lang=en

lab 3
http://www-1.ibm.com/support/docview.wss?rs=0&q1=system+V+printing&uid=isg3T1000457&loc=en_US&cs=utf-8&cc=us&lang=en

lab 4
http://www-1.ibm.com/support/docview.wss?rs=0&q1=AIX+System+V+Printing+lab&uid=isg3T1000458&loc=en_US&cs=utf-8&cc=us&lang=en

lab 5
http://www-1.ibm.com/support/docview.wss?rs=0&q1=AIX+System+V+Printing+lab&uid=isg3T1000460&loc=en_US&cs=utf-8&cc=us&lang=en

0
 

Author Comment

by:_SKIN_
ID: 17798729
1. 4.3.3.0
2. ???
3. Yes, they are network printers, they are HP JetDirect.
4. I have modified the AIX etc/hosts file with vi editor. I am not using DNS yet.
5. Yes I can ping and telnet to the printer.
0
 
LVL 4

Expert Comment

by:robertfwoods
ID: 17803458
All of that may not been to helpful since you are on 4.3.3.0.

The IBM documentation for AIX 4.3 is still available on-line, it is a bit hard to find though. Use the following link for 4.3 manuals.

http://publib16.boulder.ibm.com/pseries/en_US/infocenter/base/aix43.htm?lang=en_US&viewset=AIX&config=/usr/share/man/info/en_US/a_doc_lib/data/base.cfg

Your system has a file for the configuration of your printers. The stanzas in mine read as follows:

==================================================
hp2100:
       device = hp@hp2100
hp@hp2100:
       file = /var/spool/lpd/pio/@local/dev/hp@hp2100#hpJetDirect#9100
       header = never
       trailer = never
       access = both
       backend = /usr/lib/lpd/pio/etc/piojetd hp2100 9100
hp2101:
       device = hp@hp2101
hp@hp2101:
       file = /var/spool/lpd/pio/@local/dev/hp@hp2101#hpJetDirect#9100
       header = never
       trailer = never
       access = both
       backend = /usr/lib/lpd/pio/etc/piojetd hp2101 9100
=================================================

Look at your qconfig file. Find the stanza for the printer in question and post it in the thread.

There are two commands to use for managing the print queues, disable and enable. They will make a queue down and ready. Have you tried them when the queue errors out?

I forced an error on my configuration and received the following message from the spooler to the user that actually sent the job to the printer:

=========================================
Message from root on hawk (UNKNOWN) [Wed Oct 25 06:22:57 MDT 2006] ...
Message from queuing system:
0782-648 piohpnpf: connection reset by peer
<EOT>

Message from root on hawk (UNKNOWN) [Wed Oct 25 06:22:57 MDT 2006] ...
Message from queuing system:
0781-088 Queue hp2100:hp@hp2100 went down, job is still queued:
 Backend: /usr/lib/lpd/pio/etc/piojetd hp2100 9100 /var/spool/qdaemon/t4DkjMa
 Backend Exit Value: EXITFATAL (0100)
 Job Submit Time: Oct 25 06:09:24 2006.  Current Time: Oct 25 06:22:57 2006
Use local problem reporting procedures.
<EOT>

:root:/# lpstat
Queue   Dev   Status    Job Files              User         PP %   Blks  Cp Rnk
------- ----- --------- --- ------------------ ---------- ---- -- ----- --- ---
hp2100  hp@hp DOWN
             QUEUED     74 STDIN.10396        root                 994   1   1
hp2101  hp@hp DOWN
=========================================


But I could find nothing in the error log.

I did find in the configuration of the spool queue a diagnostic flag. I have not experimented with this but you might try it to see if you get any helpful clues.


=========================================
Use smit spooler and select from the menu:
Change / Show Print Queue Characteristics

enter the queue name

Move cursor to desired item and press Enter.

 1 Printer Setup
 2 Default Print Job Attributes
 3 Accounting File
 4 Queuing Discipline


select # 2 from above menu

scroll down to the Diagnostic level prompt and hit F4

                           DIAGNOSTIC LEVEL

Move cursor to desired item and press Enter. Use arrow keys to scroll.

 (diag1) - do not print job; display main pipeline and pre-processing f
 (diag2) - do not print job; display all pipelines and filters
 (display) - print job; display all pipelines and filters
 (ignore) - print job; ignore stderr produced by filters
 (normal) - print job; exit if filters produce stderr
=========================================








0
 
LVL 61

Assisted Solution

by:gheist
gheist earned 250 total points
ID: 17875814
First of all you have to install LaserJet backent and LaserJet driver - smitty menus allow to configure them even while not installed, but it simplu does not print.. in short: install form system CD-s printers.* after that done every printing menu works as redbook describe.

0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Attention: This article will no longer be maintained. If you have any questions, please feel free to mail me. jgh@FreeBSD.org Please see http://www.freebsd.org/doc/en_US.ISO8859-1/articles/freebsd-update-server/ for the updated article. It is avail…
Java performance on Solaris - Managing CPUs There are various resource controls in operating system which directly/indirectly influence the performance of application. one of the most important resource controls is "CPU".   In a multithreaded…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now