Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Solaris 9 and Parallels cannot find boot.bin during installation

Posted on 2006-10-24
12
1,658 Views
Last Modified: 2013-12-21
I installed Parallels on my XP system.  I set up a Solaris 9 Virtual Machine with the following settings:


Guest OS: Solaris 9
Acceleration: High
Boot Sequence: CDROM, Hard Disk, Floppy
Auto Start: Off
Memory: 512MB
Hard Disk 1: 12000MB
CD/DVD ROM: D:
Network Adapter: Bridged


When I start the VM it boots into the configuration assistant and tells me "Cannot find boot.bin."

I installed it via Virtual PC yesterday and it worked fine except that I couldn't get the NIC to work... any suggestions on getting this to work in Parallels?  I know it's possible, so it must be my hardware Iguess....
0
Comment
Question by:ParadiseITS
  • 6
  • 6
12 Comments
 
LVL 10

Expert Comment

by:Nukfror
ID: 17802740
Why are you using Solaris 9 x86 .... sssssooo not sheek.

Use Solaris 10 x64.  I running it under Parallels on Mac OX X 10.4.8 on a MacBook Pro.  Works great.  Also be sure to the LATEST version of Parallels.  I believe the latest is Build 1940, Oct 11, 2006.  This fixes some problem found with booting Solaris 10.  Even got Solaris 10 Neveda build 50 installed - looking to play around with LAE and get Centos loaded in a Linux branded zone - on a Mac no less - soo freak'n cool !!!! ;)

The NIC driver is on the Parallels Tools iso image.  You need to attach the Parallels ISO image to the running Guest OS and then go into the mounted ISO and goto the drivers/network/rtl(some number I can't remember)/solaris.  The are some files here with one being call network.sh or netinstall.sh (can't remember).  This script installs the ni driver so your network interface under Parallels will be ni0.
0
 
LVL 10

Expert Comment

by:Nukfror
ID: 17802750
Oh and be careful with the Bridge network interface in Parallels.  It really annoys me that Parallels doesn't have NAT mode networking like VMware.  I've got a sorta hack working on my Mac by setting up interface sharing through the onboard ipfw firewall but its still annoying.

I did notice though that Sun Update Connector doesn't work in IP share mode - at least when I setup it up it didn't.  It worked fine in bridge mode.  Haven't tried it yet now that is setup but with Interface-share mode enabled in Mac OS X.
0
 
LVL 9

Author Comment

by:ParadiseITS
ID: 17802989
Unfortunately, we run an application that requires Solaris x86 (believe it or not) and I am trying to get this loaded on my laptop so I can go through some CBT training I have on Solaris x86.  The ONLY reason we are using 9 is because (again, believe it or not) when we started the migration to the new version of the app 9 was the current release and we've had it loaded on the server for some time now.  To upgrade it to 10 isn't worth the effort since we already have the app installed and are in the process of validating the install.  Any change to the environment would set us back another 3-6 months.

So, I need to install Solaris 9 x86 :)  And I've seen this working on a MacBook Pro seemlessly... so I don't know why I'm having a problem, except that it is my HP Pavilion dv1500 which must have a wacky DVDROM drive that Parallels or Solaris doesn't like...  I would put it on my desktop machine at work, but then it doesn't help me a whole lot when I have time to go through the CBT...


So, I'm back to the question, is there a way around this Cannot find boot.bin. error in Configuration Assistant as soon as it comes up?  Or maybe a setting in Parallels that can fake Solaris into just accepting the hardware?
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
LVL 10

Expert Comment

by:Nukfror
ID: 17803090
Then maybe extract an ISO image of the Solaris 9 x86 DVD or CDs (depending on what you have) and then attach the software copy .iso image(s) during the install process.
0
 
LVL 9

Author Comment

by:ParadiseITS
ID: 17803173
Excellent idea.. I'll give that a try...  so to do this, I assume I should create the ISO then tell Parallels that the CDROM is the ISO, not the physical drive..?
0
 
LVL 10

Expert Comment

by:Nukfror
ID: 17809203
yep exactly.
0
 
LVL 9

Author Comment

by:ParadiseITS
ID: 17819422
I wanted to update -- I am having a really hard time getting the ISO going... I did it with CentOS with no trouble, made the ISO.. booted... installed....  but the Solaris DVD first wouldn't go.. then I got it to create the ISO and Parallels wouldn't boot off the ISO... kept saying no bootable drive...

Still trying...
0
 
LVL 9

Author Comment

by:ParadiseITS
ID: 17821351
OK, I give up....  I've tried it three times... one just failed completely... the second time I forgot to make it bootable (or at least I think...) and the third time it booted to DOS and sat there and looked at me...  


I'm using Nero 7 to try and do this...   is therre something else I should use?   Making a 2.5GB image takes a LOOOOng time to have failed 3 times...
0
 
LVL 10

Accepted Solution

by:
Nukfror earned 500 total points
ID: 17828472
Hey, don't know why I didn't suggest this before :)

You can download Solaris 9 9/05 images from here:

http://www.sun.com/software/solaris/9/index.xml
0
 
LVL 9

Author Comment

by:ParadiseITS
ID: 17834397
OK... thanks!  That's helpful... now a *stupid* question.. I d/led the DVD image(s)... how do I assemble the 5 files into an ISO?  I can't find it on the site anywehere...  I'm sure it's right there... but I don't see it!
0
 
LVL 9

Author Comment

by:ParadiseITS
ID: 17836538
Rock and roll.. I just d/led the CDROM image instead.. thanks!
0
 
LVL 10

Expert Comment

by:Nukfror
ID: 17836782
You can create the DVD images by simply cat'ing them together:

cat <beginning portion of DVD file name>* > dvd-image.iso

The asterisk will force the names to be cat'ed in order.
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Java performance on Solaris - Managing CPUs There are various resource controls in operating system which directly/indirectly influence the performance of application. one of the most important resource controls is "CPU".   In a multithreaded…
FreeBSD on EC2 FreeBSD (https://www.freebsd.org) is a robust Unix-like operating system that has been around for many years. FreeBSD is available on Amazon EC2 through Amazon Machine Images (AMIs) provided by FreeBSD developer and security office…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.

808 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question