How to disable spanning tree on cisco 851 router (IOS 12.4)

Greetings,

I have a simple network setup, ISP-> cisco router-> 3com switch-> End users/devices.  I'm thinking I can safely turn off spanning tree as I don't see myself getting into a loop-back situation with this configuration.  I have spanning-tree disabled at the switch, but the router seems to have it enabled according to packet analysis on the router lan port (maybe by default? as i dont see a source-bridge statement in my start/run configs).  And I don't see an option in the SDM utility.

Ultimately I'd like to see the router stop generating all of these STP packets.

Can i just issue the following command to disable, or is there more to this situation?

no source-bridge spanning

and if so, would ...

source-bridge spanning

... re-enable it if desired in the future?


Thanks for sharing your expertise.


BobbyBaboonAsked:
Who is Participating?
 
lrmooreConnect With a Mentor Commented:
Well, that explains it. The 851 has a built-in 4-port 10/100 switch. You can disable it the same way you do on any other IOS based switch. I would suggest enabling portfast, but not disabling it alltogether. I'm not positive of the syntax off the top of my head for this router, but it should be something like this:

interface Ethernet1
 spanning-tree porfast  
0
 
lrmooreCommented:
bridge 1 protocol ieee  <== this command enables spanning tree. If it's there, you can take it out unless any of the interfaces are assigned to this bridge-group
I don't know of anything else that would "turn on" spanning tree. It's not typically a function of a router, unless it is set up as a bridge.
0
 
BobbyBaboonAuthor Commented:
Thanks lrmoore,

I did not see that statement in my config.  But I may try the "no" option and see if that has an affect.

That explains why I'm having such a hard time finding documentation about disabling it on routers.  I know it is a switch thing, but there seems to be something setup in the c851 (this is brand new router out of the box with initial configuration and seems to be functioning properly otherwise), I verified it is disabled in the 3com switch config.  I will investigate more and try to verify that I have in fact imperically isolated it to be something generated of the router's own volition.

Would you be interested in seeing the packet information I am capturing? Don't know if it would mean anything to you.   It comes across about every 2 seconds from the lan mac adress of the router, and I believe it is broadcasting to the entire segment across the switch (not confimed yet, but likely).  I assume it is a standard STP packet, but proclaiming the router as the root.

Will keep working on it and advise...
0
 
BobbyBaboonAuthor Commented:
lrmoore,  thanks for getting me in the right direction and thinking.  Here are my findings for everyone's benefit.

I figured out on my c851 I could enable portfast with:

   congfig t
   spanning-tree portfast bpduguard

It does not give me the option to enable portfast without bpduguard.
Of course, enabling portfast while clearing up DHCP timing issues, didn't stop the switch from broadcasting the STP packets.

As this is a simple home network setup not in danger of looping (as long as I'm around anyway ;-)), I was able to disable spanning tree with:

   config t
   no spanning-tree vlan 1

All of the fastethernet ports are by default assigned to vlan 1.
I know that I can re-enable spanning tree if needed in the future, and will if I expand to multiple switch configurations.
0
All Courses

From novice to tech pro — start learning today.