Solved

After connecting to access point away from home, laptop no longer will connect to home access point

Posted on 2006-10-24
12
334 Views
Last Modified: 2013-11-09
This problem seems to occur once in a while, and I have never known what has caused it or what the solution is.

After taking my laptop to connect at some access point away from home, it will no longer connect to my access point at home when I return. What might cause this and what might the solution be?
0
Comment
Question by:jasimon9
  • 4
  • 3
  • 2
  • +2
12 Comments
 

Author Comment

by:jasimon9
ID: 17799128
Additional info: it seems to get stuck on "acquiring network address." This is strange because the system usually will connect immediately upon bootup.
0
 
LVL 20

Accepted Solution

by:
jimmymcp02 earned 150 total points
ID: 17799252
Its seems that the wireless card is not refreshing its settings

when this happens you can run the following command from the cmdp prompt

ipconfig /flushdns
ipconfig /release
ipconfig /renew

and see you are able to connect.

Also thats it happens with the same wireless router or they are different example
if you use the hotel router then you come home then your laptop does not connect to your home wireless
or connecting to any router then connecting to your home wireless connection does not work.
0
 
LVL 43

Assisted Solution

by:Steve Knight
Steve Knight earned 150 total points
ID: 17799340
Agreed.  When you connect to a network and get a DHCP address you are given a lease which lasts a certain length of time.  It could be these foregin networks are giving quite a long lease period and therefore you still have an IP address from their network.  It will initially try and connect to the original DHCP server address (and fail) until the end of the lease time at which point it will broadcast for a new one and end up talking to your router again and getting an address on your network.

If there is a period of time between connections and the lease time is qutie short you don't normally notice these things because the lease it already ran out or due to run out so it acquires a new on one anyway.

Only thing strange here is normally with XP and 2000 it releases the address at shutdown, are you by any chance hibernating or putting your machine into standby?  If so it will retain the address.

either way releasing and renewing as above and/or shutting down and restarting instead of hibernating will most likely fix it.
0
 
LVL 4

Assisted Solution

by:brownmattc
brownmattc earned 100 total points
ID: 17799784
Here is another potential answer:

Did the other network and your home network have the same network name (SSID)?  Does one or the other have some sort of encryption on it (WEP or WPA)?

To make the whole issue easy to solve:
1) Double click on your wireless network icon in the bottom right, next to the clock
2) Click on Change Order of Preferred Networks on the left
3) Find your wireless network and delete it
4) Refresh the list of wireless networks and reconnect to it.

After that you should be able to automatically connect to your network again.


Here is what can happen:  Sometimes when you are out and about you connect to a network that has the same name but different configuration settings as another network.  Windows remembers those settings and tries to automatically reconnect using them.  Then when you try to connect to another of a similar name the connection cannot be successfully made because of the differences.

Good Luck,

Matt
0
 

Author Comment

by:jasimon9
ID: 17799865
Lot's of good ideas. I will try the flushdns, release, renew (things I have done in the past, but forgot about).

I have tried rebooting several times, and that made no difference.

My home network has a unqiue name that is not duplicated on other routers.

The "delete-recreate" is also a good idea.

I'll let you know my results.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 4

Assisted Solution

by:chhokra_expert
chhokra_expert earned 100 total points
ID: 17871388
sometimes, esp if you move through numerous wireless routers before coming back to the "home" router, the new router settings supercede the home settings. you can see these in the windows wireless networking setup window... try moving your home router "up" in the settings. Also, when you switch to other routers, do you manually config your ip address for these or are you on dhcp?
0
 

Author Comment

by:jasimon9
ID: 17877239
Immediately after posting my last comment on 10/24, my laptop back light went out and I had to take it in for repair. So I have not yet been able to try the above suggestions. Will post again when I get the machine back.
0
 
LVL 43

Expert Comment

by:Steve Knight
ID: 18151843
Four way split would be fair...
0
 
LVL 20

Expert Comment

by:jimmymcp02
ID: 18159417
dido with dragon-it
0
 
LVL 43

Expert Comment

by:Steve Knight
ID: 18159720
Don't let my wife see that comment... just 'cos I had one Dido CD she thinks I fancy her
0
 

Author Comment

by:jasimon9
ID: 18170338
We did get the laptop back and have not had the situation recur since then.

I have many times moved my own network to the top, and it does not help. However, the flushdns is probably the correct approach. After sometime the dns would usually time out and take care of itself, but moving between many connections in a short time would seem to solved by the flushdns and I believe in the past that is what worked for me.

Therefore I believe that that is the correct solution. However, deleting the network and letting it be found again would also seem to be a likely solution. So I am going to split points on this basis.

0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Meet the world's only “Transparent Cloud™” from Superb Internet Corporation. Now, you can experience firsthand a cloud platform that consistently outperforms Amazon Web Services (AWS), IBM’s Softlayer, and Microsoft’s Azure when it comes to CPU and …
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now