[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Cisco Pix 506e VPN Problems

Posted on 2006-10-24
3
Medium Priority
?
357 Views
Last Modified: 2013-11-16
Hi

I have a Cisco PIX 506e working very well with a site-to-site VPN configured to our US parent company.

I now need to enable the PIX VPN end-point and, when I do this, the site-to-site VPN stops working correctly (I will be using the Cisco VPN client on the PCs).

The working config is:

interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ************************* encrypted
passwd ************************* encrypted
hostname 506epix
domain-name *************************
clock timezone EST 10
fixup protocol dns maximum-length 512
fixup protocol ftp 21
no fixup protocol h323 h225 1720
no fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.131.153.242 US2
name 192.131.153.241 US1
name 203.39.209.222 VCGate
name 203.51.233.139 VCTest
name 203.39.209.230 VCGate2
name 65.17.110.41 VCGateUS
name 216.82.240.0 ML2
name 199.217.207.73 US3
name 203.166.119.128 ML1
name 202.153.127.240 ML3
name 203.129.74.128 ML9
name 203.129.72.240 ML7
name 195.245.230.0 ML14
name 134.159.150.80 ML5
name 134.159.150.64 ML8
name 203.129.72.208 ML11
name 203.129.74.224 ML10
name 64.124.170.128 ML4
name 195.216.16.211 ML6
name 193.109.254.0 ML12
name 194.106.220.0 ML13
name 203.221.182.0 Pulse_Support
name 10.1.7.201 Pulse
name 10.1.7.200 FOGHORN
name 203.37.158.60 NGProxy
name 218.214.1.85 PulseHomeSupport
name 192.131.153.222 USMail2
name 192.131.153.221 USMail1
name 10.1.7.199 USMailonFoghorn
name 85.158.136.0 ML15
name 216.4.186.99 VCGateUS2
object-group network VideoConferencing
  network-object VCGateUS 255.255.255.255
  network-object VCGate 255.255.255.255
  network-object VCGate2 255.255.255.255
  network-object VCTest 255.255.255.255
  network-object VCGateUS2 255.255.255.255
object-group network USNet
  network-object US1 255.255.255.255
  network-object US2 255.255.255.255
  network-object US3 255.255.255.255
object-group network MessageLabs
  network-object ML1 255.255.255.192
  network-object ML2 255.255.240.0
  network-object ML4 255.255.255.240
  network-object ML6 255.255.255.255
  network-object ML7 255.255.255.240
  network-object ML8 255.255.255.192
  network-object ML10 255.255.255.224
  network-object ML12 255.255.254.0
  network-object ML13 255.255.254.0
  network-object ML14 255.255.254.0
  network-object USMail1 255.255.255.255
  network-object USMail2 255.255.255.255
  network-object ML15 255.255.248.0
object-group network Pulse
  network-object Pulse_Support 255.255.255.0
  network-object PulseHomeSupport 255.255.255.255
  network-object NGProxy 255.255.255.255
access-list outside_access_in permit tcp object-group USNet host 10.1.7.10
access-list outside_access_in permit udp object-group USNet host 10.1.7.10
access-list outside_access_in permit icmp object-group USNet host 10.1.7.10
access-list outside_access_in permit esp object-group USNet host 10.1.7.10
access-list outside_access_in permit tcp object-group VideoConferencing host *********** eq h323
access-list outside_access_in permit tcp object-group VideoConferencing host *********** eq 1731
access-list outside_access_in permit tcp object-group VideoConferencing host *********** range 3220 3225
access-list outside_access_in permit udp object-group VideoConferencing host *********** range 3230 3253
access-list outside_access_in permit tcp any interface outside eq https
access-list outside_access_in permit tcp any interface outside eq www
access-list outside_access_in permit tcp any interface outside eq 5000
access-list outside_access_in permit tcp any interface outside eq 5001
access-list outside_access_in permit tcp any interface outside eq 5002
access-list outside_access_in permit tcp object-group Pulse interface outside eq ssh
access-list outside_access_in permit tcp object-group MessageLabs interface outside eq smtp
access-list outside_access_in permit tcp any interface outside range 5003 5004
access-list outside_access_in permit tcp any interface outside range 6000 6003
access-list 101 permit ip 10.1.7.0 255.255.255.0 192.226.64.0 255.255.192.0
access-list 101 permit ip 10.1.7.0 255.255.255.0 192.227.64.0 255.255.192.0
access-list 101 permit ip 10.1.7.0 255.255.255.0 10.0.0.0 255.0.0.0
access-list 101 permit ip 10.1.7.0 255.255.255.0 192.168.0.0 255.255.0.0
access-list 101 permit ip 10.1.7.0 255.255.255.0 192.131.147.0 255.255.255.0
access-list 101 permit ip 10.1.7.0 255.255.255.0 192.131.152.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside ***************** 255.255.255.252
ip address inside 10.1.7.10 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location US1 255.255.255.255 outside
pdm location US2 255.255.255.255 outside
pdm location US3 255.255.255.255 outside
pdm location 10.1.7.111 255.255.255.255 inside
pdm location VCGate 255.255.255.255 outside
pdm location VCTest 255.255.255.255 outside
pdm location 10.1.7.1 255.255.255.255 inside
pdm location 10.1.7.52 255.255.255.255 inside
pdm location VCGate2 255.255.255.255 outside
pdm location FOGHORN 255.255.255.255 inside
pdm location VCGateUS 255.255.255.255 outside
pdm location ML3 255.255.255.240 outside
pdm location ML1 255.255.255.192 outside
pdm location ML2 255.255.240.0 outside
pdm location ML4 255.255.255.240 outside
pdm location ML5 255.255.255.240 outside
pdm location ML8 255.255.255.192 outside
pdm location ML12 255.255.254.0 outside
pdm location ML13 255.255.254.0 outside
pdm location ML6 255.255.255.255 outside
pdm location ML14 255.255.254.0 outside
pdm location ML11 255.255.255.240 outside
pdm location ML7 255.255.255.240 outside
pdm location ML9 255.255.255.224 outside
pdm location ML10 255.255.255.224 outside
pdm location Pulse_Support 255.255.255.0 outside
pdm location Pulse 255.255.255.255 inside
pdm location PulseHomeSupport 255.255.255.255 outside
pdm location NGProxy 255.255.255.255 outside
pdm location 10.1.7.54 255.255.255.255 inside
pdm location 10.1.7.202 255.255.255.255 inside
pdm location USMail1 255.255.255.255 outside
pdm location USMail2 255.255.255.255 outside
pdm location USMailonFoghorn 255.255.255.255 inside
pdm location ML15 255.255.248.0 outside
pdm location ngcoal.com.au 255.255.255.255 outside
pdm location 10.1.7.69 255.255.255.255 inside
pdm location 10.0.0.0 255.0.0.0 outside
pdm location 192.131.147.0 255.255.255.0 outside
pdm location 192.131.152.0 255.255.255.0 outside
pdm location 192.168.0.0 255.255.0.0 outside
pdm location 192.226.64.0 255.255.192.0 outside
pdm location 192.227.64.0 255.255.192.0 outside
pdm group VideoConferencing outside
pdm group USNet outside
pdm group MessageLabs outside
pdm group Pulse outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface www FOGHORN www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface https FOGHORN https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface ssh Pulse ssh netmask 255.255.255.255 0 0
static (inside,outside) tcp interface smtp FOGHORN smtp netmask 255.255.255.255 0 0
static (inside,outside) 10.1.7.10 10.1.7.10 netmask 255.255.255.255 0 0
static (inside,outside) ***************** 10.1.7.52 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 ******************* 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 1:00:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 10.1.7.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server inside 10.1.7.54 /config.txt
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set aptset esp-3des esp-md5-hmac
crypto map aptmap 10 ipsec-isakmp
crypto map aptmap 10 match address 101
crypto map aptmap 10 set peer US2
crypto map aptmap 10 set transform-set aptset
crypto map aptmap interface outside
isakmp enable outside
isakmp key *********************** address US2 netmask 255.255.255.255
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
telnet 10.1.7.54 255.255.255.255 inside
telnet timeout 5
ssh timeout 60
console timeout 0
dhcpd address 10.1.7.11-10.1.7.254 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80

I need to configure the VPN through the CLI as the PDM doesn't support this config.

I'm happy to post my failing config but thought it might be better to start afresh.  I also need this sorted ASAP! (as is always the case....)

Many thanks in advance

David
0
Comment
Question by:thestormdragondotcom
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 20

Accepted Solution

by:
calvinetter earned 2000 total points
ID: 17800820
>I need to configure the VPN through the CLI as the PDM doesn't support this config.
   CLI is preferred - no Java browser needed, just console or telnet/SSH access, all commands are available. ;)

It's recommended that you have 2 separate but identical ACLs, 1 for your "nat (inside) 0" statement, & 1 for your "crypto map aptmap 10 match address" statement: it works consistently, & helps in troubleshooting.  But if the above works fine for you, more power to ya.  
   Run the below commands in the following order to setup client VPN access:

access-list 101 permit ip 10.1.7.0 255.255.255.0 172.30.91.0 255.255.255.0
ip local pool clientpool 172.30.91.1-172.30.91.50   <- IP range must NOT overlap any IPs on any of your subnets

isakmp identity address
isakmp nat-traversal 20

crypto dynamic-map aptclientmap 999 set transform-set aptset
crypto map aptmap 222 ipsec-isakmp dynamic aptclientmap

vpngroup mygroup1 address-pool clientpool
vpngroup mygroup1 dns-server 10.1.7.x   <- local DNS server
vpngroup mygroup1 idle-time 3600   <- optional: idle out after 1 hr
vpngroup mygroup1 password mysecret

clear xlate
crypto map aptmap interface outside
isakmp enable outside

cheers
0
 

Author Comment

by:thestormdragondotcom
ID: 17801090
You're a genius!  Have the points!

Thanks very much for your help - it's all working as it should!

Thanks again

David
0
 
LVL 20

Expert Comment

by:calvinetter
ID: 17808362
You're welcome David!
0

Featured Post

Cyber Threats to Small Businesses (Part 2)

The evolving cybersecurity landscape presents SMBs with a host of new threats to their clients, their data, and their bottom line. In part 2 of this blog series, learn three quick processes Webroot’s CISO, Gary Hayslip, recommends to help small businesses beat modern threats.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question