Solved

Can't get on the Internet

Posted on 2006-10-24
5
271 Views
Last Modified: 2010-03-17
Up until a couple days ago, I could get online with my Intel-based iMac through my Linksys WRT54G wireless router. Then after copying about 11 GB of files from a laptop PC to the iMac, I shut down for the night, only to find that the next day I couldn't get online with the iMac, nor could the PC access the iMac's files. I have no idea what's changed and I've tried reconfiguring the router and gone through the network diagnostics on the iMac. It can't seem to get a 192.168.1.* address from the router, but rather gets a self-assigned 169.254.* address even though it's using DHCP. Any thoughts on this? I realize this isn't much to go on, but I'm hoping it's enough to work with to come up with a solution and I'll gladly provide more information to any questions asked. Thanks.
0
Comment
Question by:davev
  • 3
5 Comments
 
LVL 53

Expert Comment

by:strung
ID: 17806183
The 169 address means the Mac is not picking up an IP address by DHCP. Do you know if it is connecting to the router? Try setting the Mac wireless settings as follows:

Obtain IP address Manually
IP address = 192.168.1.2
Gateway or Router = 192.168.1.1
Subnet Mask = 255.255.255.0
Domain Name Server = 192.168.1.1

Then point your browser to http://192.168.1.1

If that does not connect you to the router, your problem is that you are not making a wireless connection to the router.
0
 

Author Comment

by:davev
ID: 17808309
I was able to connect to the router after doing the above, but was not able to connect when the Mac was restarted. It seems that my settings are not being fully retained. Also, the first connect to the router still did not connect me to the Internet since Safari timed out while accessing any site. I'm still at a loss....
0
 
LVL 12

Accepted Solution

by:
dalesit earned 250 total points
ID: 17815565
If you open up a command prompt on your mac in Terminal, run the command

sudo tcpdump -n -i en1 port 67 and port 68

(it will prompt you for your password)

then try to renew  your DHCP lease in the Networks system preference pane.

You should see the DHCP negotiations from your mac and the responses from the router.

This might give you an idea as to what is not working.

What wireless channel are you running on? You might be getting interference from another wireless device - some car alarms transmit on channel 8-9, which can interfere with channel 11 or channel 6 (two common default channels). You might also find someone has a video sender which transmits TV from one connection to elsewhere in the house. Again, this can cause interference to a Wifi connection.

Cheers,

Joel
0
 

Author Comment

by:davev
ID: 17816958
I tried the above command and saw 300 or 308 byte packets being sent, but the output didn't seem to indicate anything useful regarding commuication between the Mac and the router, other than the packets being sent between ports 67 and 68. Renewing the DHCP lease didn't give me a 192.168.* address, only a 169.254.* self-assigned address. I'm using channel 6 (the Linksys WRT54G default) with WPA/TKIP security that works well with the 2 PCs (desktop and laptop) on the wireless network. Could the wireless components in the Mac have failed and it's not able to communicate with the router, considering nothing else has changed? The Mac is only 2 weeks old so it's still under warranty if such is the case. Thanks.
0
 

Author Comment

by:davev
ID: 17847360
In doing the above steps as well as talking to Apple Tech Support, I was able to determine that the problem was not with the iMac, but rather with the router I was using. I have since replaced it with another one and the Internet connection problem has gone away. I would like to thank who posted their comments for their efforts. It's always nice to know there are people out there willing to try and help. Thanks again.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
Worried about if Apple can protect your documents, photos, and everything else that gets stored in iCloud? Read on to find out what Apple really uses to make things secure.
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
I've attached the XLSM Excel spreadsheet I used in the video and also text files containing the macros used below. https://filedb.experts-exchange.com/incoming/2017/03_w12/1151775/Permutations.txt https://filedb.experts-exchange.com/incoming/201…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question