Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Terminal server does not want to work anymore!!

Posted on 2006-10-25
10
Medium Priority
?
815 Views
Last Modified: 2008-01-09
Hello!

I have a Windows 2000 Advanced server (Active Directory) and I connect to it from a Windows Xp Professional domain client via Terminal Server.

But now the Terminal Server does not seem to accept connections and I have a error message saying (translated from french):

"Network error while trying to connect"

How to let it work again?
0
Comment
Question by:rthriller
  • 4
  • 3
  • 3
10 Comments
 
LVL 9

Expert Comment

by:FixingStuff
ID: 17806039
Try to stop and restart the "Terminal Services" service.
Is your TS set to Administration mode or Application mode?   If in Application mode,  make sure that you have a TS License server available for license checking or you may receive this "Network" error.
FS-
0
 
LVL 1

Author Comment

by:rthriller
ID: 17806496
My TS is set to Administration mode.
I have error message when  trying to stop it!!

I uninstalled it, reboot, reinstall and reboot and I always cannot connect to it with the same error message.

The error message appears immediatly after I type the server ip and hit Enter. It doesn't even ask me for a username and password.

I can ping the server and access to shared folders and use UltraVnc.
0
 
LVL 9

Assisted Solution

by:FixingStuff
FixingStuff earned 600 total points
ID: 17808059
The fact that it had an error trying to stop indicates a problem.
Check services and see if Terminal Services is started.   If not, try to start now that server has been rebooted.
Also, check the event log for errors relating to Term Serv. Please post any Event Log errors here.
FS-
0
Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

 
LVL 1

Author Comment

by:rthriller
ID: 17810114
Terminal Services is started, but I cannot stop it
I tried :

net stop termservice

I got (in french sorry):

La pause ou l'arrêt demandé(e) n'est pas valide pour ce service.

Vous obtiendrez une aide supplémentaire en entrant NET HELPMSG 2191.


In the Event Log there's lots of errors but there's two that are the cause of the problem :

1/ First

Type de l'événement :      Erreur
Source de l'événement :      TermService
Catégorie de l'événement :      Aucun
ID de l'événement :      14
Date :            26/10/2006
Heure :            10:09:01
Utilisateur :      N/A
Ordinateur :      SRVADM-D01
Description :
Un périphérique qui n'existe pas a été spécifié.
Données :
0000: 52 00 44 00 50 00 2d 00   R.D.P.-.
0008: 54 00 63 00 70 00 00 00   T.c.p...
0010: 00 00 00 00 00 00 00 00   ........
0018: 00 00 00 00 00 00 00 00   ........
0020: 00 00 00 00 00 00 00 00   ........
0028: 00 00 00 00 00 00 00 00   ........
0030: 00 00 00 00 00 00 00 00   ........
0038: 00 00 00 00 00 00 00 00   ........
0040: 00 00                     ..      


2/ Second

Type de l'événement :      Erreur
Source de l'événement :      TermDD
Catégorie de l'événement :      Aucun
ID de l'événement :      50
Date :            26/10/2006
Heure :            09:35:18
Utilisateur :      N/A
Ordinateur :      SRVADM-D01
Description :
Le composant "DATA ENCRYPTION" du protocole RDP a détecté une erreur dans le flux du protocole et a déconnecté le client.
Données :
0000: 00 00 04 00 02 00 52 00   ......R.
0008: 00 00 00 00 32 00 0a c0   ....2..À
0010: 00 00 00 00 32 00 0a c0   ....2..À
0018: 00 00 00 00 00 00 00 00   ........
0020: 00 00 00 00 00 00 00 00   ........
0028: 92 01 00 00               ?...    


Voilà!!
0
 
LVL 7

Accepted Solution

by:
instillmotion earned 1400 total points
ID: 17814448
There could be several reasons for this error:

1. The Encryption levels defined on the RDP-TCP connection are set too high for the client to successfully negotiate. If your client is set to Low encryption it would not be able to connect to a server with High encryption.
To check this, open Terminal Services Configuration on the Terminal Server, right-click the RDP-TCP connection, select properties, and view the Encryption settings on the General tab. Verify that this is set to the level of the client or lower. Test it on low.

2. Another cause could be a registry values in the TermService\Parameters registry key. To be safe export the following key: HKLM\System\CurrentControlSet\Services\TermServices\Parameters

Then, delete the Certificate, X509 Certificate, and X509 Certificate ID values, and restart the Terminal Server. The values will be regenerated on reboot.
0
 
LVL 9

Expert Comment

by:FixingStuff
ID: 17815676
@rthriller  -  I have referred this question to my friend instillmotion.  He is very good with Term Serv and understands French :^)   Good Luck.
FS-
0
 
LVL 1

Author Comment

by:rthriller
ID: 17817676
Thanx FixingStuff...

Instillmotion...

I tried both solutions and this is what happened :

1/ Server-side, the encryption level was set to normal, I set it to normal and still cannot connect. On the client side I do not know where to change encryption level (I am using WinXp Remote Desktop).

2/ In that registry key I only have Certificate value (no Certificate and no X509). I deleted the Cetificate value and tried to stop the Terminal Server in order to restart it but got an error message saying (translated from french) : "Requested pause or stop is not valid for this service. For more help use NET HELPMSG 2191"



0
 
LVL 7

Expert Comment

by:instillmotion
ID: 17821901
1-This setting is defined in the registry on the CLIENT MACHINE as
HKLM\System\CurrentControlSet\Control\Terminal Server\WinStations\RDP-TCP\MinEncryptionLevel .
Low equals this key being set to 1, Medium (or Client Controlled) equals 2, and High encryption equals 3.  If it's at 2 you can leave it there.

2-The registry key I was talking about in the previous post is on the Terminal Services SERVER not the Client. "HKLM\System\CurrentControlSet\Services\TermServices\Parameters"

Restore the client one if you removed it from the export you did before deleting it. Then export on the server and delete the keys mentioned above. Reboot the entire server, don't just restart the service.

Let me know how it goes.

0
 
LVL 1

Author Comment

by:rthriller
ID: 17832209
It works!!!

Thank you :)
0
 
LVL 7

Expert Comment

by:instillmotion
ID: 17835139
great!
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
In this post, I will showcase the steps for how to create groups in Office 365. Office 365 groups allow for ease of flexibility and collaboration between staff members.
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …
Suggested Courses
Course of the Month11 days, 10 hours left to enroll

916 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question