Enable internal speaker beep instead of external speakers

I'm looking to roll out a large number of XP Pro machines into a fairly open area.  Because of the lack of walls, I'm planning on installing these without speakers.  However, I'd still like to have a beep on error warnings - i.e. MS-Word "Do you want to save the chages to Document1?"  

Is there a setting to run these through the internal speaker - not different *.wav(s), just the system beep?  

Pt. 2 - If so, is there any volume control?  Thanks.

Who is Participating?
fatalXceptionConnect With a Mentor Commented:
There would be no volume control on the system "speaker" - this is basically just a piezo beeper that makes a tone when its activated, the tone depends on the voltage across it if i recall.

I found that if you disable the sound card on some makes, (if they have one) then Windows defaults to playing the default windows beep sound via the internal speaker...but I think you just have to try this and see.
Really the only thing that comes to my mind is to enter the Control Panel, select Sounds and Multimedia.
Locate and enable the sounds you want to hear, i.e. "Program Close" and disable all others. That's all I can really think of. :-)
tmcdonalAuthor Commented:
Those changes only affect how the sounds play through the sound card/speakers.  I'm looking to bypass theme completely.
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

tmcdonalAuthor Commented:
That's really close - I tested it on my PC (an HP) and it worked, however, on the new Dells it did not work.  I'll play around with this some more.

Also, I now see that the the volume question is now irrelevant.  My only concern was if it turned out to be a loud, obnoxious beep.  However the quiet (obnoxious) beep that it makes is exactly what I was looking for.
You might need to check in the DELL BIOS to see if they have an option to enable/disable the internal speaker - I have found on some models its turned off by default.

best of luck and let us know how you get on with it!
tmcdonalAuthor Commented:
No, there were no BIOS options for this.  I wanted to give a chance for any other contributions.  However, since fatalXception's answer appears to be the only solution, albeit specific to certain models, I awarded the points there.  Thanks for the help!
Pity it didn't work out the way you wanted it, thanks for the points!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.