Can't connect to SMTP server through Telnet

Hi guys,

I have small business server 2003. I can't connect to smtp server from any computer in the office. When I try to connect from mine I type in - telnet test.com 25, and it hangs for 5 seconds and then says Connection to host lost. I took a look at our Netgear firewall settings, and in Ports section there is an entry that always allows connections on 25 port for Any WAN user. However, after I try to conenct from my PC in the firewall security logs it says - Wed, 10/24/2006 08:53:08 - 25 dropped -  Source: 192.168.1.136 (my IP), 3403, LAN - Destination: 67.124.245.1 (IP of where I'm trying to connect), 25, LAN

Anyone has an idea how to fix this?
Thanks.
LVL 7
Yury MerezhkovDevelopment Team LeadAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
SembeeConnect With a Mentor Commented:
There is no SMTP server on that IP address so you may have the wrong IP address.

Simon.
0
 
poweruser32Commented:
your ISP may be blocking port 25 -in other words they want you to use or authenticate with their mail servers first to send email
0
 
Yury MerezhkovDevelopment Team LeadAuthor Commented:
When I'm using my PHP and other scripts that use SMTP I do use authentication, still it doesn't want to work. Everything works on the server, tho.
0
 
Yury MerezhkovDevelopment Team LeadAuthor Commented:
That was it, Sembee. How dumb of me, lol. It's been 6 weeks since I started having troubles with this. It was just wrong IP. I checked everything but IP. Haha. Thank you so much.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.