We help IT Professionals succeed at work.

Error Signature with delphi application

dannertb
dannertb asked
on
Medium Priority
617 Views
Last Modified: 2010-04-05
I have developed an aplication and i have tested on few xp machines and it worked very well. Application was tested on machines with XP and Delphi allready installed. But i have tested the application on a system with no delphi and i have different situations :

1 ) aplication has no start and nothing happened
2) on another machine i get this error :
Error Signature
AppName : ..... . exe AppVer 0.0.0.0 ModName : kernell32.dll
ModVer 5.1.2600.2180 OffSet : 0001eb33

on my computer work just fine
Projects -> Options -> Packages -> Not build with runtime packages

in this app i use FastReports components excepting the ussual comps that are standardly installed

can anybody help my
Comment
Watch Question

Commented:
are you using any ActiveX component? this component might not be installed in the other system
you may need to register the dll on the workstation

sun4sunday
Hi

I usually put message boxes in the code every few lines to see where the app is failing.

If there is code in the create event of the main form, this should tell you what line its at.

The app will always start - it has to do something, you need to find out what is wrong.  Make a copy of your app and start by stripping out the likely suspects until you see something on the screen, its trial and error to isolate the problem sometimes.

Voodooman

Author

Commented:
I have made an install pack using inno setup but this is not determining the dependencies. Any way i find that midas.dll was missing. But now on most computers that it was not working it is working but i have a few of them whis is not allaways working. It might be ok foe some users..... let me find out and i will be back for "accept" answers. 10x a lot
MIDAS fixes in Delphi 7.1
http://distribucon.com/blog/archive/2004/05/12/220.aspx
http://cc.borland.com/Item.aspx?id=20524
Check the above links fror midas.dll patch

Also you may have to include the dll file which is missing
It seems the midas.dll library does not install automatically for some reason and can download from this site
http://www.practiline.com/faq.htm
 get an Error loading MIDAS.dll error when starting PractiCount and the program refuses to work properly after that.

sun4sunday

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.