[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 184
  • Last Modified:

USB External Drive suddenly won't connect properly

I have been using my external USB drive with no problems.
I know the drive is good as I can hook it up to the PC directly and it works fine.
The "Unplug or Eject Hardware" box shows "inito  IEEE 1394 SPB2 Device" with a yellow exclamation mark. This isn't what it used to say, although I can't recall what it was specifically.
Any thoughts?
0
rbend
Asked:
rbend
1 Solution
 
jamietonerCommented:
If the drive work fine outside the enclosure then most likely its either a bad cable or a bad enclosure.
0
 
IPKON_NetworksCommented:
It could be something simple like dust in the connections. remove each one and clean them all up. Maybe the power supply to the enclosure is failing (not unsual as they tend to be cheap and not very stable).
Also, could be a driver corruption issue.

All this is as well as those mentioned by Jamie above.
Barny
0
 
W_HCommented:
sometimes bad contact of the cable or jsut because of Windows can cause the problem.

I have got this kind of problem quite a few time because of the foloowing:
not enough power
system problem, normally can fis with unplug and replug again.
the external case hardware problem.
cable porblem
PC connector problem
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now