Problems with my webpages when migrating to RedHat Enterprise

Hi:
We migrate our server to RedHat enterprise from RedHat9 and now the pages that use Scripts from Fireworks and other dont work. All the menus from the page are not usefull. One of my webpages is www.dise.com.mx when you browse it and you go trough the left menu, its has submenus, but they dont appear.

This only happend with Windows Explorer, with Firefox theres no problem

HELP.

Javier
fjamozuAsked:
Who is Participating?
 
ahoffmannCommented:
add your mmLoadMenus(); to body's onload=
0
 
Sam PanwarSr. Server AdministratorCommented:
Hi,

I have check your site and found that some object is missing like JAVA script for IE that's why you are getting problem so please install it and please also check the your IE is updated and all ActiveX control installed.

Are you using any firewall??


I have also get object expected error in the contact page in line 113 so please check the code and update your IE accordingly.
0
 
fjamozuAuthor Commented:
Hi,

This Java scrpits missing must be instalked at the Server?

My IE is pudated an all de ActiveX control installed.

Im not using any firewall at this moment.

Do I need to check the code in html of the web page to work with IE?

Thank you
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
fjamozuAuthor Commented:
where?

This is an example of the menus, in what part?

function mmLoadMenus() {
  if (window.mm_menu_0110184044_0) return;
  window.mm_menu_0110184044_0 = new Menu("root",72,16,"Arial, Helvetica, sans-serif",12,"#000000","#ffffff","#a7a6a4","#0068bb","left","middle",2,0,1000,-5,7,true,true,true,0,true,true);
  mm_menu_0110184044_0.addMenuItem("Laboratorio","location='tecnologia01.htm'");
  mm_menu_0110184044_0.addMenuItem("Windows","location='tecnologia02.htm'");
  mm_menu_0110184044_0.addMenuItem("Linux","location='tecnologia03.htm'");
  mm_menu_0110184044_0.addMenuItem("Desarrollos","location='tecnologia04.htm'");
   mm_menu_0110184044_0.hideOnMouseOut=true;
   mm_menu_0110184044_0.menuBorder=1;
   mm_menu_0110184044_0.menuLiteBgColor='#ffffff';
   mm_menu_0110184044_0.menuBorderBgColor='#cccccc';
   mm_menu_0110184044_0.bgColor='#cccccc';

  mm_menu_0110184044_4.writeMenus();
} // mmLoadMenus()

Thank you very much

Javier

0
 
ahoffmannCommented:
<body onload="mmLoadMenus();  ---your-other-existing-code-here--- >
0
 
fjamozuAuthor Commented:
Sorry, Im new in this, the text is:
function mmLoadMenus() {
---your-other-existing-code-here---
} // mmLoadMenus()

I change it for:
<body onload="mmLoadMenus(); {
---your-other-existing-code-here---
} // mmLoadMenus()>

Or i live it like:
function <body onload="mmLoadMenus(); {
---your-other-existing-code-here---
} // mmLoadMenus()>
Thanks
0
 
ahoffmannCommented:
ok, assuming your current body tag looks like:

  <body onload="someotherfunction();other"function()" >

then replace it by:

  <body onload="mmLoadMenus();someotherfunction();other"function()" >
0
 
fjamozuAuthor Commented:
Hi,

With all this, I changed everithing and I think the problems is my server because I upload the page in other server with the changes you tell me and everything works fine.

I use to have RedHat 9 and we upgrade the server to Red Hat Enterprise, since then we have this problem. The error is not in the code (at this moment) but in the server. Any idea why?

I have the same programs installed in the new server.
0
 
ahoffmannCommented:
> The error is not in the code (at this moment) but in the server.
please post the error message
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.