Solved

Two Computers Will Not Connect To Internet When Both Are Connected To Speedstream 6520 Modem/Router

Posted on 2006-10-25
22
543 Views
Last Modified: 2013-12-14
I need some help!  Anything you guys can do for me, would be GREATLY appreciated.

Situation:  Last week I was trying to surf the web and discovered it was taking a long time.  Then it would come up with "Page cannot be displayed".  I've been using both Firefox and IE 6.  I have been using two computers connected to the network for a year now but WHEN BOTH are connected now, I cannot access the Internet from either computer.  I've installed no new programs or hardware.

Link to Modem : http://service.sympatico.ca/index.cfm?method=content.view&content_id=5379&category_id=104


Troubleshooting Steps Already Taken:

- checked the ethernet cables to make sure their connecting and working properly (I can surf with either one connected but not with both      at the same time).

- I selected Properties on my Marvell Yukon LAN, went to TCP connections in Network Connections to make sure 'IP address obtained  
  automatically".

- I've tried reinstalling the Network Controllers

- I've called my ISP and they tell me everything is fine on their end (they've reset the modem several times)

- I have gone under CMD in the Run menu and typed in IPCONFIG and see that I have an IP address.  

- I also did a 'ping' cmd (ping www.google.com), and it came back positive, no loss in packets

- I've currently have no firewall installed and I put the router in the DMZ mode but to no avail.


Again, I cannot connect the two computers in my network to the Internet together now.  This literally happened out of the blue and was not due to any software or hardware issue.  ANYTHING you can do to help me get by this challenge.

Thank all of you in advance!

0
Comment
Question by:crrp6501
  • 8
  • 5
  • 5
  • +3
22 Comments
 
LVL 20

Expert Comment

by:ElrondCT
Comment Utility
Just to make sure: are both using Ethernet, with Cat5 cables? Or is one using the USB connection? If the latter, I strongly recommend discontinuing that and putting both on regular Cat5 cables. Using both types of connections simultaneously is unreliable, but will sometimes work.

What IP addresses are you getting for each computer, and what address is the modem/router using (for the LAN, not the outgoing IP address)?

Can the computers see each other on the LAN, in the workgroup? When both are connected, can both of them access the modem/router's setup page?
0
 

Author Comment

by:crrp6501
Comment Utility
Hi ElrondCT,

Yes, both are using Cat5 cables.  On First computer I get 192.168.2.10 and on the Second I get 192.168.2.12. Router is using 192.168.2.1.  The two computers cannot see each other in the workgroup.  When both are connected, each can access the modem/router's setup page.

Hope this helps and I apologize for the delay.  I had to get some sleep; I've been working on this for hours now.

Thanks again for all your help!
0
 
LVL 14

Assisted Solution

by:FriarTuk
FriarTuk earned 260 total points
Comment Utility
try resetting tcp/ip
netsh int ip reset c:\resetlog.txt  (http://support.microsoft.com/?kbid=299357)
or using the tool
http://www.spychecker.com/program/winsockxpfix.html

also try these:
NETSH FIREWALL RESET
NETSH WINSOCK RESET
(http://support.microsoft.com/kb/811259 how to recover from winsock2 corruption)

open a dos prompt on both (Start - run - cmd) & run "ipconfig /all" then copy/paste their results here for comparison. btw do you get any errors?

http://support.microsoft.com/kb/813936/        (how to setup home network in xp hm step 1-8)
http://support.microsoft.com/kb/304040/en-us    (how to configure sharing in xp)
0
 
LVL 40

Expert Comment

by:Fatal_Exception
Comment Utility
I have Speedstreams at about 10 of my locations, and have yet to experience serious issues with these, but be aware that they are mostly consumer devices and sometimes will go bad..  The ISP will port into it just fine, but it could be a firmware problem within the router and be undectable to the outside connection..

But, first try getting outside using an IPAddress instead of a friendly name and make sure this is not a DNS issue...  

For instance, instead of using www.yahoo.com, use 209.73.186.238
                                            www.google.com use 72.14.203.104

If you can connect, then it is definitely DNS and you will need to input a different DNS server statically, or your ISP will have to issue a different one to you using DHCP..

BTW:  since you can connect to the router and other computers, then I doubt whether it is an internal TCP issue...
0
 
LVL 10

Expert Comment

by:dragonjim
Comment Utility
It sounds more like a possible DNS problem with the router (confirm with Fatal's recommendation). You may want to consider upgrading the router's firmware.

Curious -- you said you can connect with each computer seperately (the other unplugged). Is this with the router inline?

(Modem)---(Router)---(computer)   vs (Modem)---(computer)

0
 
LVL 66

Expert Comment

by:johnb6767
Comment Utility
Haev you tried logging into the router, and had a look around in there? There is probably a reset to factory defaults link in there. Just make sure you haev your username/password for the pppoe connection if applicable. Or there should be a reset button on the outside.....

Sounds like something in teh NATTing service of the router has just gotten wacky... (yes, its a technical term...)
0
 
LVL 14

Assisted Solution

by:FriarTuk
FriarTuk earned 260 total points
Comment Utility
crrp, kindly respond to our comments in order for us to help you.  have you tried mine or other expert's suggestions yet?
0
 

Author Comment

by:crrp6501
Comment Utility
Hi all!

Sorry about the delay; life's been quite hectic.

Ok, here's the rundown.  I've done the "ping 209.73.186.238" in CMD and found no packet loss.  I've checked msinfo to see if I have a Winsock2 corruption problem and found everything to be clear. I did a Winsockxpfix.exe fix anyway to see if that would help; it did not.  My SpeadStream is a Modem/Router combined (it's got the phone jack and four ethernet ports).  I did do what FriarTuk suggested and when I reset it via the netsh cmds I actually got both working (My 'host' computer was already connected and when I plugged in the second one they both could surf).  However, when I restarted the second computer it wouldn't connect to the internet and then neither would the first one, mine.  Not sure what the heck is going on here.

I just want to make sure everyone is aware of my setup again, as I've run into apparent difficulty explaining to others:

I've got a SpeadStream Router 6520 (http://service.sympatico.ca/index.cfm?method=content.view&content_id=5379&category_id=104), with a phone cord connected directly to the router from the jack.  I've got one ethernet cable going to each of the two separate computers.  I've not had any problems with this setup before and I've been using this setup for over a year.  And right now, I can connect to the Internet if only my first computer is on.  If my second one is on, it 'locks' or slows to a crawl to only tell that the page cannot be displayed.

The only thing I could think of that might have brought this on would be when I installed ZoneAlarm Pro.  Now, to be sure, I had installed this two weeks before my connection went haywire on me.  So I thought that it might be the culprit so I uninstalled it to no avail.   I even looked through Google to see if there was anything 'extra' I had to do to make sure it was completely off my system.  I did find a few things and followed the requirements to completely remove ZoneAlarm but this has not helped to restore my connection.

Another thing I noticed was that if I went into my router's setup (192.168.2.1) and selected it to 'Renew' my ip address there would be a moment when my Internet Gateway icon in my Network Connections folder would show Disconnected.  When this happened I was momentarily able to connect to various websites.  I'm wondering; is it a port issue.  If so how should I resolve this.

Again, anything you can think of would be extremely helpful.  I am at a complete loss as to how to fix this.

Thank you again for all your effort and patience!

Cory
0
 
LVL 40

Expert Comment

by:Fatal_Exception
Comment Utility
Usually, the Gateway is installed when setting up an ICS connection..  you should be able to right click it and disable..  Also, I do not think you need this to surf, unless you are running ICS, or have UPnP enabled...
0
 
LVL 40

Expert Comment

by:Fatal_Exception
Comment Utility
BTW:  here is a short page on the Gateway..  is this what you are speaking of above?

http://www.practicallynetworked.com/sharing/xp_ics/internetgateway.htm
0
 

Author Comment

by:crrp6501
Comment Utility
Hey Fatal,

Thanks for the article and, yes, it is exactly what I have.  When I had setup my computer I went through the Network Connection Wizard and this is the setup it gave me:  When either my first OR second computer is up and running or if both are running, Internet Gateway is displayed in the Network Connections folder.

Now I've already tried running through the Setup Wizard a few times now but with no success.  I should note that I cannot access the Internet with my one computer connected if I try to disconnect the Internet Gateway. Yet I can access the Internet momentarily if both computers are up and running, 'freeze', and I 'Renew' my connection (which disables the Internet Gateway for second)?

Again, any insight would be a big help.

Cory
0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 40

Expert Comment

by:Fatal_Exception
Comment Utility
Well....  even though I have setup hundreds of these small networks, I have always recommended users NOT to use the Setup Wizard...  I always do the configuration manually, and rarely have problems..  Personally, I would take the network down to the beginning and start over..  use my page on P2P if you have any problems, or want a primer..

http://24.160.178.164/KipSolutions/P2PNetworks/TroubleshootingP2P.htm
0
 

Author Comment

by:crrp6501
Comment Utility
Hi Fatal,

Wow, you sure have some valuable information on your site.  I've tried a few of them but to no avail.  I've noticed something on my router/modem and that is the Ethernet light blinks furiously when the second computer is connected and doesn't stop the whole time both computers are connected.  However, if I connect just this one computer it doesn't blink furiously.  Does this mean anything?  Keep in mind that both computers are 'idle' are startup.

Cory
0
 
LVL 40

Accepted Solution

by:
Fatal_Exception earned 240 total points
Comment Utility
Well, that light can indicate a lot of things, and is not a good way to try to diagnose an issue...   since that modem/router is acting as a router (not a bridge), the outside traffic should not be DHCP request  packets, but could indicate that something on that computer is trying to access a webpage..  spyware / virii / trojan maybe?

Have you tried to take the systems back to the defaults and started at the beginning?
0
 
LVL 14

Assisted Solution

by:FriarTuk
FriarTuk earned 260 total points
Comment Utility
if this is a modem/router providing dhcp to all connected computers, then do away with ics - the DSL line should run into the DSL port, & all computers should connect via ethernet cables running from the ethernet ports on the router to the ethernet netwk cards on the pc's (or wirelessly).  therefore rendering the need for ICS obsolete.

maybe useful info here:
http://subscriber.communications.siemens.com/subscriber_networks/faq.shtml
0
 
LVL 10

Expert Comment

by:dragonjim
Comment Utility
Not familiar with the hardware here... but apparently a number of folks have had problems with it...

http://www.dslreports.com/forum/remark,13415363
0
 
LVL 14

Assisted Solution

by:FriarTuk
FriarTuk earned 260 total points
Comment Utility
ccrp, any updates?
0
 

Author Comment

by:crrp6501
Comment Utility
Hello everyone,

I have finally fixed the issue. You're not going to believe this: my problem was a virus.  I discovered this when the user of my second computer told me he had caught a virus just before our Internet went wacky and that he'd used AVG Anti-Virus to get rid of it.  

Well, up to that point, as you've all noted, we tried pretty much everything to fix this but to no avail.  So, when he mentioned this I decided to see if this 'virus' was still there.  I looked and it had appeared as if my friend had removed it indeed.  Well, just for kicks, I decided to uninstall AVG.  During the uninstall process, it asked me if I wanted to 'Delete the viruses in my quarantine folder?'.  Well, duh, yeah. Right after I did this, I got the Internet back for both computers. Wooohooo!  Right? Well, close.  I cannot get either computer to locate each other so I can send files to the other. Any ideas?

Once again, THANK YOU, for all each of you have done, especially FriarTuk! :)
0
 
LVL 40

Expert Comment

by:Fatal_Exception
Comment Utility
So, my comment above nailed this, eh?  :)
0
 
LVL 40

Expert Comment

by:Fatal_Exception
Comment Utility
<<but could indicate that something on that computer is trying to access a webpage..  spyware / virii / trojan maybe?<<

:)

Regardless, glad you got it, and Happy Holidays to all!

FE
0
 
LVL 14

Assisted Solution

by:FriarTuk
FriarTuk earned 260 total points
Comment Utility
here's a link explaining the different processes to close when a thread is deemed answered.
http://www.experts-exchange.com/help.jsp#hs5
0
 
LVL 40

Expert Comment

by:Fatal_Exception
Comment Utility
And thanks!

FE
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

This solves the problem of diagnosing why an internet connection is no longer working. It also helps identify the likely cause of the lost connection if the procedure fails to re-establish your internet connection. It helps to pinpoint the likely co…
Cable Modem Provisioning from DPoE compliant server  This Article is to support CMTS administrators to provide an overview of DOCSIS compliance configuration file, and to provision a cable modem located at customer place from a Back office serve…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now