Solved

Internal Routing in FE/BE Config

Posted on 2006-10-26
5
156 Views
Last Modified: 2010-03-06
Hi,
We have a single routing group with 2 back-end servers and a front-end server.  The 2 back-ends (Exchange 2003) have the same smart host on the smtp virtual server for outgoing messages.
External messages to users on both servers work properly but a message from userA on serverA to userB on serverB gets stuck in a Q on serverA.  ServerA also tries to send the message to the smarthost but after connecting never sends ths data (SMTP timeouts appear in log).  I would have expected serverA to communicate directly with serverB as the address is in the AD.  
Do we need a SMTP connector for this (if so how should it be configured) or is something else going on?  Also, Exchnage shares address space with the smart host.

Thanks a lot,
G.
0
Comment
Question by:gwpaterson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 16

Assisted Solution

by:poweruser32
poweruser32 earned 50 total points
ID: 17813101
if the smart host set up on the SMTP VS-its better to set up a smtp connecter and set up the smart host on the connecter and add your 2 servers
0
 
LVL 104

Accepted Solution

by:
Sembee earned 300 total points
ID: 17813111
The problem is that you have the smart host on the SMTP virtual server.
Remove it. That overrides everything that the Exchange server can find for itself.

Put an SMTP Connector in. Initially set both the backend servers as the bridgeheads and put the smart host where prompted.

Simon.
0
 

Author Comment

by:gwpaterson
ID: 17813827
Thanks for the info.

What are your recommendations for the address space for the SMTP connector (remember that this is split with the smart host).

Thanks,
G
0
 
LVL 104

Expert Comment

by:Sembee
ID: 17813863
In your current configuration all email goes through the smart host, so I would set the address space to * and leave Exchange to sort out the rest.

The address space is email addresses, not IP addresses.

Simon.
0
 

Author Comment

by:gwpaterson
ID: 17835749
Thanks for the tip.

I added 2 smtp connectors; 1 for the shared domain and 1 for * (and removed the smart host on the virtual smtp servers).  

Also had to make Exchange non-authoritative for the shared domin (kb/321721 and kb/823158 and Routing Transport Guide) in the recipient policy (as was getting NDRs) but things seem to be working now.

Cheers.
G.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Suggested Courses

628 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question