unable to use msn messenger or hotmail even though I have a working internet connection

I'm connecting to the net using an ADSL modem but as soon as I connect my DLINK router to the modem I'm unable to use programs such as MSN messenger or send email using hotmail even though I'm able to load pages or view emails
It's a DLINK DI-524 http://www.dlink.com.au/Products.aspx?Sec=1&Sub1=2&Sub2=5&PID=60
As soon as I remove the router everything works again. I've tried different browsers a different  computer connected to the router ... did a router firmware upgrade but no luck.
stefanomarcoAsked:
Who is Participating?
 
nprignanoTechnical ArchitectCommented:
Reading back through the thread, I see you have upgraded your firmware, but nowhere do I see you mention that you have tried restoring your router back to the factory defaults.

There is a reset button on the back of your router, unplug the power, insert a paperclip into the reset slot and hold down the button.  Plug in the power while continuing to hold down the button for 15-20 seconds, lights should flash, release the button and let the router do its thing, take approx. 45-90 seconds.

Try again.  If it still does not work, you could try rolling back the firmware by installing a previous version, but its also possible the router itself is failing.  I have wasted many hours racking my brain over faulty hardware issues that often present as configuration errors.  Low-end devices fail, its the nature of the beast.  Check to see if the device is still under factory warranty and get it replaced.

nprignano
0
 
LindyMoffCommented:
Hmm... I'd be interested to see what's going on here via a packet trace.  How do you usually send email through Hotmail -- via your web browser, or Outlook Express (or something else)?

Basically, I'd check to see if there's some firewall rule turned on your router that blocks all but HTTP traffic.
0
 
stefanomarcoAuthor Commented:
send email via web browser ... I also reset the router and did a firmware upgrade :(
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
rakichjCommented:
have you enabled the ports on the router. remember that a router is also a firewall. the programs communicate using a specific port anywhere from 1-65536. post what programs your using and we could tell you what port you need to enable on your router
0
 
stefanomarcoAuthor Commented:
no I haven't enabled any ports ... just using hotmail and various web based email services also messenger live ... but surely the average user wouldn't have to configure ports on a new router to use these services?
0
 
nprignanoTechnical ArchitectCommented:
no, but the average user would have to make sure UPnP is enabled on the firewall.  consult your router's helpfile to configure, or post the make and model and we can find it for you.

nprignano
0
 
stefanomarcoAuthor Commented:
0
 
stefanomarcoAuthor Commented:
opening all ports or disabling the firewall in the router ... same thing? could do this to see if it works?
0
 
rakichjCommented:
just enable the ports you need. should only be a couple you need to do. I think the firewall you want to keep on for security reasons.
0
 
robjeevesCommented:
Sounds odd.  Generally with these little applicance all outbound traffic is allowed by default.  Something strange is going on.

Did you look for UPnP as suggested by nprignanao? Do you have a mate with a laptop or another PC to try.  Quick troubleshooting step to isolate your PC or the router is try another box and see if it is still getting the same issue.

Rob
0
 
rakichjCommented:
windows messenger will use ports 6891-6900. you can different ways to address this issue by going to help in windows messenger, then going to help topics, then under contents you will see an article labled "using windows messenger from behind a firewall". Then you will see step by step.
0
 
kadadi_vIT AdminCommented:
I think you did not configure the router to use the internet so contact to ISP provider and reset that router to factory defaults and cehck the router configuration manual and do not need to open the ports for standard sites / messangers ...Yes if you blocked that perticular ports / serives in router builtin firewall so cehck with the firewall settings .
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.