unable to use msn messenger or hotmail even though I have a working internet connection

Posted on 2006-10-26
Last Modified: 2013-11-30
I'm connecting to the net using an ADSL modem but as soon as I connect my DLINK router to the modem I'm unable to use programs such as MSN messenger or send email using hotmail even though I'm able to load pages or view emails
It's a DLINK DI-524
As soon as I remove the router everything works again. I've tried different browsers a different  computer connected to the router ... did a router firmware upgrade but no luck.
Question by:stefanomarco
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +3

Expert Comment

ID: 17816671
Hmm... I'd be interested to see what's going on here via a packet trace.  How do you usually send email through Hotmail -- via your web browser, or Outlook Express (or something else)?

Basically, I'd check to see if there's some firewall rule turned on your router that blocks all but HTTP traffic.

Author Comment

ID: 17816738
send email via web browser ... I also reset the router and did a firmware upgrade :(

Expert Comment

ID: 17816745
have you enabled the ports on the router. remember that a router is also a firewall. the programs communicate using a specific port anywhere from 1-65536. post what programs your using and we could tell you what port you need to enable on your router
Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.


Author Comment

ID: 17816838
no I haven't enabled any ports ... just using hotmail and various web based email services also messenger live ... but surely the average user wouldn't have to configure ports on a new router to use these services?
LVL 15

Expert Comment

ID: 17817097
no, but the average user would have to make sure UPnP is enabled on the firewall.  consult your router's helpfile to configure, or post the make and model and we can find it for you.


Author Comment

ID: 17817481
opening all ports or disabling the firewall in the router ... same thing? could do this to see if it works?

Expert Comment

ID: 17817515
just enable the ports you need. should only be a couple you need to do. I think the firewall you want to keep on for security reasons.

Expert Comment

ID: 17817529
Sounds odd.  Generally with these little applicance all outbound traffic is allowed by default.  Something strange is going on.

Did you look for UPnP as suggested by nprignanao? Do you have a mate with a laptop or another PC to try.  Quick troubleshooting step to isolate your PC or the router is try another box and see if it is still getting the same issue.


Expert Comment

ID: 17817539
windows messenger will use ports 6891-6900. you can different ways to address this issue by going to help in windows messenger, then going to help topics, then under contents you will see an article labled "using windows messenger from behind a firewall". Then you will see step by step.
LVL 17

Expert Comment

ID: 17818221
I think you did not configure the router to use the internet so contact to ISP provider and reset that router to factory defaults and cehck the router configuration manual and do not need to open the ports for standard sites / messangers ...Yes if you blocked that perticular ports / serives in router builtin firewall so cehck with the firewall settings .
LVL 15

Accepted Solution

nprignano earned 500 total points
ID: 17823231
Reading back through the thread, I see you have upgraded your firmware, but nowhere do I see you mention that you have tried restoring your router back to the factory defaults.

There is a reset button on the back of your router, unplug the power, insert a paperclip into the reset slot and hold down the button.  Plug in the power while continuing to hold down the button for 15-20 seconds, lights should flash, release the button and let the router do its thing, take approx. 45-90 seconds.

Try again.  If it still does not work, you could try rolling back the firmware by installing a previous version, but its also possible the router itself is failing.  I have wasted many hours racking my brain over faulty hardware issues that often present as configuration errors.  Low-end devices fail, its the nature of the beast.  Check to see if the device is still under factory warranty and get it replaced.


Featured Post

Optimum High-Definition Video Viewing and Control

The ATEN VM0404HA 4x4 4K HDMI Matrix Switch supports 4K resolutions of UHD (3840 x 2160) and DCI (4096 x 2160) with refresh rates of 30 Hz (4:4:4) and 60 Hz (4:2:0). It is ideal for applications where the routing of 4K digital signals is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…
Suggested Courses
Course of the Month8 days, 10 hours left to enroll

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question