Solved

Cisco ASA 5510 - PIX 501 (Testing Accounting Network Connection)

Posted on 2006-10-27
3
1,834 Views
Last Modified: 2008-01-09
Another Fine Mess!
In an attempt to replace our company's Netgear VPN Router with a more advanced Firewall.
I purchased the Cisco ASA 5510.
Unfortunately impementing this device has been burdensome (as many of you are aware).

I have a separate Router we will call the IBM Router.
I am not able to disconnect this router since it is a direct connection to the ISDN line and henceforth to our Accounting AS400 Server multiple hops down the road.

I have created an interface on my ASA 5510 named ACCOUNTING.
It is addressed 10.8.3.1 (you will notice my running config below).
In an attempt to test the connectivity between my ASA 5510 / the Accounting interface and the subsequent router that I will plug into it I need to test a seprate piece of equipment to make sure that my configurations are correct before the Accounting Company will make the appropriate changes to a production environment.

So I took my PIX 501 that I happened to have lying around.
I addressed my outside interface as 10.8.3.2 and my inside interface with 10.1.1.1.

I then took a client computer and connected it to one of the switch ports of the Cisco PIX 501 and attempted to ping this device (10.1.1.9) as an example of which would be my AS400.

As you can see from the Running configuration fo the PIX (I created the appropriate Static Mapping for Nat as well as Access Lists for pinging successfully).

Where am I going wrontg.

Remember the ultimate goal is to creat an environment that confirms if I plug in the IBM router to interface ACCOUNTING on my ASA 5510 that my packets destined for 10.1.1.9 down the path will end up where they belong.

here are my running configs - I wish I could give more than 500 points, but that is the most + it is critical because the Netgear still stands as the primary router / firewall for my company until I can successfully implement the accounting connection.

RUNNING CONFIGURATION (ASA 5510):

asdm image disk0:/asdm505.bin
asdm location WTS1 255.255.255.255 inside
asdm location JRA-XSERVE1 255.255.255.255 inside
asdm location ATROPOS 255.255.255.255 inside
no asdm history enable
: Saved
:
ASA Version 7.0(5)
!
hostname ciscoasa
domain-name jrabbott.com
enable password 1q1dWhr/XLfzW0/Y encrypted
names
name 10.8.1.6 WTS1 description Citrix Server
name 10.8.1.20 ATROPOS description Database Server
name 10.8.1.8 JRA-XSERVE1 description MAIL SERVER
dns-guard
!
interface Ethernet0/0
 description ISP / Route
 nameif outside
 security-level 0
 ip address 208.xxx.xxx.100 255.255.255.248
!
interface Ethernet0/1
 description Network Traffic
 nameif inside
 security-level 100
 ip address 10.8.1.50 255.255.255.0
!
interface Ethernet0/2
 description Web Application Server / Front-End Exchange Server
 nameif Exchange
 security-level 50
 ip address 10.8.2.1 255.255.255.0
!
interface Ethernet0/3
 description JD. Edwards Inteface to WTS Accounting (10.1.1.9)
 nameif ACCOUNTING
 security-level 100
 ip address 10.8.3.1 255.255.255.0
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.1.1 255.255.255.0
 management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
clock timezone pst -8
same-security-traffic permit inter-interface
object-group service RDP tcp-udp
 description Remote Desktop (Terminal Services)
 port-object range 3389 3389
access-list INBOUND extended permit tcp any interface outside eq smtp
access-list INBOUND extended permit tcp any interface outside eq www
access-list INBOUND extended permit tcp any interface outside eq pop3
access-list INBOUND extended permit tcp any interface outside eq imap4
access-list INBOUND extended permit tcp any interface outside eq 993
access-list INBOUND extended permit tcp any interface outside eq 88
access-list INBOUND extended permit tcp any interface outside eq ldap
access-list INBOUND extended permit tcp any interface outside eq ldaps
access-list INBOUND extended permit tcp any interface outside eq 3389
access-list INBOUND extended permit tcp any interface outside eq 1604
access-list INBOUND extended permit tcp any interface outside eq citrix-ica
access-list INBOUND extended permit icmp any any echo-reply
access-list INBOUND extended permit icmp any any unreachable
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu Exchange 1500
mtu management 1500
mtu ACCOUNTING 1500
no failover
monitor-interface outside
monitor-interface inside
monitor-interface Exchange
monitor-interface management
monitor-interface ACCOUNTING
asdm image disk0:/asdm505.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
nat (inside) 1 10.8.1.0 255.255.255.0
nat (management) 0 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface smtp JRA-XSERVE1 smtp netmask 255.255.255.255
static (inside,outside) tcp interface www JRA-XSERVE1 www netmask 255.255.255.255
static (inside,outside) tcp interface pop3 JRA-XSERVE1 pop3 netmask 255.255.255.255
static (inside,outside) tcp interface imap4 JRA-XSERVE1 imap4 netmask 255.255.255.255
static (inside,outside) tcp interface 993 JRA-XSERVE1 993 netmask 255.255.255.255
static (inside,outside) tcp interface 88 JRA-XSERVE1 88 netmask 255.255.255.255
static (inside,outside) tcp interface ldap JRA-XSERVE1 ldap netmask 255.255.255.255
static (inside,outside) tcp interface ldaps JRA-XSERVE1 ldaps netmask 255.255.255.255
static (inside,outside) tcp interface 3389 ATROPOS 3389 netmask 255.255.255.255
static (inside,outside) tcp interface 1604 WTS1 1604 netmask 255.255.255.255
static (inside,outside) tcp interface citrix-ica WTS1 citrix-ica netmask 255.255.255.255
static (Exchange,outside) 208.xxx.xxx.99 10.8.2.10 netmask 255.255.255.255
static (ACCOUNTING,inside) 10.8.3.0 10.8.3.0 netmask 255.255.255.0
static (inside,ACCOUNTING) 10.8.1.0 10.8.1.0 netmask 255.255.255.0
access-group INBOUND in interface outside
route outside 0.0.0.0 0.0.0.0 208.xxx.xxx.97 1
route inside 10.1.1.0 255.255.255.0 10.8.1.1 2
route ACCOUNTING 10.1.1.0 255.255.255.0 10.8.3.2 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 management
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd lease 3600
dhcpd ping_timeout 50
dhcprelay server 10.8.1.10 outside
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect dns maximum-length 512
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
Cryptochecksum:7f4066e36f28f873e5cc366f33bc1526
: end

RUNNING CONFIGURATION of the PIX 501:

PIX Version 6.3(4)                  
interface ethernet0 auto                        
interface ethernet1 100full                          
nameif ethernet0 outside security0                                  
nameif ethernet1 inside security100                                  
enable password 1q1dWhr/XLfzW0/Y encrypted                                          
passwd 2KFQnbNIdI.2KYOU encrypted                                
hostname pixfirewall                    
domain-name ciscopix.com                        
fixup protocol dns maximum-length 512                                    
fixup protocol ftp 21                    
fixup protocol h323 h225 1720                            
fixup protocol h323 ras 1718-1719                                
fixup protocol http 80                      
fixup protocol rsh 514                      
fixup protocol rtsp 554                      
fixup protocol sip                
fixup protocol sip udp 5060                          
fixup protocol skinny 2000                          
fixup protocol smtp 25                      
fixup protocol sqlnet 1521                          
fixup protocol tftp 69                      
names    
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 192.168                                                                                
.1.0 255.255.255.0                  
access-list outside_cryptomap_20 permit ip 192.168.1.0 255.255.255.0 192.168.1.0                                                                                
 255.255.255.0              
access-list INBOUND permit icmp any any echo-reply                                                  
access-list INBOUND permit icmp any any unreachable                                                  
pager lines 24              
mtu outside 1500                
mtu inside 1500              
ip address outside 10.8.3.2 255.255.255                                    
ip address inside 10.1.1.1 255.255.255.0                                        
ip audit info action alarm                          
ip audit attack action alarm                            
pdm location 10.0.1.0 255.255.255.0 outside                                          
pdm location 192.168.1.0 255.255.255.0 outside                                              
pdm logging informational 100                            
pdm history enable                  
arp timeout 14400                
global (outside) 1 interface                            
nat (inside) 0 access-list inside_outbound_nat0_acl                                                  
nat (inside) 1 0.0.0.0 0.0.0.0 0 0                                  
static (inside,outside) 10.1.1.0 10.1.1.0 netmask 255.255.255.0 0 0                                                                  
static (outside,inside) 10.8.3.0 10.8.3.0 netmask 255.255.255.0 0 0                                                                  
access-group INBOUND in interface outside                                        
route outside 0.0.0.0 0.0.0.0 10.8.3.1 1                                        
timeout xlate 0:05:00                    
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00                                                                            
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00                                                              
timeout uauth 0:05:00 absolute                              
aaa-server TACACS+ protocol tacacs+                                  
aaa-server TACACS+ max-failed-attempts 3                                        
aaa-server TACACS+ deadtime 10                              
aaa-server RADIUS protocol radius                                
aaa-server RADIUS max-failed-attempts 3                                      
aaa-server RADIUS deadtime 10                            
aaa-server LOCAL protocol lo                          
http server enable                  
http 192.168.1.0 255.255.255.0 inside                                    
no snmp-server location                      
no snmp-server contact                      
snmp-server community public                            
no snmp-server enable traps                          
floodguard enable                
sysopt connection permit-ipsec                              
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac                  
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 10.0.1.1
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 192.168.1.1 netmask 255.255.255.255 no-xauth no-conf
ig-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 10.1.1.2-10.1.1.8 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:d01b52ec78345d3c7927746a6bef8ab0
: end

Thanks again for you guys' help.

Pete
0
Comment
Question by:peter_ophoven
3 Comments
 
LVL 10

Assisted Solution

by:srgilani
srgilani earned 100 total points
ID: 17818189
first of all this static route is wrong.

route inside 10.1.1.0 255.255.255.0 10.8.1.1 2

your accounting network 10.1.1.9 is accessable through 10.8.3.1 while you have given above static route.



0
 
LVL 79

Accepted Solution

by:
lrmoore earned 400 total points
ID: 17818342
You don't need this:
  static (ACCOUNTING,inside) 10.8.3.0 10.8.3.0 netmask 255.255.255.0

Keep this:
  static (inside,ACCOUNTING) 10.8.1.0 10.8.1.0 netmask 255.255.255.0

Agree with srgilani above:
  >route inside 10.1.1.0 255.255.255.0 10.8.1.1 2
Change to
  route ACCOUNTING 10.1.1.0 255.255.255.0 10.8.3.2 1


On the 501, you don't need this:
  static (outside,inside) 10.8.3.0 10.8.3.0 netmask 255.255.255.0 0 0        

If this is all of your INBOUND acl, then you have not allowed anything in to the host 10.1.1.9
 access-list INBOUND permit icmp any any echo-reply                                                  
 access-list INBOUND permit icmp any any unreachable

Add:
  access-list INBOUND permit ip 10.8.1.0 255.255.255.0 host 10.1.1.9
                                                     
0
 

Author Comment

by:peter_ophoven
ID: 18285030
I apologize for leaving this open as long as I did.

Thanks for your help.

Pete
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now