?
Solved

Linux will not start - probably a mounting problem.

Posted on 2006-10-27
6
Medium Priority
?
290 Views
Last Modified: 2013-12-16
I am newbie with Linux.

I did a terrible mistake and I hope it can be fixed easily without losing any data.

I installed FC5 and worked with it for few months.

I have the last kernel 2.6.18

I have an IDE HD (hdc1)

Few days ago I've installed a new SATA HD (I think marked as hds1).
I've created a new partition, a new logical volume and mount it. I set the mounting point to "/" ;(

The day after when I try to open the computer, the Linux boot halt at the middle with some errors "...FC5 cannot touch /var/lock/subsys/kudzu Read-only".

I tried to use the DVD in order to "upgrade" the OS. At some point I've got that its cannot find the "/" and I might have a problem with the stable file.

I am almost sure that I need to remove the new mounting point in order to make it work.

I used a live CD in order to get into hdc1.
I tried to change the ro to rw in the grub config file. nothing helped.

this is how my system looks like:

Disk /dev/hdc: 41.1 GB, 41174138880 bytes
255 heads, 63 sectors/track, 5005 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdc1   *           1          13      104391   83  Linux
/dev/hdc2              14        5005    40098240   8e  Linux LVM
root@slax:~#


root@slax:/mnt/hdc1# ls -lh
total 8.6M
-rw-r--r-- 1 root root 834K Sep 11 05:44 System.map-2.6.17-1.2187_FC5smp
-rw-r--r-- 1 root root 861K Oct 14 21:27 System.map-2.6.18-1.2200.fc5smp
-rw-r--r-- 1 root root  65K Sep 11 05:44 config-2.6.17-1.2187_FC5smp
-rw-r--r-- 1 root root  69K Oct 14 21:27 config-2.6.18-1.2200.fc5smp
drwxr-xr-x 2 root root 1.0K Oct 27 10:31 grub/
-rw-r--r-- 1 root root 1.7M Sep 28 03:28 initrd-2.6.17-1.2187_FC5smp.img
-rw-r--r-- 1 root root 1.7M Oct 19 01:36 initrd-2.6.18-1.2200.fc5smp.img
drwx------ 2 root root  12K Mar 23  2006 lost+found/
-rw-r--r-- 1 root root 1.8M Sep 11 05:44 vmlinuz-2.6.17-1.2187_FC5smp
-rw-r--r-- 1 root root 1.8M Oct 14 21:27 vmlinuz-2.6.18-1.2200.fc5smp


Can someone help me with that. I have no idea what to do.
Please write the required steps in detail.

Many thanks,
Shay
0
Comment
Question by:shy_amar
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
6 Comments
 

Author Comment

by:shy_amar
ID: 17818217
BTW, you don't see the SATA HD because the I have a mother board chip that required kernel 2.6.18 to support it.
The live CD has an older kernel version.
In any case the OS was installed on the first HD (IDE)
0
 
LVL 30

Accepted Solution

by:
Kerem ERSOY earned 2000 total points
ID: 17824166
Hi,

From your fdisk output:

Your
/dev/hdc1 is your boot  volume
and /dev/hdc2 is your LVM - Logical Volume Manager partition.

Things seems pretty normal here.

To mount your LVM partition please me sure that your livecd includes lvm2 modules:

modprobe dm-mod     (to load lvm modules into the memory  f they are not aready there. If this step fails go grab another  live distro with lvm support)
vgchange -ay
mkdir -p /mnt/VolGroup00/LogVol00
mount /dev/VolGroup00/LogVol00 /mnt/VolGroup00/LogVol00

This should bring up your settings

now go to your etc directory  (not the live CD distro your mounted root)
edit the mtab file to read :
/dev/mapper/VolGroup00-LogVol00 / ext3 rw 0 0

for the root and reboot.
 
Cheers,
K.

 
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 17824169
Anyway let me know what happens when you mount etc.
0
 
LVL 30

Expert Comment

by:Kerem ERSOY
ID: 17829202
Your etc directory is found under /mnt/VolGroup00/LogVol00/etc and the contents of the mtab file should be similar to that:
 

/dev/mapper/VolGroup00-LogVol00 / ext3 rw 0 0
none /proc proc rw 0 0



0

Featured Post

Give Your Engineering Team a Productivity Boost

Learn why container technology is so powerful and how it can provide your team with productivity gains and other benefits.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Little introduction about CP: CP is a command on linux that use to copy files and folder from one location to another location. Example usage of CP as follow: cp /myfoder /pathto/destination/folder/ cp abc.tar.gz /pathto/destination/folder/ab…
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses
Course of the Month14 days, 8 hours left to enroll

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question