Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

How to stop W2k3 Term Svr from logging Event ID:1111 Printer "Driver X is Unknown" errors in the system log

Posted on 2006-10-27
5
Medium Priority
?
2,811 Views
Last Modified: 2012-08-14
When my terminal server users login I keep getting errors in the system log similar to the one below. I understand why this error is coming up.  I do not need or want to install these printer drivers on the server.  I use Screwdrivers for terminal server client printing and it works great.  I just want to get rid of the error logging in the system events.

Any Ideas would be greatly appreciated!

Thank you!

Event Viewer - System Log

Event Type:      Error
Event Source:      TermServDevices
Event Category:      None
Event ID:      1111
Description:
Driver hp officejet 4200 series fax required for printer hp officejet 4200 series fax is unknown.
Contact the administrator to install the driver before you log in again.
0
Comment
Question by:ChrisKremer
  • 3
  • 2
5 Comments
 
LVL 8

Expert Comment

by:caddlady
ID: 17818781
Easiest ways:

Do not allow them to bring printers with them when they logon to TS

or

Install the driver on the server
0
 
LVL 2

Author Comment

by:ChrisKremer
ID: 17854079
caddlady

Thank you for your recommendation.

Installing the printer drivers is not an option.

I have tried to set a group policy that restricts adding the printer but it does not work. I still keep getting the errors.

How would "not allow them to bring printers with then when they login to TS" ?

Thank you for your input. Obviously this is a complex issue otherwise their would have been other posts.
0
 
LVL 8

Expert Comment

by:caddlady
ID: 17857817
Do you use AD?

One way to stop it is:     if you look at a user's properties, there is an Environment tab that deals with the Startup Environment when that user connects via TS.  Uncheck the box that says "Connect Client Printers at Logon".

0
 
LVL 8

Accepted Solution

by:
caddlady earned 2000 total points
ID: 17857862
Otherwise, if you do not want any TS connections to try and connect their printers, etc.    Go to Terminal Services Configuration,  Connections,  RDP-Tcp properties, Client Settings tab,  Uncheck Use Connections Settings from User Settings, and then check or uncheck whatever devices you do or do not want them to bring with them when they connect!
0
 
LVL 2

Author Comment

by:ChrisKremer
ID: 17880486
caddlady;

 Thank you for your suggestions and for helping me to solve my issue! The printers errors are not logged in the system log any more. I finally have resolved all the windows logging errors in the event viewer.

ChrisKremer
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Organizations create, modify, and maintain huge amounts of data to help their businesses earn money and generally function.  Typically every network user within an organization has a bit of disk space to store in process items and personal files.   …
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…
Loops Section Overview

963 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question