We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

DNS problems on Win XP machines

Medium Priority
292 Views
Last Modified: 2010-08-05
Good day.  Recently our Internet provider changed their DNS servers and required all the accounts to do the same.  Our setup before was:  Primary DNS on all computers was the local server here in our building.  Alternate was the providers DNS server.  When we moved the alternate to the new provider server we lost the ablility to use msn messenger, email and to use the internet unless we knew the IP address of the site we are going to.  By putting in the Primary and Alternate from the provider all internet functionality returned, but we had trouble with our computers access some network resources.  By going into the advanced tab and entereing the local server as a third DNS that appeared to work on all Win 98 and 2k machines.  Xp machines are still having trouble with local resources.....any help would be greatly appreciated.

Comment
Watch Question

CERTIFIED EXPERT
Top Expert 2013

Commented:
Assuming you have a domain, and active directory installed, the client machines should ONLY point to your internal DNS server. No ISP DNS servers at all. Then in the DNS management console, under Forwarders, you should add the ISP's DNS. Remove any old ones, if they exist. Also make sure your DHCP server is handing out your DNS server's IP with scope option #006. Using other than your internal DNS can result in slow logons and un-applied group policies, with your W2K and XP machines. Win8x and NT prefer a WINS server if you have one set up.

Author

Commented:
Excellent, thank you for your quick response.  I am looking at the DNS management window and see all the local computers and hosts.  I see no other addresses, either the old providers DNS addresses or the new ones.  How do I add the address from the ISP?
Bradley FoxLAN/WAN Systems Administrator
CERTIFIED EXPERT

Commented:
Open DNS Management, RC the server name, properties, forwarders tab
Enter your ISP's DNS servers here and make sure it says "all other dns domains" in the DNS Domain field.

On your clients ONLY point them to your Internal DNS servers.  If you have more than 1 domain controller enter 1 as the primary and the other as the secondary.  When the client does a DNS query the DNS server will figure out if it's internal (will resolve itself) or if it's external (will query the ISP's dns servers).
CERTIFIED EXPERT
Top Expert 2013
Commented:
Open the DNS management console and click on the server name in the left window (sometimes have to click twice). In the right hand Window you will see forwarders. Double click on that and on the Forwarders tab enter the ISP's DNS in the "selected domain's forwarder IP and click add.
You can add several for insurance.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
CERTIFIED EXPERT
Top Expert 2013

Commented:
Sorry mcsween, I see we posted at the same time.

Author

Commented:
Ok, found and entered that.  I do not have the "all other dns domains"  Enable forwarders is checked, recursion is not.   I am using 2k Advanced as a server os... Is the "all other dns domains" something that is an option on this version?
Bradley FoxLAN/WAN Systems Administrator
CERTIFIED EXPERT

Commented:
sorry, when I was looking for the exact steps I was using my W2k3 Server.  You should be all set...that option does not exist on W2k.  It's an option to setup different forwarders for different domains.

Author

Commented:
Excellent..THank you both.  Since RobWill was first to respond I will give them the points.  McSween, thank you as well.
CERTIFIED EXPERT
Top Expert 2013

Commented:
Thanks missinglink28604 , though I have no problem if you wish to re-open and split the points.
Cheers,
--Rob
Bradley FoxLAN/WAN Systems Administrator
CERTIFIED EXPERT

Commented:
dont bother...not necessary  RobWill had the correct answer first...no biggie :)
CERTIFIED EXPERT
Top Expert 2013

Commented:
:-)  Thanks mcsween.
--Rob
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.