Solved

AAAARGH Why wont PIX VPN come up

Posted on 2006-10-27
11
2,453 Views
Last Modified: 2013-11-16
As Symantec have stopped producing small firewalls my firm has finally started shipping PIX firewalls

Ive just tried to set up a VPN (site to site on the bench) and it will not connect please see below


PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 6F9WTj1TxzG5ntGC encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pix1234
domain-name doofah.net
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 10.1.0.0 test
access-list inside_outbound_nat0_acl permit ip any test255.255.0.0
access-list outside_cryptomap_20 permit ip any test255.255.0.0
access-list inside_access_in permit ip any any
access-list inside_access_in permit tcp any any
access-list inside_access_in permit icmp any any
access-list outside_access_in permit icmp any any
pager lines 24
logging on
logging monitor debugging
mtu outside 1500
mtu inside 1500
ip address outside 217.22.146.108 255.255.255.248
ip address inside 172.17.1.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 172.17.1.0 255.255.255.255 inside
pdm location test 255.255.0.0 outside
pdm logging debugging 100
pdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 10 0.0.0.0 0.0.0.0 0 0
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 217.22.146.105 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 172.17.1.0 255.255.255.255 inside
http 172.17.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set pfs group2
crypto map outside_map 20 set peer 217.22.146.105
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 217.22.146.105 netmask 255.255.255.255 no-xauth no-config-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet 172.17.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:8aab2bd20149355b5eca7e2120a00d19
: end


The result of a Debug................



pix1234# debug crypto isakmp
pix1234#
ISAKMP (0): beginning Main Mode exchange
crypto_isakmp_process_block:src:217.22.146.105, dest:217.22.146.108 spt:500 dpt:
500
OAK_MM exchange
ISAKMP (0): processing SA payload. message ID = 0

ISAKMP (0): Checking ISAKMP transform 1 against priority 20 policy
ISAKMP:      encryption DES-CBC
ISAKMP:      hash SHA
ISAKMP:      default group 2
ISAKMP:      auth pre-share
ISAKMP:      life type in seconds
ISAKMP:      life duration (VPI) of  0x0 0x1 0x51 0x80
ISAKMP (0): atts are acceptable. Next payload is 0
ISAKMP (0): SA is doing pre-shared key authentication using id type ID_FQDN
return status is IKMP_NO_ERROR
crypto_isakmp_process_block:src:217.22.146.105, dest:217.22.146.108 spt:500 dpt:
500
OAK_MM exchange
ISAKMP (0): processing KE payload. message ID = 0

ISAKMP (0): processing NONCE payload. message ID = 0

ISAKMP (0): ID payload
        next-payload : 8
        type         : 2
        protocol     : 17
        port         : 500
        length       : 24
ISAKMP (0): Total payload length: 28
return status is IKMP_NO_ERROR
ISAKMP (0): retransmitting phase 1 (0)...
ISAKMP (0): retransmitting phase 1 (1)...
ISAKMP (0): retransmitting phase 1 (2)...
ISAKMP (0): retransmitting phase 1 (3)...
ISAKMP (0): retransmitting phase 1 (4)...
ISAKMP (0): deleting SA: src 217.22.146.108, dst 217.22.146.105
ISADB: reaper checking SA 0xf42974, conn_id = 0  DELETE IT!

VPN Peer:ISAKMP: Peer Info for 217.22.146.105/500 not found - peers:0

pix1234#
0
Comment
Question by:Pete Long
  • 6
  • 5
11 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 17820318
Since you've only posted one side, can I assume that the other one is a mirror image of this one?
Do you have an actual host sitting behind each PIX pinging each other?
On host 10.1.0.x set a continuous ping to host 172.17.1.x
Then post result of "show cry is sa" and "show cry ip sa"
0
 
LVL 57

Author Comment

by:Pete Long
ID: 17820349
The other side is a SGS420 (yes I know but we have hundreds of the things deployed) :(

Yess Hosts are behind each Firewall - will post info in a sec..................
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17820375
These are back-back in a lab?

>crypto map outside_map 20 set transform-set ESP-3DES-SHA
>isakmp policy 20 encryption des

Your transform = 3DES
Your policy = DES
Change the policy to 3DES, or change to transform to DES, whichever will match the SGS
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 57

Author Comment

by:Pete Long
ID: 17820414


pix1234# show cry is sa
Total     : 0
Embryonic : 0
        dst               src        state     pending     created
pix1234#
ISAKMP (0): beginning Main Mode exchange
crypto_isakmp_process_block:src:217.22.146.105, dest:217.22.146.108 spt:500 dpt:
500
OAK_MM exchange
ISAKMP (0): processing SA payload. message ID = 0

ISAKMP (0): Checking ISAKMP transform 1 against priority 20 policy
ISAKMP:      encryption 3DES-CBC
ISAKMP:      hash SHA
ISAKMP:      default group 2
ISAKMP:      auth pre-share
ISAKMP:      life type in seconds
ISAKMP:      life duration (basic) of 28800
ISAKMP (0): atts are acceptable. Next payload is 0
ISAKMP (0): SA is doing pre-shared key authentication using id type ID_FQDN
return status is IKMP_NO_ERROR
crypto_isakmp_process_block:src:217.22.146.105, dest:217.22.146.108 spt:500 dpt:
500
OAK_MM exchange
ISAKMP (0): processing KE payload. message ID = 0

ISAKMP (0): processing NONCE payload. message ID = 0

ISAKMP (0): ID payload
        next-payload : 8
        type         : 2
        protocol     : 17
        port         : 500
        length       : 24
ISAKMP (0): Total payload length: 28
return status is IKMP_NO_ERROR
crypto_isakmp_process_block:src:217.22.146.105, dest:217.22.146.108 spt:500 dpt:
500
ISAKMP: drop P2 msg on unauthenticated SA

ISAKMP (0): retransmitting phase 1 (0)...
ISAKMP (0): retransmitting phase 1 (1)...
ISAKMP (0): retransmitting phase 1 (2)...
ISAKMP (0): retransmitting phase 1 (3)...
ISAKMP (0): retransmitting phase 1 (4)...
ISAKMP (0): deleting SA: src 217.22.146.108, dst 217.22.146.105
ISADB: reaper checking SA 0xfd97dc, conn_id = 0  DELETE IT!

VPN Peer:ISAKMP: Peer Info for 217.22.146.105/500 not found - peers:0

pix1234# show cry ip sa


interface: outside
    Crypto map tag: outside_map, local addr. 217.22.146.108

   local  ident (addr/mask/prot/port): (0.0.0.0/0.0.0.0/1/0)
   remote ident (addr/mask/prot/port): (0.0.0.0/0.0.0.0/1/0)
   current_peer: 217.22.146.105:0
     PERMIT, flags={origin_is_acl,}
    #pkts encaps: 0, #pkts encrypt: 0, #pkts digest 0
    #pkts decaps: 0, #pkts decrypt: 0, #pkts verify 0
    #pkts compressed: 0, #pkts decompressed: 0
    #pkts not compressed: 0, #pkts compr. failed: 0, #pkts decompress failed: 0
    #send errors 12, #recv errors 0

     local crypto endpt.: 217.22.146.108, remote crypto endpt.: 217.22.146.105
     path mtu 1500, ipsec overhead 0, media mtu 1500
     current outbound spi: 0

     inbound esp sas:


     inbound ah sas:


     inbound pcp sas:


     outbound esp sas:


     outbound ah sas:


     outbound pcp sas:



   local  ident (addr/mask/prot/port): (0.0.0.0/0.0.0.0/0/0)
   remote ident (addr/mask/prot/port): (Coniston/255.255.0.0/0/0)
   current_peer: 217.22.146.105:0
     PERMIT, flags={origin_is_acl,}
    #pkts encaps: 0, #pkts encrypt: 0, #pkts digest 0
    #pkts decaps: 0, #pkts decrypt: 0, #pkts verify 0
    #pkts compressed: 0, #pkts decompressed: 0
    #pkts not compressed: 0, #pkts compr. failed: 0, #pkts decompress failed: 0
    #send errors 12, #recv errors 0

     local crypto endpt.: 217.22.146.108, remote crypto endpt.: 217.22.146.105
     path mtu 1500, ipsec overhead 0, media mtu 1500
     current outbound spi: 0

     inbound esp sas:


     inbound ah sas:


     inbound pcp sas:


     outbound esp sas:


     outbound ah sas:


     outbound pcp sas:


pix1234#



Ill be offline for about 45 mins :)
0
 
LVL 57

Author Comment

by:Pete Long
ID: 17820965
Back home now

>>These are back-back in a lab?

Yes - We are going to be shipping a lot of 506E's to fill the gap left by the 100,200,300 and 400 series SGS units we used to sell
We will still be selling the 1600 and 5400's (PIX 515/525 equivalents if you haven't seen them)

>>Your transform = 3DES
>>Your policy = DES

OK will check that on Monday morning :)

 - These are brand new firewalls - I though we were on v7 now? does the 506 only support 6.3?

and

 - All my colleagues are used to Nice shiny Web consoles to configure firewall - I know we have the PDM - but I still find I can get things done easier with the CLI - I tried to set up port forwarding through the PDM today - and just gave up :( two lines in the CLI and it was working fine - whats the PDM like for thinks like Gateway to Gateway VPN's and Client to Gateway VPN's  - If its not good I can see my workload increasing :(
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17821966
You have to fix the transform to match the policy to match the SGS

506 only supports v 6.3
Since the ASA5505 has been released, no more development toward porting 7.0 to 501/506

The PDM GUI does have nice VPN wizard that makes the vpn setup quite simple.

Agree that a simple change like a static port xlate is much easier with CLI...

have a good weekend!
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 17821982
>access-list inside_outbound_nat0_acl permit ip any test255.255.0.0
>access-list outside_cryptomap_20 permit ip any test255.255.0.0

I also highly recommend making these quite specific <local lan/mask> <remote lan/mask>

access-list inside_outbound_nat0_acl permit ip 172.17.1.0 255.255.255.0 test 255.255.0.0
access-list outside_cryptomap_20 permit ip 172.17.1.0 255.255.255.0 test 255.255.0.0

With exact mirrors on the other side:
 local lan 10.1.0.0 255.255.255.0
 remote lan 172.17.1.0 255.255.255.0
0
 
LVL 57

Author Comment

by:Pete Long
ID: 17825933
Cheers m8y Ill sort that out on Monday :) Have a good 1

Pete
0
 
LVL 57

Author Comment

by:Pete Long
ID: 17835159
Thanks Again

Do you have a good link to analysing debug crypto commands in a step by step format?


Pete
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17836752
Unfortunately, no. it's really not that difficult because you have 2 phases to troubleshoot.
sho cry is sa = phase 1 = blank, MM_something  or QM_IDLE
 debugs show 'atts accecptable' or not acceptable
 if not acceptable, then you have mismatch of policy
sho cry ip sa = phase 2 tunnel definition.
  tunnels match on both ends with mirror image
  your end "any" to Coniston
  = their end Coniston to "any" ? ?
you can see what problems that would create

   local  ident (addr/mask/prot/port): (0.0.0.0/0.0.0.0/0/0)  <== theirs can't match 'any'
    remote ident (addr/mask/prot/port): (Coniston/255.255.0.0/0/0)
 
encrypt/decrypt counters and error counters.
apparent 1-way traffic = encrypt on one end no decrypt on the other = routing issues.
If phase 1 doesn't come up, no need to debug further until it does.
0
 
LVL 57

Author Comment

by:Pete Long
ID: 17837934
OK

Phase 1  establishes the SA's and is usually tested with

show cry is sa

To see if I'm establishing phase 1 I'm looking for 'atts acceptable'
 if it fails at this point then either the shared secret is wrong/mismatched or what else?

Phase 2

Is defined by the cryptomap? and {the interesting traffic} applied to the outside interface via a 'no nat' acl?

tested with

show cry ip sa

^^^ Am I on the right track?

why is there a transform set and a policy? is the transform for key exchange to establish SA and the policy to encrypt the traffic?

Sheesh you can tell Its been a year since I sat this exam - far too long working on SEF's and Raptors LOL
0

Featured Post

Active Directory Webinar

We all know we need to protect and secure our privileges, but where to start? Join Experts Exchange and ManageEngine on Tuesday, April 11, 2017 10:00 AM PDT to learn how to track and secure privileged users in Active Directory.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Span IP Range across two sites via Cisco ASA Site-to-Site VPN 8 51
Download Logs File from Cisco Switch 1 63
clear arp 1 38
Cisco RV042G 4 7
If you have an ASA5510 then this sort of thing would be better handled with a CSC Module, however on an ASA5505 thats not an option, and if you want to throw in a quick solution to stop your staff going to facebook during work time, then this is the…
This article will cover setting up redundant ISPs for outbound connectivity on an ASA 5510 (although the same should work on the 5520s and up as well).  It’s important to note that this covers outbound connectivity only.  The ASA does not have built…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question