[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1611
  • Last Modified:

trying to install curlftpfs but no glib-2.0 found

I am trying to install curlftpfs-0.9 on Fedora Core 4. When I run ./configure I am told that glib-2.0 is required but not found. Should I do a "yum install glib-2.0" or will I screw other things up?

My goal is to setup the ability to mount a remote ftp server as a filesystem so I can backup files to it directly. I installed FUSE and Curl but need to get the curlftpfs piece installed to finish. If I'm making this harder then it needs to be or you have a better way to do this feel free to clue me in.

I have a root server at a hosting company and they provide an ftp server for backup. I want ot be able to backup not just files via ftp using mput commands but my whole server including some MySQL databases.

I'm a Linux newbie so simpler is better :) Thanks in advance for the help
0
maagnh
Asked:
maagnh
1 Solution
 
ygouthamCommented:
yum install xxx would not "screw" things up for you.  you can go ahead and do it.  

yum does not uninstall any package.  but if any additional package is required for installation, then it does so by default so as to not change any other packages which are installed, and the same are also provided the ability to run satisfactorily.

ftp://ftp.gtk.org/pub/glib/2.12/

this also gives the repository from gtk for the latest and stable versions source file downloads.  if you so wish then you can download the specific file and compile it from source.  much similar with "./configure" , etc.

goutham
0
 
nociSoftware EngineerCommented:
You might be better of with this one as it doesn't transmit usernames & password unencrypted over the (inter-)net. (secure shell file system)

http://shfs.sourceforge.net/

Otherwise i agree with ygoutham
0
 
maagnhAuthor Commented:
OK here's where I'm at.

I did a 'yum list available' and saw glib2-devel listed so I then did a yum install glib2-devel which worked without errors. I then ran the ./configure again for curlftpfs which came back with the following

error: package requirements (fuse >=2.2) were not met

so I proceeded with installing one item after another because every time I installed something it needed something else or soem "dependency' wasn't met, argh :(

I will mark this as answered because I think your answer is right but my lack of linux knowledge and experience is getting in the way.

Thanks.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now