• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 375
  • Last Modified:

nfs mount times

I'm mounting a remote path via NFS but it is taking a really long time to mount each time.  I have changed the rsize and wsize but it always takes 1:45 to mount the path.  Is there anything I can do to make it faster?

server:/nightly.0/user /home/user/nightly.0/ nfs ro,hard,rsize=3276,wsize=32768,timeo=1,intr 0 0

time mount /home/user/nightly.0/

real    1m45.018s
user    0m0.000s
sys     0m0.012s

cat /etc/redhat-release
CentOS release 4.4 (Final)
0
bryanlloydharris
Asked:
bryanlloydharris
  • 5
  • 2
2 Solutions
 
ssvlCommented:
what about ping reply

is you use the server name ip address

if name check the /etc/hosts and /etc/resolv.conf file
0
 
bryanlloydharrisAuthor Commented:
I added to /etc/hosts and it's still slow.  Is that what you meant?
0
 
bryanlloydharrisAuthor Commented:
Here are the ping times.

icmp_seq=0 ttl=63 time=0.431 ms
icmp_seq=1 ttl=63 time=0.590 ms
icmp_seq=2 ttl=63 time=0.415 ms
icmp_seq=3 ttl=63 time=0.341 ms
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
bryanlloydharrisAuthor Commented:
Is there anything else I should put to make it clear of my intentions with the remote mounting?
0
 
ygouthamCommented:
bryan

when you try a reverse mount (the other way around than what you are currently trying), does it happen fast enuf for you???

try enabling vsftpd or some other transfer mechanism to see if the machine to machine copy times are integral.  

the idea is to see if the CAT5 cable is at fault or not. once we ensure that it is working satisfactorily, then try restarting the sshd service and nfs service (to remove any stale sockets that might be hanging around).  if it is an ext3 to ext3 mount then it should not be taking so much time.  

just my thoughts.

0
 
bryanlloydharrisAuthor Commented:
I have actually solved the problem in a way which I don't understand.  Would anybody please let me know why it is working quickly now?

I noticed that nfsd was only running on the server, not the client.  When I tried to start nfs, I noticed it took a long time.  So then I thought to put the following line in /etc/exports to make the computer automatically start nfsd upon bootup.

/tmp 127.0.0.1(ro)

I don't really use this, but I put it there(along with some lines in /etc/hosts.allow and /etc/hosts.deny for the server computer) and now nfsd starts upon bootup of the computer.

Now when I mount an nfs partition from the server onto a directory of the client it works in about 0.04 seconds.
0
 
ygouthamCommented:
nfs mount is not contingent upon nfs service running in the client machine.  try undoing the /tmp part and see if the problem persists.  it might be related to something else and do not jump to conclusions without having identified the problem. check if the nfs times are getting stretched when you stop nfs service in the client as a precaution so that we isolate that to be the problem.

goutham
0
 
bryanlloydharrisAuthor Commented:
I think I have figured it out now, thanks for all the help!
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now