Solved

ThinkPad T42p - Wireless Radio Won't Enable After Windows Update

Posted on 2006-10-27
13
9,409 Views
Last Modified: 2011-08-18
I just did a restore of this computer back to factory state.  I then upgraded all of the ThinkPad software.  At this point my wireless was working fine.  After this I let windows update install all of the updates it wanted.  Now the wireless card doesn't work correctly.  The ThinkPad utilities don't seem to be able to control the card at all.  I did uncheck the windows controlling wireless box in the device settings, but still no dice.  Anyone?  Need help here ASAP.
0
Comment
Question by:efaden
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +2
13 Comments
 
LVL 39

Expert Comment

by:PUNKY
ID: 17826194
Have you uninstalled drivers and re-installed it yet? If you updated windows, then the card should be updated up-to-date version as well. Try it see if it helps. If not, please post back.

The card must be seen in device manager, if not it is issue detecting hardware, and if it is a case, please let me know what kinda a card (usb or PCMCIA type)?
0
 

Author Comment

by:efaden
ID: 17827018
It detects it just fine.  I tried uninstalling and reinstalling.  No luck.   After some messing with it there seems to be some sort of a conflict between the newest version of the IBM foo and the Windows updates.  Not sure exactly what or how to fix it though.  I think for now I am just going to not use windows update.
0
 
LVL 39

Expert Comment

by:PUNKY
ID: 17827410
Please explain more why the wireless card is not working correctly? could not connect internet / network or there is no signal?
0
Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

 
LVL 39

Expert Comment

by:PUNKY
ID: 17827420
As you said, it is detected fine, so it would show up in device manager without any yello mark, correct?

Moreover, firewall should be disable when you test internet / network. Also, check internet options to see Securities and Privacy are set default, then in Advance Tab set to default.
0
 

Author Comment

by:efaden
ID: 17828733
The card is enabled just fine.  It actually has something to do with the IBM software.  E.g. their IBM Access Connection program and the Wireless Card Util.  The IBM Access connection seems to think the radio is on, but just can't change its state, and the wireless driver util thinks that the radio is off.  The device itself actually works when the settings are done through Network Connections.  So I really think it is a bug with the IBM stuff.
0
 
LVL 39

Expert Comment

by:PUNKY
ID: 17829308
Please check the manual to see how turn off radio:

ftp://ftp.software.ibm.com/pc/pccbbs/mobiles_pdf/c79plac41.pdf 

Please try.
0
 
LVL 9

Expert Comment

by:bigjimbo813
ID: 17830496
have you verified the wireless card is enabled in the bios?
0
 
LVL 88

Expert Comment

by:rindi
ID: 17848533
Make sure that if you are using the IBM wireless utility the the wireless zero config tool is disabled, or vice versa. Your PC is probably trying to connect with both tools at once! Usually the windows wireless zero config tool is good enough and connects faster after a reboot than the manufacturer's tools, but often the manufacturer's tools are more customizable if it isn't too old.
0
 

Author Comment

by:efaden
ID: 17849091
Turned out to be a know bug with their drivers.  Somehow during the standard IBM Update it corrupted the power management driver.  Solution was to install everything in some specific order that the IBM folks gave me.
0
 

Expert Comment

by:ITPRO27
ID: 17908123
EFADEN,
what is the install order...I am experiencing a similar issue.
0
 

Accepted Solution

by:
ITPRO27 earned 500 total points
ID: 18044779
Download and install the "System Update" utility for your Thinkpad T42 notebook from the Lenovo support web site. Run "System Update" and choose to download the Intel ProSet Software from the list. When installing the Intel ProSet software do not install the driver, but rather just the application. This should allow you to utilize the "Thinkvantage Access connection" software along with the "Hotkey" buttons if you have that software installed.
0

Featured Post

Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Brother MFC-J6720DW Scan to Email 5 131
wifi not working 3 76
can't connect to wireless with ipad 12 91
Receiving wifi on an underground station 22 174
This article describes how to perform a hard reset on your router. Usually this is most-useful on wireless routers, but the same concept applies to nearly all home/SOHO routers. This process will return the router to factory defaults, so record your…
This article is split into background info to start and actual review at bottom: Some time ago I wanted to sell a system with both wired and wireless capability but at minimum expense.  Having visited my trusted online auction I was pleasantly su…
Finding and deleting duplicate (picture) files can be a time consuming task. My wife and I, our three kids and their families all share one dilemma: Managing our pictures. Between desktops, laptops, phones, tablets, and cameras; over the last decade…

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question