Solved

ThinkPad T42p - Wireless Radio Won't Enable After Windows Update

Posted on 2006-10-27
13
9,414 Views
Last Modified: 2011-08-18
I just did a restore of this computer back to factory state.  I then upgraded all of the ThinkPad software.  At this point my wireless was working fine.  After this I let windows update install all of the updates it wanted.  Now the wireless card doesn't work correctly.  The ThinkPad utilities don't seem to be able to control the card at all.  I did uncheck the windows controlling wireless box in the device settings, but still no dice.  Anyone?  Need help here ASAP.
0
Comment
Question by:efaden
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +2
13 Comments
 
LVL 39

Expert Comment

by:PUNKY
ID: 17826194
Have you uninstalled drivers and re-installed it yet? If you updated windows, then the card should be updated up-to-date version as well. Try it see if it helps. If not, please post back.

The card must be seen in device manager, if not it is issue detecting hardware, and if it is a case, please let me know what kinda a card (usb or PCMCIA type)?
0
 

Author Comment

by:efaden
ID: 17827018
It detects it just fine.  I tried uninstalling and reinstalling.  No luck.   After some messing with it there seems to be some sort of a conflict between the newest version of the IBM foo and the Windows updates.  Not sure exactly what or how to fix it though.  I think for now I am just going to not use windows update.
0
 
LVL 39

Expert Comment

by:PUNKY
ID: 17827410
Please explain more why the wireless card is not working correctly? could not connect internet / network or there is no signal?
0
Are You Headed to Black Hat USA 2017?

Getting ready for Black Hat next week? Kick things off with the WatchGuard Badge Challenge and test your puzzle and cipher skills. Do you have what it takes to earn our limited edition Firebox Badge? Get started today - https://crimsonthorn.net

 
LVL 39

Expert Comment

by:PUNKY
ID: 17827420
As you said, it is detected fine, so it would show up in device manager without any yello mark, correct?

Moreover, firewall should be disable when you test internet / network. Also, check internet options to see Securities and Privacy are set default, then in Advance Tab set to default.
0
 

Author Comment

by:efaden
ID: 17828733
The card is enabled just fine.  It actually has something to do with the IBM software.  E.g. their IBM Access Connection program and the Wireless Card Util.  The IBM Access connection seems to think the radio is on, but just can't change its state, and the wireless driver util thinks that the radio is off.  The device itself actually works when the settings are done through Network Connections.  So I really think it is a bug with the IBM stuff.
0
 
LVL 39

Expert Comment

by:PUNKY
ID: 17829308
Please check the manual to see how turn off radio:

ftp://ftp.software.ibm.com/pc/pccbbs/mobiles_pdf/c79plac41.pdf 

Please try.
0
 
LVL 9

Expert Comment

by:bigjimbo813
ID: 17830496
have you verified the wireless card is enabled in the bios?
0
 
LVL 88

Expert Comment

by:rindi
ID: 17848533
Make sure that if you are using the IBM wireless utility the the wireless zero config tool is disabled, or vice versa. Your PC is probably trying to connect with both tools at once! Usually the windows wireless zero config tool is good enough and connects faster after a reboot than the manufacturer's tools, but often the manufacturer's tools are more customizable if it isn't too old.
0
 

Author Comment

by:efaden
ID: 17849091
Turned out to be a know bug with their drivers.  Somehow during the standard IBM Update it corrupted the power management driver.  Solution was to install everything in some specific order that the IBM folks gave me.
0
 

Expert Comment

by:ITPRO27
ID: 17908123
EFADEN,
what is the install order...I am experiencing a similar issue.
0
 

Accepted Solution

by:
ITPRO27 earned 500 total points
ID: 18044779
Download and install the "System Update" utility for your Thinkpad T42 notebook from the Lenovo support web site. Run "System Update" and choose to download the Intel ProSet Software from the list. When installing the Intel ProSet software do not install the driver, but rather just the application. This should allow you to utilize the "Thinkvantage Access connection" software along with the "Hotkey" buttons if you have that software installed.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently purchased a Bluetooth headset called the Music Jogger (model BSH10). The control buttons on it look like this: One of my goals is to use it as the microphone and speakers for Skype calls. In that respect, it works well. However, I …
DECT technology has become a popular standard for wireless voice communication. DECT devices are not likely to be affected by other electronic devices and signals because they operate in a separate frequency-band.
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
Suggested Courses

635 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question