We help IT Professionals succeed at work.

Conflict Between Onboard Sata Controller and PCI IDE Contoller?

juandeaux
juandeaux asked
on
Medium Priority
774 Views
Last Modified: 2008-01-09
For a new XP installation, I set up RAID-1 (2 – WD 800JD/80GB) employing the built-in controller on a recently installed BioStar P4M80-M4 motherboard. I also have 4 IDE hard drives connected via the two channels provided on the motherboard. This configuration works fine, with the exception of having to ‘F9’ at startup to manually select the ‘Bootable Add-In Cards’ at the boot menu; if the IDE drives are not attached the system boots automatically. (The necessity of having press F9 every time is not the main problem, but I would be glad to know a way around it.)

When I connect an optical disk (or any hard drives) to the Ultra 100TX2, the startup sequence appears normal until it hangs up following “Verifying DMI Pool Data” and goes no farther. I assume that this is due to a conflict between the onboard SATA Controller and the Ultra, but I haven’t been able to figure out how to resolve it.

Any ideas?
Comment
Watch Question

Retired
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2009
Commented:
As for the boot issue ... look CAREFULLY in the BIOS boot options.  In most cases you can select the add-in card as the first boot device, but it's often "hidden" (i.e. not obvious) => there may be a separate option you have to enable rather than a simple selection in the Boot Order menu.   You may also be able to resolve it by being sure none of the partitions on the IDE drives are marked "Active"  (which will cause them to be skipped in the boot resolution process).

As for the conflict with the TX2 ... it's unlikely it's a conflict with the SATA controller, but it may be a conflict with your onboard IDE controller.   Try the card in a different PCI slot and see if that resolves it.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
Hey, switching the TX2 to a different slot eliminated that issue. I feel a little sheepish since I had thought of doing that, but didn’t. I should have gone with my intuition.

The situation now is that if I interrupt (F9) and select Bootable Add-In Cards, XP starts up and all drives are available to Windows, onboard IDE, SATA and TX2-connected. If the PC is left to start up automatically it terminates with BOOT DISK FAILURE, INSERT SYSTEM DISK ….. If there is a “feature” to designate the add-in card as the boot device it certainly isn’t obvious. I will do some more tinkering with the BIOS settings and maybe I’ll get lucky.

I suppose I should award you the points since you did resolve the main problem and it was sort of a two-part question. If I am unable to sort out the boot selection issue I will submit a new question later. Thanks.
Gary CaseRetired
CERTIFIED EXPERT
Most Valuable Expert 2013
Top Expert 2009

Commented:
You don't, by any chance, have any USB devices plugged in to the computer do you ?   (External hard drive; USB flash drive; SD, CF, Memory Stick devices; etc.)   If so, these can cause the same issue ... which you can resolve by disable "USB Boot" in the BIOS.

Author

Commented:
The only USB devices are the mouse and printer.

I fiddled around a bit and was able to hit on a setting that eliminated the boot problem. I set the Boot order to USB-FDD::CD-ROM::Hard Disk and voilà, the system boots up normally with all of the devices mounted and no manual intervention required.

Thanks a lot for the help.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.