[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

TGA With Transparancy

Posted on 2006-10-28
9
Medium Priority
?
245 Views
Last Modified: 2010-04-06
I have a BMP with a solid blue (0,0,225) background.

I need to export it to a TGA file, but the solid blue background must be transparant in the TGA file.

(This is so I can have transparancy in my Half-Life 2 spray, for those who need to know why it must be a TGA).

Thanks for the help.
0
Comment
Question by:boll0kk
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
9 Comments
 
LVL 38

Expert Comment

by:lherrou
ID: 17827153
boll0kk,

What software are you using? Or is that part of the question?

LHerrou

0
 

Author Comment

by:boll0kk
ID: 17828189
I have Photoshop CS 2, but if there's other software I have to get hold of then I'd like to know :)
0
 
LVL 38

Accepted Solution

by:
lherrou earned 360 total points
ID: 17828478
OK, try this:

Select the area you want to be transparent in the tga file.
Go to CHANNELS and add a new channel. It should be called Alpha by default.
CUT the selection out of this channel, this will create a mask. Now try saving as TGA (32 bits per pixel.)
0
Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

 
LVL 2

Assisted Solution

by:xqz
xqz earned 520 total points
ID: 17891693
Hi boll0kk, lherrou

My solution is similar to lherrou's:

First select the area you want to make transparent, if it is a pure colour you can use the colour selection tool with 0 fuzziness.
Then inverse the selection (ctrl+shift+I in win), so now you're selecting the areas you want to keep.
Then switch to the channels tab, and click the icon below which looks like a white circle in a box. (Should read "save selection as channel" if you hover your cursor over)
You can now save as a TGA file, ensure that "Alpha channels" is checked in the save dialog.

I think it's basically the same thing as what lherrou said, forgive me if i repeated (in that case lherrou should take full credit ^^) Good Luck!
0
 
LVL 38

Expert Comment

by:lherrou
ID: 17892299
Slightly different approach, but the result should be the same: a TGA with transparency in Alpha Channels :)
0
 

Author Comment

by:boll0kk
ID: 17914321
Hmm, when I go to Save As, then I select "Targa (*.TGA;etc)"  but the alpha channel box (and all other boxes) are fuzzed out! The boxes aren't fuzzed out if I try to save as any other extension, but it has to be a TGA unfortunately!

Here's a link to a screenshot of the problem:
http://www.imagefilez.com/out.php/i32879_uploadme.jpg

The file I'm opening is called "Untitled-1.bmp" and, after creating an alpha channel etc, I'm trying to save it as MyImage.tga. I also tried saving it as Untitled-1.psd, then saving it as a tga, but the boxes are still fuzzed out..!

Any help on this one? I've never got on with photoshop, I've always used much more intuitive pieces of software like Fireworks - its a shame though because photoshop has alot of power, but its very difficult to do what you wanna do unless you have a bloody degree in the software! :-P

Thanks :-)
0
 
LVL 38

Expert Comment

by:lherrou
ID: 17914440
How about saving it as another format which supports transparency (png, maybe) and then converting that file to Targa?
0
 
LVL 2

Assisted Solution

by:xqz
xqz earned 520 total points
ID: 17916133
Hi all

I'm suspecting your original BMP may be indexed not supporting transparency. Try switching image mode of your bmp file to RGB. Go to Image -> Mode -> RGB Colour

I don't have any experience with fireworks personally, so I can't give much advice on that one sorry...

Good luck!

0
 

Author Comment

by:boll0kk
ID: 17951548
Okay, to solve the problem:

Ctrl+A, then Edit->Copy

Then File->New and Ctrl->V

That puts the image into a blank PSD document, so like gets rid of the BMP info in the document....

Then use xgz's method, save as TGA and the checkbox should be unticked this time!

Hoorah :) Thanks
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Keep your audience engaged and get the most out of your next presentation with these quick Prezi tips.
Many programs have tried to outwit PowerPoint in terms of technology and skill. These programs, however, still lack several characteristics that PowerPoint has possessed from the start. Here's why PowerPoint replacements won't entirely work for desi…
HTML5 has deprecated a few of the older ways of showing media as well as offering up a new way to create games and animations. Audio, video, and canvas are just a few of the adjustments made between XHTML and HTML5. As we learned in our last micr…
Learn the basics of inputting and editing your text components in Prezi. We will cover how to set styles, position, and group your text components. In your Prezi editor, click anywhere on the canvas to add text: A flashing cursor informs you that yo…

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question