We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

RedHat Crontab fails to run at appropriate time

Henrybg
Henrybg asked
on
Medium Priority
240 Views
Last Modified: 2013-12-16
A few days ago, I noticed my cronjobs had stopped running. I have tried several solutions including cold reboot but all has been unsuccessful. What else in the world could cause this?

The only sensative change I know of is the adjustment of the time.  I inavertently changed the time using the desktop method of right clicking on the time and choosing the  "adjust time" option.

I also tried this on a vmware version of RedHat I have running on my laptop and the same thing happened. For some reason, the cronjobs apparently nolonger "know" what time it is. How can I undo this?

Thanks and regards,

Henry
Comment
Watch Question

Commented:
chekc to see if crond is running as a daemon. if not restart the service and see

service crond restart

chkconfig --list crond (this would tell you if crond or cron daemon is running at the current boot level)

If it is a daily / hourly script, then you might consider adding the script files to the /etc/cron.daily or /etc/cron.hourly subdirecotires and have the same run presuming the rest of the cron jobs are running satisfactorily.

see if your system date and the command "date" on a terminal window are retunring the same time.

changing the system date through gui or command line should have the same impact. so need not fear any loss or wanting to do a roll-back.

if your date command return s a bad date / time, then you can set it back with date -s xxxxxxxxx.  the xxxxxxxx can also be in the same format of the output that you receive from the "date" command. this will set your time right.

goutham

Author

Commented:
This problem still exists. I have rolled back the changes made and the cronjob now work. I still need to ensure that root signs on only at the console or via the su options. Any recommendations on this anyone?
Commented:
henrybg,

i am glad that your crontab now runs which i thought was the original problem. if a suggestion is given, then it is kind of prudent to repost the outcomes of the suggestion than keeping quiet.  we cannot fully reconstruct a problem and suggest the entire solution on a single post.

what you need right now is a stricter password control on the machine and even vigilant security measures in trying to curb off ssh and other means of gaining root access.  please read through /etc/ssh/sshd_config and /etc/ssh/ssh_config.  you can remove root from gaining ssh access and a user who has ssh can only do so with "sudo" or su.

next time onwards be enthusiastic about your own "query" than wait for miracles to happen by...

cheers

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Cyclops3590Sr Software Engineer
CERTIFIED EXPERT

Commented:
It has been another 32 days since the last comment, please give an update, accept an answer, or request the question to be closed.

Thank you.

Cyclops3590
EE Cleanup Volunteer
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.