We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

start kde on bootup of gentoo

dwcronin
dwcronin asked
on
Medium Priority
870 Views
Last Modified: 2013-12-15
Experts,
I have recently installed Gentoo on my computer.  I also have KDE.  When I boot up, I start at a command prompt.  I then type:

1) startx
2) startkde

to get kde up and running.  What do I have to do to start up in kde when I boot up so I don't have to type these lines?

Thanks,
Dan
Comment
Watch Question

nociSoftware Engineer
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
emerge xdm

see that xdm is started through rc-update add xdm default

als see to it that kdm is referenced:
in /etc/conf.d/xdm put:

DISPLAYMANAGER="xdm"

(this setting should be removed from /etc/rc.conf).
dwcronindisabled

Author

Commented:
Anything else?  I booted over to linux and did the things that you said.  It still doesn't start up with kde running. (!)  

Dan
you need to do the following:
login as root on your system
Create a backup of your /etc/inittab file by:
# cd /etc
# cp inittab inittab.backup

Then,
# vi /etc/inittab
Search for the line with:
x:3:once:
and change the 3 to 5.
This is for the graphical startup.
Save the file using :wq

After this your system would be able to start up with the graphical desktop.

Note the above steps work for Fedora Core 4, but for gentoo, please try them out.
nociSoftware Engineer
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Gentoo uses a VERY different startup from fedora....,
the boot phases are named boot (for minimum),
default for normal etc.

For gentoo this should be in your inittab (I expect it to be there)
----------------------
# Used by /etc/init.d/xdm to control DM startup.
# Read the comments in /etc/init.d/xdm for more
# info. Do NOT remove, as this will start nothing
# extra at boot if /etc/init.d/xdm is not added
# to the "default" runlevel.
x:a:once:/etc/X11/startDM.sh
----------------------

Are you up to date with all the modules???
There have been some changes in the setup of base-modules that
might influence things if not up to date.
To synchronize
------
emerge --sync               # to sync
emerge -vuaDN world         # to check and if you agree, Y ...
------

nociSoftware Engineer
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
I just noticed an error..,
it should be:

DISPLAYMANAGER="kdm"

And remove the line from /etc/rc.conf if there is a DISPLAYMANAGER= line..
(that is an old one)
nociSoftware Engineer
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Also check this setting in /etc/rc.conf
(it is the window manager, of choice to start)

XSESSION=kde-3.5
Software Engineer
CERTIFIED EXPERT
Distinguished Expert 2019
Commented:
(the -3.5 is assuming you have kde-3.5.x installed)

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.