mnttab error


We recently migrated from Solaris NIS Server to RH EL3. Binded all the Solaris and Linux clients. Automount is working but i get the below error while doing df -k in a automounted directory. I did fsck manually and cleaned up mnttanb but it doesn't help. Please advise.

gumani--root[22] df -k .
df: a line in /etc/mnttab has to many fields
gumani--root[23] uname -a
SunOS gumani 5.8 Generic_108528-19 sun4u sparc SUNW,Ultra-5_10

Who is Participating?
NukfrorConnect With a Mentor Commented:
Solaris 8 (without the x86 notation) means Solaris for SPARC chip based systems

Solaris 8 x86 means Solaris for Intel based systems.

The Alert Patch Cluster is smaller then the recommended.  Its just patches based on Sun published alerts for Solaris.  You should be the Recommended+Security Cluster.
rdashokrajAuthor Commented:

Is there any log file available for mnttab so as to check this error ?  /etc/mnttab looks like this.

# more /etc/mnttab
/dev/dsk/c0t0d0s0       /       ufs     rw,intr,largefiles,onerror=panic,suid,dev=2200000       1162145615
/proc   /proc   proc    dev=4580000     1162145614
fd      /dev/fd fd      rw,suid,dev=4640000     1162145616
mnttab  /etc/mnttab     mntfs   dev=4740000     1162145617
swap    /var/run        tmpfs   dev=1   1162145617
swap    /tmp    tmpfs   dev=2   1162145619
/dev/dsk/c0t0d0s3       /export ufs     rw,intr,largefiles,onerror=panic,suid,dev=2200003       1162145619
godavari:/vol/vol0/godavari08/local     /usr/local      nfs     intr,bg,dev=47c0001     1162145626
-hosts  /net    autofs  indirect,nosuid,ignore,nobrowse,dev=4800001     1162145627
auto_home       /home   autofs  indirect,ignore,nobrowse,dev=4800002    1162145627
-xfn    /xfn    autofs  indirect,ignore,dev=4800003     1162145627
auto.disks      /disks  autofs  indirect,ignore,dev=4800004     1162145627      /tools  autofs  indirect,ignore,dev=4800005     1162145627
auto.projects   /projects       autofs  indirect,ignore,dev=4800006     1162145627
-hard   /-         autofs  indirect,ignore,dev=4800007     1162145627
auto.proj       /proj   autofs  indirect,ignore,dev=4800008     1162145627
auto.misc       /misc   autofs  indirect,ignore,dev=4800009     1162145627
auto.users      /users  autofs  indirect,ignore,dev=480000a     1162145627
gumani:vold(pid260)     /vol    nfs     ignore,dev=47c0002      1162145634
kalyani:/export/home2/cds446MSR8        /tools/cds446MSR8       nfs     hard,dev=47c0005        1162145636
sutlej:/vol/datavol/sutlej06/sysadmin   /proj/sysadmin  nfs     hard,dev=47c0011        1162154084
rdashokrajAuthor Commented:
"mount" also gives this error. Please notice the last line.

# mount
/ on /dev/dsk/c0t0d0s0 read/write/setuid/intr/largefiles/onerror=panic/dev=2200000 on Sun Oct 29 23:44:35 2006
/proc on /proc read/write/setuid/dev=4580000 on Sun Oct 29 23:44:34 2006
/dev/fd on fd read/write/setuid/dev=4640000 on Sun Oct 29 23:44:36 2006
/etc/mnttab on mnttab read/write/setuid/dev=4740000 on Sun Oct 29 23:44:37 2006
/var/run on swap read/write/setuid/dev=1 on Sun Oct 29 23:44:37 2006
/tmp on swap read/write/setuid/dev=2 on Sun Oct 29 23:44:39 2006
/export on /dev/dsk/c0t0d0s3 read/write/setuid/intr/largefiles/onerror=panic/dev=2200003 on Sun Oct 29 23:44:39 2006
/usr/local on godavari:/vol/vol0/godavari08/local remote/read/write/setuid/intr/bg/dev=47c0001 on Sun Oct 29 23:44:46 2006
mount: line in mnttab has too many entries
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

check your /etc/vfstab, /etc/auto_direct /etc/auto_home files to make sure that there is NO WHITE space in the mount point dir name.

If you need more help please post your /etc/mnttab, /etc/vfstab, /etc/auto_direct and /etc/auto_home files
rdashokrajAuthor Commented:
Yuzh, I'm looking at the WHITE space now.  Below given the content of files you required. I have already posted /etc/mnttab.

bash-2.03# cat /etc/vfstab
#device         device          mount           FS      fsck    mount   mount
#to mount       to fsck         point           type    pass    at boot options
#/dev/dsk/c1d0s2 /dev/rdsk/c1d0s2 /usr          ufs     1       yes     -
fd      -       /dev/fd fd      -       no      -
/proc   -       /proc   proc    -       no      -
/dev/dsk/c0t0d0s1       -       -       swap    -       no      -
/dev/dsk/c0t0d0s0       /dev/rdsk/c0t0d0s0      /       ufs     1       no      -
/dev/dsk/c0t0d0s3       /dev/rdsk/c0t0d0s3      /export ufs     2       yes     -
swap    -       /tmp    tmpfs   -       yes     -
#remoted mounted drives
godavari:/vol/vol0/godavari08/local  -  /usr/local nfs    -    yes     intr,bg
bash-2.03# cat /etc/auto_master
# Master map for automounter
/net            -hosts          -nosuid,nobrowse
/home           auto_home       -nobrowse
/xfn            -xfn
bash-2.03# cat /etc/auto_home
# Home directory map for automounter

If you want to see if a white space is the problem, you should do a "view /etc/mnttab" and then input ":set list".  This will display TABS as "^T" symbols.  Spaces will show up as spaces.  The issue is with files like /etc/vfstab, /etc/auto_master and such are white space delimited already so looking for spaces in there is going to be somewhat fruitless as a space between fields is perfectly acceptable.

Anything found in /etc/mnttab has already been accepted by the kernel as a valid mount.  /etc/mnttab is a kernel created and maintained file.

I would start by doing a patch audit for your version of solaris.  Stuff that's accepted into /etc/mnttab by the kernel and then errored upon by tools that use the /etc/mnttab file (like df and mount) sounds like a bug to me.
yuzhConnect With a Mentor Commented:
I just notice that you have not apply the Solaris patch for a long time, apply the latest Solaris 8  Recommended Patch Clusters to see if it can fix it.
rdashokrajAuthor Commented:

I appreciate your valuable inputs on this issue. But unfortunately that day as we couldn't solve the problem, we escalated to our L3 support and they fixed it (Not sure what they have done). Btw as per your advice, I checked the solaris site to download the latest solaris 8 recommended patch clusters but bit confused what to download (I never done patch cluster installation). I'm seeing these 4 available downloads, which one to take ?
1. Solaris 8 Sun Alert Patch Cluster
2. Solaris 8
3. Solaris 8 x86 Sun Alert Patch Cluster
4. Solaris 8 x86       <--- What is this x86 refers to?

rdashokrajAuthor Commented:
Nukfor, Thanks for your explanation. I had this doubt for a long time but little hesitant to ask someone :)
rdashokrajAuthor Commented:
Yuzh,  Your suspicion is right. Its a space issue in vfstab. Our L3 support guys corrected the same. Thanks !!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.