Solved

IRQ Conflict, advice required...

Posted on 2006-10-29
23
970 Views
Last Modified: 2010-05-18
Hi,

Recently built a new machine:

Asus M2R32-MVP Crossfire (Socket AM2)
AMD Athlon 64 X2 Dual Core FX62 2.80GHz
Sapphire ATI Radeon X1950 XT-X SILENT Heatpipe 512MB GDDR4
2 x 36.6gb Raptor Western Digital Hard Drives in Raid 0
GeIL 2GB (2x1GB) PC6400C4 800MHz Ultra Low Latency DDR2 Dual Channel Kit
Creative Audigy 2 ZS PCI Soundcard

The soundcard is the only PCI device occupying 1 of the 2 PCI slots on the Motherboard. The Graphics card occupies PCI-E Slot 1, slot 2 is not occupied. When playing games every so often I get the Blue Screen of Death with an IRQL_DRIVER_NOT_LESS_OR_EQUAL. I ran the Windows debugging tool to find it is being caused by portcls.sys . I did a google search to find this was related to the soundcard but there were lots of possible reasons for the error. I checked the device manager to find that the Soundcard is sharing PCI IRQ 21 with the onboard Raid Controller with PCI IRQ 22 slot being occupied by the 1394 Host Controller which I don't actually require.

I have tried moving the soundcard to the other PCI slot to no avail as that then occupies PCI IRQ 23 which is the onboard Network card where I continued to get the same error.

I have read several articles with regards to IRQ but am none the wiser as to what I can do to rectify this problem. I believe if I reassign the Soundcard IRQ to PCI IRQ 22 after disabling the 1394 controller I will no longer get the error. Either that or I assign it to another IRQ, 1-23 are currently occupied.

Is there anyone who can tell me how I can achieve this as it is driving me mad at the moment, the machine crashes on a regular basis when running multimedia applications.

Thankyou

Regards
0
Comment
Question by:Ali_TR
  • 10
  • 4
  • 3
  • +3
23 Comments
 
LVL 13

Expert Comment

by:gonzal13
Comment Utility
I would remove the sound card and reboot the PC. Make sure that everything works and then reinstall the sound card. The reason behind this is that I ran into problems with my PC. It is a 24 in high unit with 5 PCI cards and 4 hard drives.

At the time I had problems with it I did not know much about computers. I had one built with everything that was on the market 10 years ago. Everytime something went wrong, I took it to the shop. The fixed the problem and when I brought it home I had another problem. Finally on time when I brought the PC in, the tech became my teacher. He said to remove every piece of hardware. He then said to install one at a time and test out the PC. I then continued it untill everything worked.

I still have the PC rather the 24 inch box which I have updated to the latest hardware less the PCI cards. I never had to go back to the store when my PC crashed.

Anyway just a suggestion.
0
 
LVL 13

Expert Comment

by:gonzal13
Comment Utility
http://support.microsoft.com/kb/316208/en-us

I took the note deleated the subscripts between the words and looked in Microsoft's database and found the above. It would not work with the subscripts
0
 

Author Comment

by:Ali_TR
Comment Utility
It isn't that particluar driver that the IRQL error is referring to, it can refer to many different drivers from what I have read. I ran the debug tool kit which I downloaded from Microsoft and checked the minidump files in the Windows system folder, all of them were relating to a soundcard driver. The problem isn't stopping me from booting up, just when my soundcard is used in some way, mainly gaming.

I have taken the card out and installed it in the only other PCI slot in the case which changed the IRQ from 23 to 21, it was sharing with the Network card before but now the Raid Controller. As I understand some IRQ's can be shared as long as they don't share requests at the same time, I feel with the fact I play games both on and offline is the reason behind the problem occuring with the IRQ shared between the onboard Network and the Raid Controller. If it was something different like a peripheral for a camera or some other 3rd party app I probably wouldn't get the conflict as they wouldn't request at the same time.

I should add I am running Windows XP Service Pack 2 with all the available updates, I have disabled any unnecessary resource hogs in the BIOS and also updated all hardware to run the latest drivers.
0
 

Author Comment

by:Ali_TR
Comment Utility
Oh and the Raid Controller is an ATi AHCI, latest drivers used for Windows installation.
0
 
LVL 11

Expert Comment

by:jimbecher
Comment Utility
Wow. Sharing IRQ's was one of the MAJOR advantages of PCI. Problems like you are having sound like the drivers aren't quite up to date. Have you downloaded the latest and greatest for all your devices? Especially the sound card?
0
 

Author Comment

by:Ali_TR
Comment Utility
Yeah all are bang up to date. I have reinstalled all the soundcard drivers since the initial installation after moving it to the other PCI slot.

It might be a case of me going down the wrong avenue on this, I just figured with it being a soundcard driver causing the error and with it being the only device sharing an IRQ that this was the root of the problem.

One of the other things I did change initially was the PCI Latency from the default 32 to 64 as I read this can sometimes increase performance in gaming with PCI devices that don't send lots of short requests on a continual basis.  I have changed this back to 32 earlier today but haven't played many games to see if this could've been part of the problem.

Trouble is the error has occurred after 5 minutes of playing and after 3 hours of playing, it's totally random which makes it really hard to test as I don't always want to sit and play games, usually stuff like Counter-Strike for 30 minutes here and there. I have ran system bench tests, 3DMark 03 and 05 which have yet to crash with an error which further adds to the frustration of finding out what exactly I am dealing with.
0
 
LVL 11

Expert Comment

by:jimbecher
Comment Utility
Yes. It is tough when the problem is intermittant. You might see if there is a BIOS upgrade for your mobo. I had the same problem with a network card a while ago and it was a problem with the BIOS. An upgrade did the trick ...
0
 
LVL 15

Expert Comment

by:venom96737
Comment Utility
Use everest to see what is taking up IRQ 5 that is the default IRQ for sound devices.  You can get that here http://www.majorgeeks.com/download4181.html
Your sound card should be getting assigned to IRQ 5 you should have a look to see what is taking up that space if nothing is then I would say that you have it assigned in the bios and should go have a look and unassign it.
0
 

Author Comment

by:Ali_TR
Comment Utility
IRQ 5 isn't in use.

I checked the BIOS late last night and the only PCI options I can change are Latency and a few to do with PCI VGA cards. The IRQ section is just a list of unused IRQ's where I can choose to reserve them, it doesn't specifcy with what devices, just an option to reserve.

With regards to the BIOS upgrade, there is one revision out however it does warn that it will not boot with certain DDR2 modules and the changes were more aesthetic than anything else so I stayed away from upgrading so far. I'll try flashing it this morning.
0
 
LVL 13

Expert Comment

by:ylandrum
Comment Utility
Don't know about your card, but some Creative Labs cards will let you choose an IRQ in Device Manager. My SB Live 5.1 is that way.
0
 
LVL 20

Expert Comment

by:cpc2004
Comment Utility
Hi Ali,

You mix up IRQ and IRQL. IRQ means interrupt request line and it is hardware. IRQLmeans Interrupt Request Level. IRQL and IRQ has no relation.  Your windows is crashed with bugcheck code 0A.

The formal explanation of 0x0000000A IRQL_NOT_LESS_OR_EQUAL
This bug check is issued if paged memory (or invalid memory) is accessed when the IRQL is higher than 2. The error that generates this bug check usually occurs after the installation of a faulty device driver, system service, or BIOS.  It may be related to faulty RAM. In order to find out whether the problem is related to faulty RAM or software problem, process the dump to find out why the memory incessible. If the storage does not exist, it is software problem. If the storage reference is valid, it is caused by faulty ram.

Bugcheck code 0A is usually related to hardware problem such as faulty ram or CPU.   The system event log and the minidump has the most useful diagnostic information. When Windows crashes with blue screen, it writes a system event 1001 or 1003 and a minidump to the folder \windows\minidump. Check system event 1001 and 1003 and it has the detail of the blue screen.

Event ID: 1001
Source: Save Dump
Description:
The computer has rebooted from a bugcheck.The bugcheck was : 0xc000000a (0xe1270188, 0x00000002, 0x00000000, 0x804032100).
Microsoft Windows..... A dump was saved in: .......

Event Source: System Error
Event Category: (102)
Event ID: 1003
Description:
Error code 1000007f, parameter1 0000000d, parameter2 00000000, parameter3 00000000, parameter4 00000000

Control Panel -> Adminstrative Tools -> Event Viewer -> System -> Event 1001/1003. Copy the content and paste it back here

Zip 5 to 6 minidumps to a zip file and attach it at any webspace. I will study the dump and find out the culprit. If you can't provide the minidumps, run memtest to stress test the ram. Make sure that your windows is not infected with spyware, adware adn chkdsk /r.
http://www.memtest86.com/.

Get public webspace
Use a free service like rapidshare to attach the minidumps and post the url of the mimidumps at this thread.
http://www.rapidshare.de/
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 

Author Comment

by:Ali_TR
Comment Utility
Thankyou. These are the latest files in the Event Viewer for Events 1001/1003.

Event 1001 from the Event Viewer:

The computer has rebooted from a bugcheck.  The bugcheck was: 0x100000d1 (0xff95ba2c, 0x00000008, 0x00000000, 0xba2caacc). A dump was saved in: C:\WINDOWS\Minidump\Mini102806-01.dmp.

Event 1003 from the Event Viewer:

Error code 00000044, parameter1 87e92b88, parameter2 00000d62, parameter3 00000000, parameter4 00000000.

I am unable to login to my own Webspace due to maintenance and the rapidshare thing is returning all drives are full. I will post below the code returned from the Windows Debugging tool for the latest error. All 4 files in the minidump folder reference portcls.sys as the probable cause. I understand IRQ and IRQL are different, it was just with this being a soundcard driver as the probable cause I just investigated everything I could within my knowledge to try and fix it, the IRQ conflict was the nearest I could get.

-------------------------------------------------------------------------------------------------------------------------------
Mini102806-01.dmp
-------------------------------------------------------------------------------------------------------------------------------

Microsoft (R) Windows Debugger  Version 6.6.0007.5
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\WINDOWS\Minidump\Mini102806-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*c:\symbols*http://msdl.microsoft.com/download/symbols
Executable search path is:
Windows XP Kernel Version 2600 (Service Pack 2) MP (2 procs) Free x86 compatible
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 2600.xpsp_sp2_gdr.050301-1519
Kernel base = 0x804d7000 PsLoadedModuleList = 0x8055c700
Debug session time: Sat Oct 28 19:27:33.171 2006 (GMT+0)
System Uptime: 0 days 0:36:12.875
Loading Kernel Symbols
..................................................................................................................................
Loading User Symbols
Loading unloaded module list
.............
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 100000D1, {ff95ba2c, 8, 0, ba2caacc}

Probably caused by : portcls.sys ( portcls!CInterruptSync::`vftable'+c )

Followup: MachineOwner

-------------------------------------------------------------------------------------------------------------------------------
0
 
LVL 20

Expert Comment

by:cpc2004
Comment Utility
Hi,

Windows 2000 or Windows XP has been installed in ACPI mode and that is how it assigns its plug and play resources. This is normal.  While most people experience no problems, other people can encounter some problems. Usually it's all assigned to IRQ9, sometimes IRQ11.  In theory,  this single IRQ is used as a gateway to 255 virtual IRQs above 15.  By allowing Windows 2000 to automatically assign your resources, you will not have to juggle IRQ assignments, which lets you install more devices that require IRQs than before. Windows 2000 uses ACPI to manage Plug and Play, device enumeration, the dynamic loading and unloading of drivers, and system power management. In addition, if your motherboard's chipset and BIOS fully support an IO-APIC, the ACPI HAL will allow the system to take advantage of hardware IRQs available above 15. This is especially important on dual processor systems.

These are not conflicts: this is IRQ sharing.  Most PCI devices, along with AGP video cards, are designed to accommodate and support IRQ sharing.

Refer the following web page
http://nvidia.custhelp.com/cgi-bin/nvidia.cfg/php/enduser/std_adp.php?p_faqid=53&p_created=1097087191&p_sid=dlo1F6sh&p_lva=&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX3Jvd19jbnQ9NCZwX3NlYXJjaF90eXBlPXNlYXJjaF9mbmwmcF9wcm9kX2x2bDE9JnBfY2F0X2x2bDE9JnBfcGFnZT0xJnBfc2VhcmNoX3RleHQ9SVJR&p_li=

Portcls is a stable module. Probably it is a ram problem.  Attach 5 to 6 minidumps at webspace for further problem diagnostic.
0
 

Author Comment

by:Ali_TR
Comment Utility
Thankyou.

My hosting is backup. I have zipped up the 4 minidump files in the minidump directory and they can be downloaded here:

http://www.brooklynblackout.net/minidumps/Mini102506-01.zip

Please let me know if you need any other information.
0
 
LVL 15

Expert Comment

by:venom96737
Comment Utility
Well your minidump tells you the same things you already know that you are having a problem with your SOUND driver lol.  Your sound card is still using the wrong IRQ it should be using IRQ 5 why in the world your system is throwing it over with to share with the raid controller is beyond me.  What is happening right now is the when the raid asks for an interupt to the cpu and the sound card ask for an inturrupt at the same time they crash together and cause the bsod.  Now you can only imagine that the raid is in almost constant use as is the network card.  Maybe you have an onboard soundcard that is not turned off on the motherboard? You need to get that sound card over ot IRQ 5 that is the default for sound and thats where it should be hitting from.  Just for the record IRQ 9 is cascaded with IRQ 2 it is also used for PCI steering 11 by default is just open.
0
 
LVL 11

Expert Comment

by:jimbecher
Comment Utility
Most BIOSs will let you manually set the IRQ by slot. Have you tried that?
0
 
LVL 15

Expert Comment

by:venom96737
Comment Utility
He should be able to do that same thing from the device manager just assign it to 5.
0
 
LVL 11

Expert Comment

by:jimbecher
Comment Utility
What he should be able to do and what he can do are sometimes two different things ....
0
 

Author Comment

by:Ali_TR
Comment Utility
Onboard sound is disabled in the BIOS, along with the FDD Controller etc so I just have the core things enabled.

The BIOS does not give the option to assign IRQ's, only reserve a select few IRQ slots for ISA devices so I haven't amended that.

I can't find anywhere in the Device Manager to where I can reassign a device to an unused IRQ, everything is either greyed out or in a none editable box. Do I need to boot in safe mode to do this? Any information on how I can change it in the Device Manager would be appreciated.
0
 

Author Comment

by:Ali_TR
Comment Utility
Just to add to that, I followed the help guide on how to change the Resource settings however the Change Settings tab is greyed out with the help  section giving a probable cause being that it is not a Plug and Play device.
0
 
LVL 20

Accepted Solution

by:
cpc2004 earned 500 total points
Comment Utility
Hi Ali,

The first minidump is crashed with bugcheck code with nt status 1d (ie illegal instruction) and it is the sign of hardware error (motherboard or ram). All of your minidumps are crashed at different instruction and it is also the symptom of hardware error. The seond and the last minidumps are crashed at IRQL 8 and it is the hadware IRQL. Crash at hardware IRQL is usually related to hardware error.  You had better run memtest to stress test the ram and upgrade the firmware of the motherboard.

Summary of minidumps
Mini102506-01.dmp BugCheck 1000008E, {c000001d, b9f17aca, 89bd0168, 0}
Probably caused by : portcls.sys ( portcls!CInterruptSync::`vftable'+a )
Crash instruction
b9f17aca f0b9d805f1b9    lock mov ecx,offset portcls!CInterruptSync::`vector deleting destructor' (b9f105d8)


Mini102506-02.dmp BugCheck 100000D1, {5d4cb995, 8, 1, b9950ac1}
Probably caused by : portcls.sys ( portcls!CInterruptSync::`vftable'+1 )
Crash Instruction
b9950ac1 a395b94c5d      mov     dword ptr ds:[5D4CB995h],eax


Mini102506-03.dmp BugCheck 44, {87e92b88, d62, 0, 0}
Probably caused by : Npfs.SYS ( Npfs!NpFastRead+68 )
Crash instruction
804f9c37 5d              pop     ebp

Mini102806-01.dmp BugCheck 100000D1, {ff95ba2c, 8, 0, ba2caacc}
Probably caused by : portcls.sys ( portcls!CInterruptSync::`vftable'+c )
Crash instruction
ba2caacc d8352cba95ff    fdiv    dword ptr ds:[0FF95BA2Ch] ds:0023:ff95ba2c=????????
0
 

Author Comment

by:Ali_TR
Comment Utility
Thankyou.

I have just updated to the latest BIOS revision which was released a few days a go. Fixes DDR2 issues from the Operating System not booting to general crashes in Windows.

One thing I did notice was prior to this version the RAM settings for 2T mode were Auto/Enabled/Disabled. When running Auto CPU-Z stated the RAm was running in 1T mode which I know for sure won't work at the optimal memory speeds for my RAM. Now with the update it just says 1T mode or 2T mode so you are forced to select.

Going to run MemTest 86 today and play some intense media applications over the weekend and see how it goes. I will post on Monday to let you know.

Thankyou for all your help so far.

Regards
0
 

Author Comment

by:Ali_TR
Comment Utility
Just to update I have had no further errors relating to this since over a week a go. Soundcard/Raid Controller/Network Controller all on their own IRQ now although that may not have been the cause.

Ran MemTest86 for 6 hours, passed 13 tests and failed 0 on both sticks of RAM and that was in 1T mode, I can't game in 1T mode as it looks like the tighter memory timings cause it to fall over and I get regular crashes. In 2T mode however everything appears to be running okay.

Thankyou for all your help.
0

Featured Post

Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

Join & Write a Comment

As the title indicates, I have done this before. It chills me everytime I update the OS on my phone, (http://www.experts-exchange.com/articles/18084/Upgrading-to-Android-5-0-Lollipop.html) because one time I did this and I essentially had a bricked …
I use more than 1 computer in my office for various reasons. Multiple keyboards and mice take up more than just extra space, they make working a little more complicated. Using one mouse and keyboard for all of my computers makes life easier. This co…
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now