Solved

Cannot connect with our pix to the outside after changing from classC to class B address

Posted on 2006-10-29
4
420 Views
Last Modified: 2010-04-09
We switched our network from Class C to Class B addressing.  Go a new  Cisco 5510.  That is working okay.  Had a linksys router for 2nd/cable modem line.  Moved old PIX to this line as Linksys does not support Class B Address.

What we need to do is connect  citrix and Blackberry enterprise server throught the cable modem line point to a single server.  172.16.0.42.  Have unlimited outgoing access from select workstations using this gateway. 172.16.1.3.  This is our configuration at this point.  We did not delete some of the old 192.168.1.2 items yet.  

We can ping the pix at 172.16.1.3 but cannot get any access to the outside nor access coming in from the outside to the 172.16.0.42 server.

We cannot determine what is missing as we compare the old config to the revised config.

Ports are needed for citrix 1494, 1495????, 1604 and 5993 for blackberry enterprise server.

We have been working on this for a while.  Thanks.

Cliff.

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxxxxr encrypted
hostname xxxx
domain-name xxxxxxxxxxx.com
fixup protocol dns maximum-length 1500
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit ip 172.16.0.0 255.255.0.0 172.16.0.0 255.255.0.0
access-list 100 permit ip 172.16.0.0 255.255.0.0 172.17.0.0 255.255.0.0
access-list fire permit icmp any any
access-list fire permit udp any host 206.176.219.45 eq 8008
access-list fire permit tcp any interface outside eq https
access-list fire permit tcp any interface outside eq www
access-list fire permit tcp any host 24.197.225.82 eq 1604
access-list fire permit udp any host 24.197.225.82 eq 1604
access-list fire permit tcp any host 24.197.225.82 eq citrix-ica
access-list fire permit udp any host 24.197.225.82 eq 1494
access-list fire permit tcp any host 24.197.225.82 eq 1495
access-list fire permit udp any host 24.197.225.82 eq 1495
access-list fire permit tcp any host 24.197.225.82 eq smtp
access-list fire permit tcp any host 24.197.225.82 eq 8008
access-list fire permit udp any host 24.197.225.82 eq 8008
access-list fire permit tcp any host 24.197.225.82 eq 8009
access-list fire permit udp any host 24.197.225.82 eq 8009
access-list fire permit tcp any host 24.197.225.82 eq 1677
access-list fire permit udp any host 24.197.225.82 eq 1677
access-list fire permit tcp any host 24.197.225.82 eq 1678
access-list fire permit udp any host 24.197.225.82 eq 1678
pager lines 24
logging monitor warnings
mtu outside 1500
mtu inside 1500
ip address outside 24.xxx.xxx.xx 255.255.255.252
ip address inside 172.16.1.3 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
ip local pool dhcppool 192.168.2.1-192.168.2.254
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 100
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 8008 192.168.1.2 8008 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 8008 192.168.1.2 8008 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 8009 192.168.1.2 8009 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 8009 192.168.1.2 8009 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 5639 192.168.1.40 5639 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 5639 192.168.1.40 5639 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 5640 192.168.1.40 5640 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 5640 192.168.1.40 5640 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface smtp 192.168.1.11 smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 1677 192.168.1.11 1677 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 1677 192.168.1.11 1677 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 1678 192.168.1.11 1678 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 1678 192.168.1.11 1678 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface https 192.168.1.11 https netmask 255.255.255.255 0 0
static (inside,outside) tcp interface www 192.168.1.11 www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 1604 172.16.0.42 1604 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 1604 172.16.0.42 1604 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface citrix-ica 172.16.0.42 citrix-ica netmask 255.255.255.255 0 0
static (inside,outside) udp interface 1494 172.16.0.42 1494 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 1495 172.16.0.42 1495 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 1495 172.16.0.42 1495 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 5993 172.16.0.42 5993 netmask 255.255.255.255 0 0
access-group fire in interface outside
route outside 0.0.0.0 0.0.0.0 24.197.225.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set aquavpn esp-des esp-md5-hmac
crypto dynamic-map dynmap 12 set transform-set aquavpn
crypto map newmap 12 ipsec-isakmp dynamic dynmap
crypto map newmap interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp identity address
isakmp keepalive 10
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
isakmp policy 12 authentication pre-share
isakmp policy 12 encryption des
isakmp policy 12 hash md5
isakmp policy 12 group 2
isakmp policy 12 lifetime 86400
vpngroup aqua address-pool dhcppool
vpngroup aqua split-tunnel 100
vpngroup aqua idle-time 9000
vpngroup aqua max-time 100000
vpngroup aqua password ********
vpngroup neavpn address-pool dhcppool
vpngroup neavpn split-tunnel 100
vpngroup neavpn idle-time 1800
vpngroup neavpn password ********
telnet 192.168.1.0 255.255.255.0 inside
telnet 172.16.0.0 255.255.0.0 inside
telnet timeout 30
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
vpnclient username xxxxxxx password ********
terminal width 80
Cryptochecksum:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
: end

0
Comment
Question by:cwsoft05
4 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 17830716
What is the default gateway of host 172.16.0.42?
 172.16.1.3 ?
No? then it must change.
Yes? then we look at other things...
 
>static (inside,outside) tcp interface 8008 192.168.1.2 8008 netmask 255.255.255.255 0 0
Are these statics to 192.168.1.x addresses still valid? If not, they should be removed.
0
 

Author Comment

by:cwsoft05
ID: 17831041
We wer able to answer our own question.  First, we are removing the obsolete 192.168.1.xxx addresses but under the time constraints it did not matter.  As for the answer.  172.16.1.3 is the default inside gateway.  The problem was in the route outside 0.0.0.0 0.0.0.0 24.197.225.1 1 line.  When we converted from the old connection to this connection, we converted our DSL's external gateway address to this address.  The prior gateway ended in .1 and we misinterpretted this as to also be .1 in our new cable connection.  It was a different number and was the gateway provided by the cable ISP.  When we deleted this improper number and added the correct gateway address, alll worked.
Thanks.
0
 
LVL 1

Accepted Solution

by:
kodiakbear earned 0 total points
ID: 17874146
Closed, 500 points refunded.
kb
Experts Exchange Moderator
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Suggested Solutions

If you are like regular user of computer nowadays, a good bet that your home computer is on right now, all exposed to world of Internet to be exploited by somebody you do not know and you never will. Internet security issues has been getting worse d…
The DROP (Spamhaus Don't Route Or Peer List) is a small list of IP address ranges that have been stolen or hijacked from their rightful owners. The DROP list is not a DNS based list.  It is designed to be downloaded as a file, with primary intention…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now