We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

OWALOGON.ASP Problems

montyjenkins
montyjenkins asked
on
Medium Priority
1,001 Views
Last Modified: 2008-01-09
Hi,

I have just installed Exchange 2003 Standard on a 2003 Advanced server today.   Exchange seems to be running fine so far, users are able to get into their mail.   I noticed this problem when I was enabling the FBA for use with our Thawte SSL cert.   I enabled FBA and also configured the Default site to use SSL along with the Exchange and Public Virtual directories.

When I go to test out the connection it fails.  It makes me use https, then prompts me to say ok for accepting the cert and then it says cannot find page.   If I try to go to the following link on the server  https://localhost/ExchWeb/bin/auth/owalogon.asp

This is with FBA enabled.  If I take off FBA and leave everything else as is then users are able to log in over OWA.   Very confused.    

Am running SP2 for Exchange as well.  
Comment
Watch Question

CERTIFIED EXPERT
Commented:
Does the file actually exist on your disk?  Have a look for
  Program Files\Exchsrvr\exchweb\bin\auth\owalogon.asp

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
I just checked and it is there.

CERTIFIED EXPERT

Commented:
Have a look at your current IIS log (in C:\Windows\System32\LogFiles\W3SVC1) in Notepad, and look for the lines that show the GET request for OWALOGON.ASP .  Can you paste them here?

Author

Commented:
Here is a log file entry.

2006-10-30 02:37:49 W3SVC1 xxx.xxx.xxx.xxx GET /exchweb/bin/auth/owalogon.asp url=https://mail.archrival.com/exchange/&reason=0 443 - x.x.x.x
Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.2;+SV1;+.NET+CLR+1.1.432
2;+.NET+CLR+2.0.50727) 404 2 1260

Author

Commented:
I did also check to make sure that the ASP componet is installed.
CERTIFIED EXPERT

Commented:
Have a look in IIS Manager, and click on the Web Service Extensions container in the left-hand pane.  Make sure that the status of Active Server Pages is 'Allowed' in the right-hand pane.

Author

Commented:
just verifed and all services are enabled.  here is a tid bit.

when users log off the owa they get an error saying page cannot be found for logoff.asp

I just don't get it.  I have double checked to make sure that ASP is installed and ASP is being allowed.
CERTIFIED EXPERT

Commented:
Every time I've seen 'Page not found' with a subcode of 2 (as shown in the IIS logs), then something somewhere was blocking ASP execution.  Can you find a URLScan.ini file on the server anywhere?  Also, is there an ISA server there?

Author

Commented:
I agree with the blocking of ASP because it just acts like anything you tell to open anything with .asp it says NOOPE.

No ISA server.  Just 2003 Enterprise server with Exchange 2003 server standard.

just did a complete search of all .ini files on the server and no URLScan.ini file.
CERTIFIED EXPERT

Commented:
So you tried http://servername/default.asp from the default web site?

Have a look at the properties of the Default Web Site, and click the Configuration button.  On 'Mappings', double-click the .asp extension - does it point to inetsrv\asp.dll ?  Is GET in the list of verbs?

Author

Commented:
There isn't a default.asp listed.  There is an iisstart.htm

I just checked the mappings and for .asp it says "C:\WINDOWS\system32\inetsrv\asp.dll"

Author

Commented:
I do have symantec corporate anti-virus v 10 with groupware for exchange loaded on the server, but I have the same setup loaded on other servers and haven't had a problem with that.  Just throwing it out there.
CERTIFIED EXPERT

Commented:
What value does the server have for this registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\OC Manager\Subcomponents\iis_asp

It should be a 0 or a 1

Author

Commented:
I think I found the problem.  I was showing a guy who is a programmer here the deal.  He was just as confused.

I ended up checking add/remove programs and I found this.

Under Application Server, IIS, World Wide Web Services I see an option for Active Server pages.  It wasn't checked.  I checked it, let the server do it's deal.  It's working now.

Am a little confused, but am glad it's working.  I had never gone that deep to check things in the past.


Thanks for all the advise, help!


Monty
CERTIFIED EXPERT

Commented:
That was what I suggested checking earlier (ASP subcomponent of IIS) :@)  Perhaps you checked the ASP.Net component by mistake - the two are easily confused.  Anyway, I'm glad it's working now.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.