We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you two Citrix podcasts. Learn about 2020 trends and get answers to your biggest Citrix questions!Listen Now

x

Help with port forwards

Computer_Smart_LTD
on
Medium Priority
1,078 Views
Last Modified: 2008-01-09
Hello

I have just installed 1 x Grandstream GXP-2000 VOIP Phone (Sipgate Service Provider) with some degree of success (See below for problems). However as this is my first experience with VOIP im a little confused about which ports to forward and what each port does. I don’t want to open a huge range of ports as that is a poor installation.

The router is a Netgear FVG318 & i have forwarded the following ports

TCP/UDP - 10000 : 10012 (I believe this is for network traversal, however i have turned it off on the phone as it didn’t want to work at all)
UDP - 5060 : 5062 (As far as im aware this port & the one below are for voice in and out, correct me if im wrong!)
UDP - 5004 : 5008
UDP - 30000 : 30021 (I have no idea what this port is for or if i need it)
TCP/UDP - 3478

The only ports i can see in the phones menu are 5004 in advanced settings 5060 Line 1 & 5062 line 2 all the other ports above are what i found on the Sipgate site. I find it very frustrating that the ports you need to forward aren’t just listed in the phones settings it seams that with VOIP there are a lot of hidden settings (Or is this just me)

Problems

If line one is put on hold then taken off all sound is lost then it loses the server. However line two (Separate Sipgate Account) is ok. Also it doesn’t seam to work all the time it’s too unreliable to be an office phone yet.

I would be greatful of any help.

Cheers



Andrew
Comment
Watch Question

CERTIFIED EXPERT

Commented:
The GXP-2000 is a good phone and I use about 30 of them in an office with very few problems. I suggest you go to their support site and download version 1.1.1.14 of the firmware as that is the latest and is stable.

The following ports need to be forwarded -
RTP - Look on the advanced settings for the 'local rtp port'. By default this is UDP/5004 (make sure random port is disabled)
SIP - By default this is 5060 but if you have more than one line configured additional lines may use 5062, 5064 etc... This port is show on the accounts page(s).

If you are still experiencing problems then I suggest you also configure a STUN server (on advanced tab) as this helps overcome problems introduced by some firewall.

SIP is used to setup and manage the calls. RTP is the protocol to actually send the voice.

Author

Commented:
Hi

Thanks for that, what router are you using for 30 phones & did you have to forward the ports to each phone?

Regards



Andrew
CERTIFIED EXPERT
Commented:
We have an Asterisk server so no ports need to be forwarded as the phones are on the same network as the server.
The Asterisk box has two network interfaces so it connects to the internal network where the phones are and the Internet so no NAT is required and this avoids any port forwarding issues.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts
Hey -
   Sipgate runs an SBC ( session border controller) ... i.e. no need to foward ports... nat transversal is done via ALG

Author

Commented:
Hi

Thanks for your help, Im now runing Axon PBX software.

Regards


Andrew
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.