?
Solved

VPN

Posted on 2006-10-30
7
Medium Priority
?
227 Views
Last Modified: 2013-11-16
Phase 1 completes - but debug at the other end says that my end has a proxy ip od 0.0.0.0 so trafic wont flow whats wrong

Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password jBC4QLwDeVyZqacL encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname EMAX
domain-name EMAX.LOCAL
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 172.16.173.0 Brighton-SN2
name <other end > Brighton-GW
name 172.16.172.0 Brighton-SN1
access-list inside_outbound_nat0_acl permit ip any Brighton-SN1 255.255.255.0
access-list inside_outbound_nat0_acl permit ip any Brighton-SN2 255.255.255.0
access-list outside_cryptomap_20 permit ip any Brighton-SN1 255.255.255.0
access-list outside_cryptomap_20 permit icmp any Brighton-SN1 255.255.255.0
access-list outside_cryptomap_20 permit ip any Brighton-SN2 255.255.255.0
access-list outside_cryptomap_20 permit icmp any Brighton-SN2 255.255.255.0
access-list inside_access_in permit ip any any
access-list inside_access_in permit icmp any any
access-list inbound permit icmp any any
pager lines 24
icmp permit any echo outside
mtu outside 1500
mtu inside 1500
ip address outside <this end outside > 255.255.255.0
ip address inside 172.16.174.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location Brighton-GW 255.255.255.255 outside
pdm location Brighton-SN1 255.255.255.0 outside
pdm location Brighton-SN2 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group inbound in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 217.22.144.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 172.16.174.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer Brighton-GW
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address Brighton-GW netmask 255.255.255.255 no-xauth no-config-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 172.16.174.2-172.16.174.254 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:30c5a081625c9369ae0df17d393907fa
: end
[OK]

0
Comment
Question by:Pete Long
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
7 Comments
 
LVL 57

Author Comment

by:Pete Long
ID: 17832991
in their debug it says

dest_proxy= 0.0.0.0/0.0.0.0/0/0 (type=4)

they say they dont support this and the cryptomap does not have the correct ACLs assigned to it this end?
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 2000 total points
ID: 17833147
Same issue that I pointed out in your other question...

>access-list outside_cryptomap_20 permit ip any Brighton-SN1 255.255.255.0
"any" = 0.0.0.0/0.0.0.0

Change to:
aaccess-list outside_cryptomap_20 permit ip 172.16.174.0 255.255.255.0 Brighton-SN1 255.255.255.0
0
 
LVL 57

Author Comment

by:Pete Long
ID: 17833604
Testing..................

Man I owe you a stack of beers if this works :)
0
Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

 
LVL 57

Author Comment

by:Pete Long
ID: 17833742
is that juset on the outside_cryptomap_20  ACL?

or do these bad boys need changing as well?

access-list inside_outbound_nat0_acl permit ip any Brighton-SN1 255.255.255.0
access-list inside_outbound_nat0_acl permit ip any Brighton-SN2 255.255.255.0
0
 
LVL 57

Author Comment

by:Pete Long
ID: 17833762
In fact obviously not cause it looks like the tunnels up .........................................
0
 
LVL 57

Author Comment

by:Pete Long
ID: 17835131
All is well in the world Cheers my friend :)

0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17836696
Yep, that's why we use two different acls for the crypto map and the nat_zero..

Glad you're working!
0

Featured Post

Four New Appliances. Same Industry-leading Speeds.

But don't take it from us.  The Firebox M370 is Miercom tested and Miercom approved, outperforming its competitors for stateless and stateful traffic throughput scenarios.  Learn more about the M370, M470, M570 and M670 and find the right solution for your organization today!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you are like regular user of computer nowadays, a good bet that your home computer is on right now, all exposed to world of Internet to be exploited by somebody you do not know and you never will. Internet security issues has been getting worse d…
The DROP (Spamhaus Don't Route Or Peer List) is a small list of IP address ranges that have been stolen or hijacked from their rightful owners. The DROP list is not a DNS based list.  It is designed to be downloaded as a file, with primary intention…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…
Suggested Courses
Course of the Month11 days, 18 hours left to enroll

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question