?
Solved

Logon script generating "no more endpoints from the endpoint mapper" error

Posted on 2006-10-30
8
Medium Priority
?
725 Views
Last Modified: 2013-11-14
I recently created and ran a logon script for my office network, which would stealth install a couple programs and map network drives to universal letters for the entire office. I used active directory from our server running Windows Server 2003 to export the logon script to the users, running Windows XP. It went off without a hitch for most users, but in two instances the users got the error "There are no more endpoints available from the endpoint mapper" when they log on. I've found a lot of links to troubleshooting sites and posts instructing people to use DC Diag on EE, but I haven't found anything to explain what the actual problem is. If anyone can tell me what is happening here, and how to fix it, it's worth 500 points.
0
Comment
Question by:SysAdmin06
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
8 Comments
 
LVL 14

Expert Comment

by:FriarTuk
ID: 17838528
0
 

Author Comment

by:SysAdmin06
ID: 17841704
I've seen that particular link on EE before, but it's not really helping. I would really like to know why I'm getting the error so it won't happen again. Appreciate the tip though.
0
 
LVL 14

Expert Comment

by:FriarTuk
ID: 17864772
not having any real knowledge of this type of issue, that was the most useful KB article I could find.  what is the exact error msg? what is shown in the event viewer?
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 
LVL 1

Expert Comment

by:DrJames99
ID: 17905258
Hi,

I'm having this issue myself... almost identical.  Login scripts which are implemented through Domain GPO's.    The dcdiag all return passed results, and it appears that everything within DNS is correctly configured.

The problem is that some Domain Users are having extremely long login times.  I have also tried removing the users from the domain, and re-adding them... and now I run into the "no more enpoints available from endpoint mapper" failure message.

You might want to download and check out GPMC (http://download.microsoft.com/download/a/d/b/adb5177d-01a7-4f04-bfcc-cb7cea8b5bb7/gpmc.msi ), which will allow you to easily locate and manage any additional or rogue GPO's which might exist within your domain.  These might be causing a conflict within your network as well.

Good luck.

DjEc
0
 

Author Comment

by:SysAdmin06
ID: 17938828
Thanks for the post DrJames99. That link looks promising. I'm currently swamped right now, and the login script is far from essential, so it's taken a back seat to my other little frustrations at the moment, but I'll try to dl and play with GPMC sometime this week and let you know how it goes.
0
 
LVL 1

Accepted Solution

by:
DrJames99 earned 2000 total points
ID: 17939482
Actually, I have resolved the problem.  In the end, it seems Win2K3 has different RPC protocols which are being used as Win2K.    Therefore, the requests were being filtered.  (you can determine this as well using the  portqry tool.)  In our case it was 1025 which was being dropped on the firewall between the DC's and the client.

Hopefully this helps you out in your quest to find an available endpoint ;-)

Cheers,
DjEc
0
 
LVL 1

Expert Comment

by:DrJames99
ID: 17946109
Additionally... if you are using Win2K3 with an updated SP1.  There are more issues that you can find here:

http://www.howtonetworking.com/Troubleshooting/2003sp1a.htm

hth
0
 

Author Comment

by:SysAdmin06
ID: 18028527
Thanks for the response and the excellent info!!
0

Featured Post

Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

cPanel is a Unix based web hosting control panel that provides a graphical interface and automation tools designed to simplify the process of hosting a web site. cPanel utilizes a 3 tier structure that provides functionality for administrators, rese…
For both online and offline retail, the cross-channel business is the most recent pattern in the B2C trade space.
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Suggested Courses

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question