We help IT Professionals succeed at work.

We've partnered with Certified Experts, Carl Webster and Richard Faulkner, to bring you a podcast all about Citrix Workspace, moving to the cloud, and analytics & intelligence. Episode 2 coming soon!Listen Now

x

auto logon script for machien

bbcac
bbcac asked
on
Medium Priority
286 Views
Last Modified: 2008-02-01
I have a machine that I setup via the registry to auto logon. It seems to work fine.

In active directory I configured that user to run a logon script.

THe computer automatically logs on fine, but it doesnt' run  the script.

I have the force auto logon value set as well so that if you logoff it automatically logs back on. If I do this then the script DOES run.

Why is that?
Comment
Watch Question

By default XP clients  do not wait to connect to the network before logging in to the computer.  A backround refresh of Group Policy is performed after network connection and some policies cannot be applied in the background (folder redirection, softing installation, roaming profiles, logon scripts, etc.).  To work around this apply the following policy to you autologon machines via GPO:

Computer Comfiguration > Administrative Templates > Syste, > Logon > Always Wait for the network before logon

Author

Commented:
good point... I should have mentioned that I have already tried this trick to no avail.
So you probable already have the following enabled also:

User Configuration > Administrative Templates > System > Scripts > Run Logon Scripts

Id so, other than running the scripts locally I'm out of ideas.

Author

Commented:
I dont' have that setting in my GP... besides, the script is running when i log off and log back on. Therefore it can run the script, just not on a reboot. Something else is funky I think. The problem is that for some reason on a restart its like the computer can't see the policy or the script. Any ideas?
Sorry about they delayed response.  I had to clear a blowup on one of my own networks.

I apparently lost all ability to type yesterday.  That policy should have been "Run Logon Scripts Synchronously" in the same location.

What account are you using to autologon the machine?  Is it a domain or local account?

If it's a local account you may want to try enabling the machine loopback policy and setting it to merge:

User Configuration > Administrative Templates > System > Group Policy > User Group Policy Processing Mode

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
It is not a local user... it is a domain user... the user is set to run the logon script in Active Directory. I'll try that local setting, just that this account/setup without that policy setting seems to work elsewhere.
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.