We help IT Professionals succeed at work.

Pop3 connector

superclyde
superclyde asked
on
Medium Priority
2,019 Views
Last Modified: 2013-03-11
Exchange 2003 6.5 with sp2
Exchange has been running great for 3 years...
Exchange crashed with no remorse Friday.  I reinstalled exchange.  Outgoing SMTP and internal e-mail is working fine.  We use an external POP3 server for our email.  Exhchange grab the mail and Distributes internally.  

It was working fine before the reload. Now, on the mail it gets from the external POP3 server, it is adding a prefix to the address and the mail is deemed undeliverable by the local exchange server.

it is adding the "mspop3connector". (see below)

The following recipient(s) could not be reached:

      mspop3connector.david@line-xindiana.com on 10/30/2006 2:31 PM
            The e-mail account does not exist at the organization this message was sent to.  Check the e-mail address, or contact the recipient directly to find out the correct address.

All help is greatly appreciated.
Comment
Watch Question

Commented:
Run IMBREG.exe from c:\program files\microsoft windows small business server\networking\pop3
Then do a IISReset.
Check if the problem is resolved.

Not the solution you were looking for? Getting a personalized solution is easy.

Ask the Experts

Author

Commented:
That was it.  What is that????  You da man!!!!  No Really, What is that "imbreg"?

Thanks a million!!

Commented:
No Worries.

IMBREG.exe is used to Re-register the POP3 Connector event sink in Microsoft Internet Information Services (IIS)
I had this problem, and we also excluded the following folders from AVG's scanning. I carried out both fixes so not sure which worked, but the problem seems to have been resolved.

Fix 2.
Adjust AVG or other anti-virus scanning to exclude the folders below
C:\Program Files\Microsoft Windows Small Business Server\Networking\POP3\Incoming mail\
C:\Program Files\Microsoft Windows Small Business Server\Networking\POP3\Failed mail\
C:\Program Files\Exchsrvr\
D:\Exchsrvr\

Use the above in the Exception list for AVG Resident shield settings, but also for any other scans
In AVG Scan set up scheduled scan for C: and D: then exclude the POP3 folder in the above two paths. and the two exchsrv folders.
Update to my previous post: Wheere I list
C:\Program Files\Exchsrvr\
D:\Exchsrvr\
The point is to exclude any of the servers exchsrv folders, you may only have the:
C:\Program Files\Exchsrvr\ on your server.
I have done both of the above but problem is still there it works for a while to run imbreg.exe and then  a while later the problem is back.Server is SBS 2003 Prem.

The receiving user is on the local network and the sending user is on vpn connection to server and yet it still returns as follow  mspop3connector.user@domain.co.za.

Could anybody assist please?
Access more of Experts Exchange with a free account
Thanks for using Experts Exchange.

Create a free account to continue.

Limited access with a free account allows you to:

  • View three pieces of content (articles, solutions, posts, and videos)
  • Ask the experts questions (counted toward content limit)
  • Customize your dashboard and profile

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.