• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 195
  • Last Modified:

In compatibility problems

We are trying to migrate applications from one server to another in Apache.

one server(x1) running apache 1.3  and another server(x2) running apache 2.0
1.3 apache version doesnt have any mod rewrite function, but 2.0 apache version
has mod rewrite function.

when we forward all the pages from one server (x2) to (x1) redirect works just fine,
but when we redirect pages from x1 to x2 redirect doesnt work.

please provide suggestions..

The following inquiries are in regards to mod_rewrite running on apache 1.3:

1.  Need to determine if the module is loaded.

2.  Need to load it if it is not already loaded.

3.  If it is already loaded, need to know how to activate it.

1 Solution
shihabfAuthor Commented:
any one could answer
to know which module are compiled in Apache1.3 you can invoke from command line:
/usr/local/apache/bin/httpd -l (or on windows C:\apache\apache.exe -l)

If module is not the list you need to recompile apache with additional option:
--enable-module=rewrite (see http://httpd.apache.org/docs/1.3/install.html for details about compilation and installation)

once module is installed then you can start using it by adding following lines:

RewriteEngine  on
RewriteRule ....

more detailed info about mod rewrite and url rewritig guides are on
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now